]> git.pld-linux.org Git - packages/Tktable.git/blob - Tktable.spec
- pl
[packages/Tktable.git] / Tktable.spec
1 %define         tkver   8.4
2 #
3 Summary:        TkTable - a table/matrix widget extension to Tcl/Tk
4 Summary(pl.UTF-8):      TkTable - rozszerzenie Tcl/Tk o widget tabeli/macierzy
5 Name:           Tktable
6 Version:        2.9
7 Release:        1
8 License:        BSD
9 Group:          Development/Languages/Tcl
10 Source0:        http://dl.sourceforge.net/tktable/%{name}%{version}.tar.gz
11 # Source0-md5:  a91cac4270a0c46945723d8f5106e80b
12 Patch0:         %{name}-pkg_lib_file.patch
13 URL:            http://tktable.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  tk-devel >= %{tkver}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _ulibdir        /usr/lib
19
20 %description
21 TkTable is a table/matrix widget extension to Tcl/Tk.
22
23 The basic features of the widget are:
24  * multi-line cells
25  * support for embedded windows (one per cell)
26  * row & column spanning
27  * variable width columns / height rows (interactively resizable)
28  * row and column titles
29  * multiple data sources ((Tcl array || Tcl command) &| internal
30    caching)
31  * supports standard Tk reliefs, fonts, colors, etc.
32  * x/y scrollbar support
33  * 'tag' styles per row, column or cell to change visual appearance
34  * in-cell editing - returns value back to data source
35  * support for disabled (read-only) tables or cells (via tags)
36  * multiple selection modes, with "active" cell
37  * multiple drawing modes to get optimal performance for larger tables
38  * optional 'flashes' when things update
39  * cell validation support
40  * Works everywhere Tk does (including Windows and Mac!)
41  * Unicode support (Tk 8.1+)
42
43 %description -l pl.UTF-8
44 TkTable to rozszerzenie Tcl/Tk o widget tabeli/macierzy.
45
46 Główne możliwości widgetu to:
47  - komórki wieloliniowe
48  - obsługa wbudowanych okienek (jedno w komórce)
49  - komórki obejmujące kilka wierszy lub kolumn
50  - wiele źródeł danych ((tablica Tcl || polecenie Tcl) &| wewnętrzna
51    pamięć podręczna)
52  - obsługa standardowych styli, fontów, kolorów itp. Tk
53  - poziomy i pionowy pasek przewijania
54  - style dla wierszy, kolumn lub komórek zmieniające wygląd
55  - edycja wewnątrz komórki - zwracająca wartości do źródła danych
56  - obsługa wyłączonych (tylko do odczytu) tabel lub komórek
57  - wiele trybów wyboru z "aktywną" komórką
58  - wiele trybów rysowania w celu uzyskania optymalnej wydajności dla
59    większych tabel
60  - opcjonalne "błyski" przy uaktualnianiu elementów
61  - kontrola poprawności komórek
62  - działanie wszędzie tam, gdzie Tk (włącznie z Windows i Mac OS-em)
63  - obsługa Unicode (Tk 8.1+)
64
65 %package devel
66 Summary:        TkTable - development files
67 Summary(pl.UTF-8):      TkTable - pliki programistyczne
68 Group:          Development/Languages/Tcl
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       tk-devel >= %{tkver}
71
72 %description devel
73 TkTable development files.
74
75 %description devel -l pl.UTF-8
76 Pliki programistyczne TkTable.
77
78 %package demo
79 Summary:        TkTable - demo programs
80 Summary(pl.UTF-8):      Programy demonstracyjne TkTable
81 Group:          Development/Languages/Tcl
82 Requires:       %{name} = %{version}-%{release}
83
84 %description demo
85 TkTable demo programs.
86
87 %description demo -l pl.UTF-8
88 Programy demonstracyjne TkTable.
89
90 %prep
91 %setup -q -n %{name}%{version}
92 %patch0 -p1
93
94 %build
95 %{__autoconf}
96 %configure
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_includedir},%{_mandir},%{_ulibdir}}
103
104 %{__make} install \
105          DESTDIR=$RPM_BUILD_ROOT
106
107 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}%{version}/html
108 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}%{version}/*.txt
109
110 mv $RPM_BUILD_ROOT%{_libdir}/%{name}%{version}/lib%{name}%{version}.so $RPM_BUILD_ROOT%{_libdir}
111
112 %if "%{_libdir}" != "%{_ulibdir}"
113 mv $RPM_BUILD_ROOT%{_libdir}/%{name}%{version} $RPM_BUILD_ROOT%{_ulibdir}
114 # FIXME: this shouldn't be done
115 ln -sf %{_libdir}/lib%{name}%{version}.so $RPM_BUILD_ROOT%{_ulibdir}/lib%{name}%{version}.so
116 %endif
117
118 ln -sf lib%{name}%{version}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
119
120 install -d $RPM_BUILD_ROOT%{_mandir}/mann
121 install doc/*.n $RPM_BUILD_ROOT%{_mandir}/mann
122
123 install generic/tkTable.h $RPM_BUILD_ROOT%{_includedir}
124
125 cp -a demos $RPM_BUILD_ROOT%{_ulibdir}/%{name}%{version}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README.txt README.blt TODO.txt UPGRADING.txt license.txt
136 %attr(755,root,root) %{_libdir}/lib%{name}%{version}.so
137 %dir %{_ulibdir}/%{name}%{version}
138 %{_ulibdir}/%{name}%{version}/*.tcl
139 %if "%{_libdir}" != "%{_ulibdir}"
140 # FIXME: this shouldn't be done
141 %{_ulibdir}/lib*%{version}.so
142 %endif
143 %{_mandir}/mann/*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_libdir}/lib%{name}.so
148 %{_includedir}/*
149
150 %files demo
151 %defattr(644,root,root,755)
152 %{_ulibdir}/%{name}%{version}/demos
This page took 0.065484 seconds and 3 git commands to generate.