]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- added desktop patch
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         xfce_version    4.4.0
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        0.8.0
10 Release:        2
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
14 # Source0-md5:  9f7b0945d6a235391049f6818fb4d188
15 Patch0:         %{name}-desktop.patch
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  GConf2-devel >= 2.16.0
18 BuildRequires:  dbus-glib-devel >= 0.62
19 # XXX: gamin (>= 0.1.0) is preferred over fam
20 BuildRequires:  fam-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.12.4
23 BuildRequires:  gtk+2-devel >= 2:2.10.6
24 BuildRequires:  gtk-doc >= 1.7
25 BuildRequires:  hal-devel >= 0.5.7
26 BuildRequires:  intltool
27 BuildRequires:  libexif-devel >= 0.6.13
28 BuildRequires:  libexo-devel >= 0.3.2
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel >= 1.2.12
31 BuildRequires:  libxfce4util-devel >= %{xfce_version}
32 BuildRequires:  pcre-devel >= 6.0
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.311
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
38 Requires(post,postun):  desktop-file-utils
39 Requires(post,postun):  gtk+2
40 Requires(post,postun):  hicolor-icon-theme
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       hal >= 0.5.7
43 Requires:       libexo >= 0.3.2
44 Requires:       shared-mime-info >= 0.15
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Thunar is a modern file manager, aiming to be easy-to-use and fast.
49
50 %description -l pl.UTF-8
51 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
52 szybkość użycia.
53
54 %package apidocs
55 Summary:        Thunar API documentation
56 Summary(pl.UTF-8):      Dokumentacja API Thunar
57 Group:          Documentation
58 Requires:       gtk-doc-common
59
60 %description apidocs
61 Thunar API documentation.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API Thunar.
65
66 %package libs
67 Summary:        Thunar libraries
68 Summary(pl.UTF-8):      Biblioteki Thunar
69 Group:          Libraries
70
71 %description libs
72 Thunar libraries.
73
74 %description libs -l pl.UTF-8
75 Biblioteki Thunar.
76
77 %package devel
78 Summary:        Header files for Thunar libraries
79 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
80 Group:          Development/Libraries
81 Requires:       %{name}-libs = %{version}-%{release}
82 Requires:       GConf2-devel >= 2.16.0
83 Requires:       dbus-glib-devel >= 0.62
84 Requires:       fam-devel
85 Requires:       hal-devel >= 0.5.7
86 Requires:       libexo-devel >= 0.3.2
87 Requires:       libjpeg-devel
88
89 %description devel
90 This is the package containing the header files for Thunar libraries.
91
92 %description devel -l pl.UTF-8
93 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
94
95 %package static
96 Summary:        Static Thunar libraries
97 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 Static Thunar libraries.
103
104 %description static -l pl.UTF-8
105 Statyczne biblioteki Thunar.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 %configure \
113         --enable-dbus \
114         --enable-exif \
115         --enable-gnome-thumbnailers \
116         --enable-gtk-doc \
117         --enable-pcre \
118         --enable-startup-notification \
119         --with-html-dir=%{_gtkdocdir} \
120         %{?with_static_libs:--enable-static}
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
131
132 %find_lang %{name} --all-name
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 %update_desktop_database_post
139 %update_icon_cache hicolor
140
141 %postun
142 %update_desktop_database_postun
143 %update_icon_cache hicolor
144
145 %post   libs -p /sbin/ldconfig
146 %postun libs -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README THANKS TODO
151 %attr(755,root,root) %{_bindir}/*
152 %dir %{_sysconfdir}/xdg/Thunar
153 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
154 %attr(755,root,root) %{_libdir}/ThunarBulkRename
155 %attr(755,root,root) %{_libdir}/ThunarHelp
156 %attr(755,root,root) %{_libdir}/thunar-vfs-*
157 %attr(755,root,root) %{_libdir}/thunar-sendto-email
158 %dir %{_libdir}/thunarx-1
159 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
160 %attr(755,root,root) %{_libdir}/xfce4/panel-plugins/thunar-tpa
161
162 %{_datadir}/Thunar
163 %{_datadir}/xfce4/panel-plugins/*.desktop
164 %{_datadir}/dbus-1/services/*.service
165 %{_desktopdir}/*.desktop
166 %{_iconsdir}/hicolor/*/*/*
167 %{_pixmapsdir}/Thunar
168 %{_mandir}/man1/Thunar*
169
170 # FIXME: maybe it's common dir?
171 %dir %{_datadir}/thumbnailers
172 %{_datadir}/thumbnailers/*.desktop
173
174 %dir %{_docdir}/Thunar
175 # move it to proper place
176 %{_docdir}/Thunar/README*
177
178 %dir %{_docdir}/Thunar/html
179 %{_docdir}/Thunar/*.txt
180 %{_docdir}/Thunar/html/C
181 %{_docdir}/Thunar/html/*.css
182 %lang(es) %{_docdir}/Thunar/html/es
183 %lang(eu) %{_docdir}/Thunar/html/eu
184 %lang(fr) %{_docdir}/Thunar/html/fr
185 %lang(ja) %{_docdir}/Thunar/html/ja
186 %lang(pl) %{_docdir}/Thunar/html/pl
187 %lang(ru) %{_docdir}/Thunar/html/ru
188 %lang(zh_TW) %{_docdir}/Thunar/html/zh_TW
189
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/thunar*
193
194 %files libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/lib*.so.*.*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/lib*.so
201 %{_libdir}/lib*.la
202 %{_includedir}/thunar*
203 %{_pkgconfigdir}/*.pc
204
205 %if %{with static_libs}
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/*.a
209 %endif
This page took 0.054852 seconds and 3 git commands to generate.