]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
noarch apidocs
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 %define         xfce_version    4.10.0
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        1.6.2
10 Release:        3
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://archive.xfce.org/src/xfce/thunar/1.6/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a446103ab90855cc8ba484dfeedb82d8
15 Patch0:         %{name}-desktop.patch
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.8
19 BuildRequires:  dbus-glib-devel >= 0.62
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  exo-devel >= 0.10.0
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 1:2.18.0
24 BuildRequires:  gtk+2-devel >= 2:2.14.0
25 BuildRequires:  gtk-doc >= 1.7
26 BuildRequires:  intltool
27 BuildRequires:  libexif-devel >= 0.6.0
28 BuildRequires:  libnotify-devel >= 0.4.0
29 BuildRequires:  libtool
30 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
31 BuildRequires:  libxfce4util-devel >= %{xfce_version}
32 BuildRequires:  pcre-devel >= 6.0
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.601
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  udev-glib-devel >= 145
38 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
39 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
40 Requires(post,postun):  desktop-file-utils
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       exo >= 0.8.0
43 Requires:       gtk-update-icon-cache
44 Requires:       hicolor-icon-theme
45 Requires:       shared-mime-info >= 0.15
46 Requires:       xfconf >= %{xfce_version}
47 Suggests:       tumbler
48 Obsoletes:      Thunar-thumbnailers
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Thunar is a modern file manager, aiming to be easy-to-use and fast.
53
54 %description -l pl.UTF-8
55 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
56 szybkość użycia.
57
58 %package apidocs
59 Summary:        Thunar API documentation
60 Summary(pl.UTF-8):      Dokumentacja API Thunar
61 Group:          Documentation
62 Requires:       gtk-doc-common
63 Obsoletes:      thunar-vfs-apidocs
64 %if "%{_rpmversion}" >= "5"
65 BuildArch:      noarch
66 %endif
67
68 %description apidocs
69 Thunar API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API Thunar.
73
74 %package libs
75 Summary:        Thunar libraries
76 Summary(pl.UTF-8):      Biblioteki Thunar
77 Group:          X11/Libraries
78 Obsoletes:      thunar-vfs
79
80 %description libs
81 Thunar libraries.
82
83 %description libs -l pl.UTF-8
84 Biblioteki Thunar.
85
86 %package devel
87 Summary:        Header files for Thunar libraries
88 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-libs = %{version}-%{release}
91 Requires:       exo-devel >= 0.6.0
92 Requires:       gtk+2-devel >= 2:2.14.0
93 Obsoletes:      thunar-vfs-devel
94
95 %description devel
96 This is the package containing the header files for Thunar libraries.
97
98 %description devel -l pl.UTF-8
99 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
100
101 %package static
102 Summary:        Static Thunar libraries
103 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
104 Group:          X11/Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Obsoletes:      thunar-vfs-static
107
108 %description static
109 Static Thunar libraries.
110
111 %description static -l pl.UTF-8
112 Statyczne biblioteki Thunar.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
119
120 %build
121 %{__gtkdocize}
122 %{__intltoolize}
123 %{__libtoolize}
124 %{__aclocal}
125 %{__automake}
126 %{__autoheader}
127 %{__autoconf}
128 %configure \
129         --enable-dbus \
130         --enable-exif \
131         --enable-gtk-doc \
132         --enable-pcre \
133         --enable-startup-notification \
134         --with-html-dir=%{_gtkdocdir} \
135         %{?with_static_libs:--enable-static} \
136         --disable-silent-rules
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/thunarx-2/*.{a,la}
146 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xfce4/panel/plugins/*.{a,la}
147 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
148
149 # duplicate of ur
150 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
151
152 %find_lang %{name} --all-name
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 %update_desktop_database_post
159 %update_icon_cache hicolor
160
161 %postun
162 %update_desktop_database_postun
163 %update_icon_cache hicolor
164
165 %post   libs -p /sbin/ldconfig
166 %postun libs -p /sbin/ldconfig
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README THANKS TODO
171 %attr(755,root,root) %{_bindir}/*
172 %dir %{_sysconfdir}/xdg/Thunar
173 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
174 %dir %{_libdir}/Thunar
175 %attr(755,root,root) %{_libdir}/Thunar/ThunarBulkRename
176 %attr(755,root,root) %{_libdir}/Thunar/thunar-sendto-email
177 %dir %{_libdir}/thunarx-2
178 %attr(755,root,root) %{_libdir}/thunarx-2/*.so
179 %attr(755,root,root) %{_libdir}/xfce4/panel/plugins/libthunar-tpa.so
180
181 %{_datadir}/Thunar/sendto/*.desktop
182 %{_datadir}/xfce4/panel-plugins/*.desktop
183 %{_datadir}/dbus-1/services/*.service
184 %{_desktopdir}/*.desktop
185 %{_iconsdir}/hicolor/*/*/*
186 %{_pixmapsdir}/Thunar
187 %{_mandir}/man1/Thunar*
188
189 %dir %{_docdir}/Thunar
190 # move it to proper place
191 %{_docdir}/Thunar/README*
192
193 %files apidocs
194 %defattr(644,root,root,755)
195 %{_gtkdocdir}/thunarx
196
197 %files libs
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libthunarx-2.so.*.*.*
200 %attr(755,root,root) %ghost %{_libdir}/libthunarx-2.so.0
201
202 %files devel
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/libthunarx-2.so
205 %{_includedir}/thunarx-2
206 %{_pkgconfigdir}/thunarx-2.pc
207
208 %if %{with static_libs}
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/libthunarx-2.a
212 %endif
This page took 0.098988 seconds and 3 git commands to generate.