]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- cleanup
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         xfce_version    4.10.0
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        1.4.0
10 Release:        1
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://archive.xfce.org/src/xfce/thunar/1.4/%{name}-%{version}.tar.bz2
14 # Source0-md5:  737ad2c36ed36b10fef82e860b9e990a
15 Patch0:         %{name}-desktop.patch
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.8
19 BuildRequires:  dbus-glib-devel >= 0.62
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  exo-devel >= 0.8.0
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 1:2.18.0
24 BuildRequires:  gtk+2-devel >= 2:2.14.0
25 BuildRequires:  gtk-doc >= 1.7
26 BuildRequires:  intltool
27 BuildRequires:  libexif-devel >= 0.6.0
28 BuildRequires:  libnotify-devel >= 0.4.0
29 BuildRequires:  libtool
30 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
31 BuildRequires:  libxfce4util-devel >= %{xfce_version}
32 BuildRequires:  pcre-devel >= 6.0
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.601
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  udev-glib-devel >= 145
38 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
39 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
40 Requires(post,postun):  desktop-file-utils
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       exo >= 0.8.0
43 Requires:       gtk-update-icon-cache
44 Requires:       hicolor-icon-theme
45 Requires:       shared-mime-info >= 0.15
46 Requires:       xfconf >= %{xfce_version}
47 Suggests:       tumbler
48 Obsoletes:      Thunar-thumbnailers
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Thunar is a modern file manager, aiming to be easy-to-use and fast.
53
54 %description -l pl.UTF-8
55 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
56 szybkość użycia.
57
58 %package apidocs
59 Summary:        Thunar API documentation
60 Summary(pl.UTF-8):      Dokumentacja API Thunar
61 Group:          Documentation
62 Requires:       gtk-doc-common
63 Obsoletes:      thunar-vfs-apidocs
64
65 %description apidocs
66 Thunar API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API Thunar.
70
71 %package libs
72 Summary:        Thunar libraries
73 Summary(pl.UTF-8):      Biblioteki Thunar
74 Group:          X11/Libraries
75 Obsoletes:      thunar-vfs
76
77 %description libs
78 Thunar libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki Thunar.
82
83 %package devel
84 Summary:        Header files for Thunar libraries
85 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
86 Group:          X11/Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       exo-devel >= 0.6.0
89 Requires:       gtk+2-devel >= 2:2.14.0
90 Obsoletes:      thunar-vfs-devel
91
92 %description devel
93 This is the package containing the header files for Thunar libraries.
94
95 %description devel -l pl.UTF-8
96 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
97
98 %package static
99 Summary:        Static Thunar libraries
100 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
101 Group:          X11/Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Obsoletes:      thunar-vfs-static
104
105 %description static
106 Static Thunar libraries.
107
108 %description static -l pl.UTF-8
109 Statyczne biblioteki Thunar.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 %{__gtkdocize}
117 %{__intltoolize}
118 %{__libtoolize}
119 %{__aclocal}
120 %{__automake}
121 %{__autoheader}
122 %{__autoconf}
123 %configure \
124         --enable-dbus \
125         --enable-exif \
126         --enable-gtk-doc \
127         --enable-pcre \
128         --enable-startup-notification \
129         --with-html-dir=%{_gtkdocdir} \
130         %{?with_static_libs:--enable-static} \
131         --disable-silent-rules
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/thunarx-2/*.{a,la}
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xfce4/panel/plugins/*.{a,la}
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
144
145 # duplicate of ur
146 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
147
148 %find_lang %{name} --all-name
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 %update_desktop_database_post
155 %update_icon_cache hicolor
156
157 %postun
158 %update_desktop_database_postun
159 %update_icon_cache hicolor
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog NEWS README THANKS TODO
167 %attr(755,root,root) %{_bindir}/*
168 %dir %{_sysconfdir}/xdg/Thunar
169 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
170 %dir %{_libdir}/Thunar
171 %attr(755,root,root) %{_libdir}/Thunar/ThunarBulkRename
172 %attr(755,root,root) %{_libdir}/Thunar/thunar-sendto-email
173 %dir %{_libdir}/thunarx-2
174 %attr(755,root,root) %{_libdir}/thunarx-2/*.so
175 %attr(755,root,root) %{_libdir}/xfce4/panel/plugins/libthunar-tpa.so
176
177 %{_datadir}/Thunar
178 %{_datadir}/xfce4/panel-plugins/*.desktop
179 %{_datadir}/dbus-1/services/*.service
180 %{_desktopdir}/*.desktop
181 %{_iconsdir}/hicolor/*/*/*
182 %{_pixmapsdir}/Thunar
183 %{_mandir}/man1/Thunar*
184
185 %dir %{_docdir}/Thunar
186 # move it to proper place
187 %{_docdir}/Thunar/README*
188
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/thunarx
192
193 %files libs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libthunarx-2.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libthunarx-2.so.0
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libthunarx-2.so
201 %{_includedir}/thunarx-2
202 %{_pkgconfigdir}/thunarx-2.pc
203
204 %if %{with static_libs}
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/libthunarx-2.a
208 %endif
This page took 0.093971 seconds and 3 git commands to generate.