]> git.pld-linux.org Git - packages/TORCS.git/blob - TORCS.spec
- use release > 1
[packages/TORCS.git] / TORCS.spec
1 # ToDo:
2 # - make it compile - this one is horrible, it creates exports/include dir
3 #   in top source directory and puts symlinks to various *.h files there.
4 #   However, it does not put symlinks to plib/*.h or GL/*.h. Anyone knows
5 #   how to fix it? Or maybe this one should be removed from repo?
6 Summary:        The Open Racing Car Simulator
7 Summary(pl):    The Open Racing Car Simulator
8 Name:           TORCS
9 Version:        1.2.0
10 Release:        0.1
11 License:        GPL     
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/torcs/%{name}-%{version}-src.tgz
14 Source1:        http://dl.sourceforge.net/torcs/%{name}-%{version}-src-robots-base.tgz
15 Source2:        http://dl.sourceforge.net/torcs/%{name}-%{version}-src-robots-berniw.tgz
16 Source3:        http://dl.sourceforge.net/torcs/%{name}-%{version}-src-robots-K1999.tgz
17 Source4:        http://dl.sourceforge.net/torcs/%{name}-%{version}-data.tgz
18 Source5:        http://dl.sourceforge.net/torcs/%{name}-%{version}-data-tracks-base.tgz
19 Source6:        http://dl.sourceforge.net/torcs/%{name}-%{version}-data-cars-extra.tgz
20 Source7:        http://dl.sourceforge.net/torcs/%{name}-%{version}-data-cars-Patwo-Design.tgz
21 Patch0:         %{name}-inc.patch
22 URL:            http://torcs.sourceforge.net/
23 BuildRequires:  plib > 1.7.0-1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define _prefix /usr/X11R6
27
28 %description
29
30 %description -l pl
31
32 %prep
33 %setup -q -n torcs-1.2.0 -a1 -a2 -a3 -a4 -a5 -a6
34 mv torcs-1.2.0/src/drivers/* src/drivers
35 rm -r torcs-1.2.0
36 %patch0 -p1
37
38 %build
39 CPPFLAGS="-I/usr/X11R6/include"; export CPPFLAGS
40 CFLAGS="-I/usr/X11R6/include"; export CFLAGS
41 %{__aclocal}
42 %{__autoconf}
43 %configure \
44         --x-includes=%{_prefix}/include
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT
50
51 %{__make} install DESTDIR=$RPM_BUILD_ROOT
52 cp -rf data cars categories tracks menu $RPM_BUILD_ROOT%{_datadir}/games/torcs
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGELOG.html README.linux
60 %attr(755,root,root) %{_bindir}/*
61 %dir %{_datadir}/games/torcs
62 %{_datadir}/games/torcs/cars/
63 %{_datadir}/games/torcs/categories/
64 %{_datadir}/games/torcs/config/
65 %{_datadir}/games/torcs/data/
66 %{_datadir}/games/torcs/drivers/
67 %{_datadir}/games/torcs/menu/
68 %{_datadir}/games/torcs/modules/
69 %{_datadir}/games/torcs/results/
70 %{_datadir}/games/torcs/telemetry/
71 %{_datadir}/games/torcs/tracks/
72 %{_datadir}/games/torcs/setup_linux.sh
73 %attr(755,root,root) %{_datadir}/games/torcs/torcs
74 %{_libdir}/lib*.so
This page took 0.031661 seconds and 3 git commands to generate.