]> git.pld-linux.org Git - packages/SysVinit.git/blob - SysVinit.spec
-added /etc/initscript
[packages/SysVinit.git] / SysVinit.spec
1 Summary:        System V initialization program
2 Summary(de):    System V-Intialisierungsprogramm
3 Summary(fr):    Programme d'initialisation Sys V.
4 Summary(pl):    Program inicjalizuj±cy w Systemie V 
5 Summary(tr):    System V baþlatma programý
6 Name:           SysVinit
7 Version:        2.76
8 Release:        6d
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Demony
12 URL:            ftp://ftp.cistron.nl/pub/people/miquels/software
13 Source0:        sysvinit-%{version}.tar.gz
14 Source1:        sysvinit-initscript
15 Patch:          sysvinit-optimize.patch
16 Buildroot:      /tmp/%{name}-%{version}-root
17
18 %description
19 SysVinit is the first program started by the Linux kernel when the system
20 boots, controlling the startup, running, and shutdown of all other
21 programs.
22
23 %description -l pl
24 SysVinit jest pierwszym programem uruchamianym przez j±dro, podczas 
25 startu systemu. Kontroluje start, pracê oraz zamykanie wszystkich
26 innych programów.
27
28 %description -l de
29 SysVinit ist das erste Programm, das beim Systemstart vom Linux-Kernel 
30 gestartet wird. Es steuert das Starten, Ausführen und Beenden aller
31 anderen Programme.
32
33 %description -l fr
34 SysVinit est le premier programme exécuté par le noyau de Linux lorsque le
35 système démarre, il contrôle le lancement, l'exécution et l'arrêt de tous
36 les autres programmes.
37
38 %description -l tr
39 SysVinit, sistem açýlýrken Linux çekirdeði tarafýndan çalýþtýrýlan ilk
40 programdýr. Diðer programlarýn baþlamalarýný, çalýþmalarýný ve sonlanmalarýný
41 saðlar/denetler.
42
43 %prep
44 %setup -q -n sysvinit-%{version}
45 %patch -p1
46
47 %build
48 make -C src OPTIMIZE="$RPM_OPT_FLAGS"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 for I in sbin usr/bin usr/man/man{1,5,8} etc var/run dev; do
54         install -d $RPM_BUILD_ROOT/$I
55 done
56 make -C src ROOT=$RPM_BUILD_ROOT BIN_OWNER=`id -u` BIN_GROUP=`id -g` install
57 install %SOURCE1 $RPM_BUILD_ROOT/etc/initscript
58
59 #ln -sf ../var/run/initrunlvl $RPM_BUILD_ROOT/etc
60
61 mknod --mode=0600 $RPM_BUILD_ROOT/dev/initctl p 
62
63 ln -sf killall5 $RPM_BUILD_ROOT/sbin/pidof
64
65 # man pages cleaning & compressing ;)
66
67 rm -f $RPM_BUILD_ROOT/usr/man/man1/lastb.1
68
69 echo .so last.1 > $RPM_BUILD_ROOT/usr/man/man1/lastb.1
70
71 rm -f $RPM_BUILD_ROOT/usr/man/man8/poweroff.8
72 rm -f $RPM_BUILD_ROOT/usr/man/man8/telinit.8
73 rm -f $RPM_BUILD_ROOT/usr/man/man8/reboot.8
74
75 echo .so halt.8 > $RPM_BUILD_ROOT/usr/man/man8/reboot.8
76 echo .so halt.8 > $RPM_BUILD_ROOT/usr/man/man8/telinit.8
77 echo .so halt.8 > $RPM_BUILD_ROOT/usr/man/man8/poweroff.8
78
79 gzip -9nf $RPM_BUILD_ROOT/usr/man/{man1/*,man5/*,man8/*} \
80 doc/Propaganda debian/changelog doc/sysvinit-%{version}.lsm  
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc doc/Propaganda.gz debian/changelog.gz doc/sysvinit-%{version}.lsm.gz  
88
89 %attr(755,root,root) /sbin/*
90
91 #%ghost /etc/*
92
93 %attr(755,root,root) /usr/bin/*
94 %attr(600,root,root) /dev/initctl
95 %attr(640,root,root) /etc/initscript
96 %attr(644,root, man) /usr/man/man[158]/*
97
98 %changelog
99 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
100   [2.74-6d]
101 - gzipping instead bzipping
102 - cosmetic changes
103
104 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
105   [2.74-5d]
106 - build against glibc-2.1,
107 - added pl translation,
108 - changed prmissions of binaries to 711,
109 - removed a suid bit from wall,
110 - moved %changelog at the end of spec.
111 - added a Chris Evans's <chris@ferret.lmh.ox.ac.uk> patches.
112
113 * Thu May 07 1998 Prospector System <bugs@redhat.com>
114 - translations modified for de, fr, tr
115
116 * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
117 - upgraded to 2.74
118 - fixed the package source url... (yeah, it was wrong !)
119
120 * Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
121 - fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
122   22 bytes, not 24...). Fix in -md5.patch
123
124 * Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
125 - /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
126   just plain wrong..
127 - /usr/bin/utmpdump was missing in the files section, although it was
128   explicitly patched into PROGS.
129 - added attr's to the files section.
130 - various small fixes.
131
132 * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
133 - updated to 2.71
134 - built against glibc 2.0.4
135
136 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
137 - Added sulogin.8 man page to file list.
This page took 0.044087 seconds and 4 git commands to generate.