]> git.pld-linux.org Git - packages/Sockets.git/blob - Sockets.spec
- GPL v2+
[packages/Sockets.git] / Sockets.spec
1 #
2 # TODO:
3 #       - package docs
4 #       - build shared library
5 #
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8 #
9 Summary:        C++ Sockets Library
10 Summary(pl.UTF-8):      Biblioteka gniazd C++
11 Name:           Sockets
12 Version:        2.1.8
13 Release:        0.1
14 License:        GPL v2+
15 Group:          Development/Libraries
16 Source0:        http://www.alhem.net/Sockets/%{name}-%{version}.tar.gz
17 # Source0-md5:  f285cfcd3558e83f4c2b2c5b114d98d8
18 Source1:        http://www.alhem.net/Sockets/%{name}-%{version}-doxygendocs.tar.gz
19 # Source1-md5:  d2b4427f6cb10a7f15c3c34edb386ba7
20 Source2:        http://www.alhem.net/Sockets/tutorial/%{name}-tutorial.tar.gz
21 # Source2-md5:  86a6c9cb22d06ffacd65cd953398da84
22 URL:            http://www.alhem.net/Sockets/
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  openssl-devel
25 BuildRequires:  sed >= 4.0
26 Requires:       libstdc++-devel
27 Requires:       openssl-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 C++ class library wrapping the Berkeley sockets C API. Features
32 include, but are not limited to, SSL support, IPv6 support, TCP and
33 UDP sockets, SCTP sockets, HTTP protocol, highly customizable error
34 handling.
35
36 %description -l pl.UTF-8
37 Biblioteka klas C++ obudowująca berkeleyowskie API C gniazd.
38 Możliwości obejmują m.in. obsługę SSL, obsługę IPv6, gniazda TCP i
39 UDP, gniazda SCTP, protokół HTTP, elastyczną obsługę błędów.
40
41 %prep
42 %setup -q
43
44 sed -i -e 's,\$(PREFIX)/lib$,$(PREFIX)/%{_lib},' Makefile
45
46 %build
47 %{__make} \
48         CXX="%{__cxx}" \
49         CFLAGS='%{rpmcxxflags} -Wall $(INCLUDE) -MD -D_VERSION=\"$(VERSION)\" -DLINUX'
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %{__make} install \
56         PREFIX=$RPM_BUILD_ROOT%{_prefix}
57
58 install tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %attr(755,root,root) %{_bindir}/Sockets-config
66 %{_includedir}/Sockets
67 %{_libdir}/libSockets.a
68 %{_examplesdir}/%{name}-%{version}
This page took 0.097338 seconds and 4 git commands to generate.