]> git.pld-linux.org Git - packages/Sockets.git/blame - Sockets.spec
- GPL v2+
[packages/Sockets.git] / Sockets.spec
CommitLineData
1e9bf343
TP
1#
2# TODO:
1e9bf343
TP
3# - package docs
4# - build shared library
5#
6# Conditional build:
7%bcond_without static_libs # don't build static library
6d64dcd9 8#
1e9bf343
TP
9Summary: C++ Sockets Library
10Summary(pl.UTF-8): Biblioteka gniazd C++
11Name: Sockets
12Version: 2.1.8
13Release: 0.1
1fb71272 14License: GPL v2+
1e9bf343
TP
15Group: Development/Libraries
16Source0: http://www.alhem.net/Sockets/%{name}-%{version}.tar.gz
17# Source0-md5: f285cfcd3558e83f4c2b2c5b114d98d8
18Source1: http://www.alhem.net/Sockets/%{name}-%{version}-doxygendocs.tar.gz
19# Source1-md5: d2b4427f6cb10a7f15c3c34edb386ba7
20Source2: http://www.alhem.net/Sockets/tutorial/%{name}-tutorial.tar.gz
21# Source2-md5: 86a6c9cb22d06ffacd65cd953398da84
22URL: http://www.alhem.net/Sockets/
23BuildRequires: libstdc++-devel
24BuildRequires: openssl-devel
8782a7ad 25BuildRequires: sed >= 4.0
1fb71272
JB
26Requires: libstdc++-devel
27Requires: openssl-devel
1e9bf343
TP
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
6d64dcd9
JB
31C++ class library wrapping the Berkeley sockets C API. Features
32include, but are not limited to, SSL support, IPv6 support, TCP and
33UDP sockets, SCTP sockets, HTTP protocol, highly customizable error
34handling.
1e9bf343
TP
35
36%description -l pl.UTF-8
6d64dcd9
JB
37Biblioteka klas C++ obudowująca berkeleyowskie API C gniazd.
38Możliwości obejmują m.in. obsługę SSL, obsługę IPv6, gniazda TCP i
39UDP, gniazda SCTP, protokół HTTP, elastyczną obsługę błędów.
1e9bf343
TP
40
41%prep
6d64dcd9 42%setup -q
1e9bf343 43
8782a7ad
JB
44sed -i -e 's,\$(PREFIX)/lib$,$(PREFIX)/%{_lib},' Makefile
45
1e9bf343 46%build
8782a7ad
JB
47%{__make} \
48 CXX="%{__cxx}" \
49 CFLAGS='%{rpmcxxflags} -Wall $(INCLUDE) -MD -D_VERSION=\"$(VERSION)\" -DLINUX'
1e9bf343
TP
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55%{__make} install \
56 PREFIX=$RPM_BUILD_ROOT%{_prefix}
57
58install tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
8782a7ad 65%attr(755,root,root) %{_bindir}/Sockets-config
1e9bf343 66%{_includedir}/Sockets
8782a7ad 67%{_libdir}/libSockets.a
1e9bf343 68%{_examplesdir}/%{name}-%{version}
This page took 0.070548 seconds and 4 git commands to generate.