]> git.pld-linux.org Git - packages/Sockets.git/blame - Sockets.spec
- english %desc from homepage
[packages/Sockets.git] / Sockets.spec
CommitLineData
1e9bf343
TP
1#
2# TODO:
3# - pass CFLAGS
4# - package docs
5# - build shared library
6#
7# Conditional build:
8%bcond_without static_libs # don't build static library
9
10Summary: C++ Sockets Library
11Summary(pl.UTF-8): Biblioteka gniazd C++
12Name: Sockets
13Version: 2.1.8
14Release: 0.1
15License: GPL
16Group: Development/Libraries
17Source0: http://www.alhem.net/Sockets/%{name}-%{version}.tar.gz
18# Source0-md5: f285cfcd3558e83f4c2b2c5b114d98d8
19Source1: http://www.alhem.net/Sockets/%{name}-%{version}-doxygendocs.tar.gz
20# Source1-md5: d2b4427f6cb10a7f15c3c34edb386ba7
21Source2: http://www.alhem.net/Sockets/tutorial/%{name}-tutorial.tar.gz
22# Source2-md5: 86a6c9cb22d06ffacd65cd953398da84
23URL: http://www.alhem.net/Sockets/
24BuildRequires: libstdc++-devel
25BuildRequires: openssl-devel
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
d8407cbf
TP
29C++ class library wrapping the berkeley sockets C API.
30Features include, but are not limited to, SSL support, IPv6 support,
31tcp and udp sockets, sctp sockets, http protocol, highly customizable
32error handling.
1e9bf343
TP
33
34%description -l pl.UTF-8
35
36%prep
37%setup -q -n %{name}-%{version}
38
39%build
40%{__make}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45
46%{__make} install \
47 PREFIX=$RPM_BUILD_ROOT%{_prefix}
48
49install tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%attr(755,root,root) %{_bindir}/*
57%{_includedir}/Sockets
58%{_libdir}/lib*.a
59%{_examplesdir}/%{name}-%{version}
This page took 0.073163 seconds and 4 git commands to generate.