]> git.pld-linux.org Git - packages/SoQt.git/blame_incremental - SoQt.spec
- updated to 1.6.0 (relicensed on BSD; uses cmake now)
[packages/SoQt.git] / SoQt.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4%bcond_without static_libs # static library
5%bcond_with qt4 # Qt4 instead of Qt5
6
7Summary: Qt GUI component toolkit library for Coin
8Summary(pl.UTF-8): Biblioteka komponentu graficznego interfejsu Qt dla biblioteki Coin
9Name: SoQt
10Version: 1.6.0
11Release: 1
12License: BSD
13Group: X11/Libraries
14#Source0Download: https://github.com/coin3d/soqt/releases
15Source0: https://github.com/coin3d/soqt/releases/download/SoQt-%{version}/soqt-%{version}-src.tar.gz
16# Source0-md5: 724996aedad2a33760dc36f08ceeda22
17Patch0: %{name}-pc.patch
18URL: https://github.com/coin3d/soqt
19BuildRequires: Coin-devel >= 4.0.0
20BuildRequires: OpenGL-GLX-devel
21%if %{with qt4}
22BuildRequires: QtCore-devel >= 4
23BuildRequires: QtGui-devel >= 4
24BuildRequires: QtOpenGL-devel >= 4
25%else
26BuildRequires: Qt5Core-devel >= 5
27BuildRequires: Qt5Gui-devel >= 5
28BuildRequires: Qt5OpenGL-devel >= 5
29BuildRequires: Qt5Widgets-devel >= 5
30%endif
31BuildRequires: cmake >= 3.0
32%{?with_apidocs:BuildRequires: doxygen}
33BuildRequires: libstdc++-devel
34BuildRequires: pkgconfig
35%if %{with qt4}
36BuildRequires: qt4-build >= 4
37%else
38BuildRequires: qt5-build >= 5
39%endif
40BuildRequires: rpmbuild(macros) >= 1.752
41BuildRequires: xorg-lib-libX11-devel
42BuildRequires: xorg-lib-libXext-devel
43BuildRequires: xorg-lib-libXmu-devel
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47SoQt is a Qt GUI component toolkit library for Coin. It is also
48compatible with SGI and TGS Open Inventor, and the API is based on the
49API of the InventorXt GUI component toolkit.
50
51%description -l pl.UTF-8
52SoQt to biblioteka toolkitu komponentu graficznego interfejsu
53użytkownika (GUI) Qt dla biblioteki Coin. Jest zgodna także z
54biblioteką SGI i TGS Open Inventor, a API jest oparte na API toolkitu
55komponentu graficznego interfejsu użytkownika InventorXt.
56
57%package devel
58Summary: Header files for SoQt library
59Summary(pl.UTF-8): Pliki nagłówkowe biblioteki SoQt
60Group: X11/Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: Coin-devel >= 4.0.0
63%if %{with qt4}
64Requires: QtCore-devel >= 4
65Requires: QtGui-devel >= 4
66Requires: QtOpenGL-devel >= 4
67%else
68Requires: Qt5Core-devel >= 5
69Requires: Qt5Gui-devel >= 5
70Requires: Qt5OpenGL-devel >= 5
71Requires: Qt5Widgets-devel >= 5
72%endif
73
74%description devel
75Header files for SoQt library.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe biblioteki SoQt.
79
80%package static
81Summary: Static SoQt library
82Summary(pl.UTF-8): Statyczna biblioteka SoQt
83Group: X11/Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86%description static
87Static SoQt library.
88
89%description static -l pl.UTF-8
90Statyczna biblioteka SoQt.
91
92%package apidocs
93Summary: API documentation for SoQt library
94Summary(pl.UTF-8): Dokumentacja API biblioteki SoQt
95Group: Documentation
96%{?noarchpackage}
97
98%description apidocs
99API documentation for SoQt library.
100
101%description apidocs -l pl.UTF-8
102Dokumentacja API biblioteki SoQt.
103
104%prep
105%setup -q -n soqt
106%patch0 -p1
107
108%build
109install -d builddir
110cd builddir
111%cmake .. \
112%if %{with apidocs}
113 -DSOQT_BUILD_DOCUMENTATION=ON \
114 -DSOQT_BUILD_DOC_MAN=ON \
115%endif
116 %{?with_qt4:-DSOQT_USE_QT5=OFF}
117
118%{__make}
119cd ..
120
121%if %{with static_libs}
122install -d builddir-static
123cd builddir-static
124%cmake .. \
125 -DSOQT_BUILD_SHARED_LIBS=OFF \
126 %{?with_qt4:-DSOQT_USE_QT5=OFF}
127
128%{__make}
129cd ..
130%endif
131
132%install
133rm -rf $RPM_BUILD_ROOT
134
135%if %{with static_libs}
136%{__make} -C builddir-static install \
137 DESTDIR=$RPM_BUILD_ROOT
138%endif
139
140%{__make} -C builddir install \
141 DESTDIR=$RPM_BUILD_ROOT
142
143# obsoleted by pkg-config
144#%{__rm} $RPM_BUILD_ROOT%{_libdir}/libSoQt.la
145
146%if %{with apidocs}
147# packaged as %doc
148%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/html
149# to common names etc.
150%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{_*_,components,devices,misc,viewers}.3
151%endif
152# bogus location
153%{__rm} -r $RPM_BUILD_ROOT%{_infodir}/SoQt1
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post -p /sbin/ldconfig
159%postun -p /sbin/ldconfig
160
161%files
162%defattr(644,root,root,755)
163%doc AUTHORS BUGS.txt COPYING ChangeLog FAQ NEWS README
164%attr(755,root,root) %{_libdir}/libSoQt.so.*.*.*
165%attr(755,root,root) %ghost %{_libdir}/libSoQt.so.20
166%{_datadir}/SoQt
167
168%files devel
169%defattr(644,root,root,755)
170%attr(755,root,root) %{_libdir}/libSoQt.so
171%{_includedir}/Inventor/Qt
172%{_pkgconfigdir}/SoQt.pc
173%{_libdir}/cmake/SoQt-%{version}
174%if %{with apidocs}
175%{_mandir}/man3/SoQt*.3*
176%endif
177
178%if %{with static_libs}
179%files static
180%defattr(644,root,root,755)
181%{_libdir}/libSoQt.a
182%endif
183
184%if %{with apidocs}
185%files apidocs
186%defattr(644,root,root,755)
187%doc builddir/html/*.{css,html,js,png}
188%endif
This page took 0.075222 seconds and 4 git commands to generate.