]> git.pld-linux.org Git - packages/Smarty.git/blob - Smarty.spec
- rel 2
[packages/Smarty.git] / Smarty.spec
1 %define         _doc_version    2.6.14
2 %include        /usr/lib/rpm/macros.php
3 Summary:        Template engine for PHP
4 Summary(pl):    System szablonów dla PHP
5 Name:           Smarty
6 Version:        2.6.18
7 Release:        2
8 License:        LGPL
9 Group:          Development/Languages/PHP
10 Source0:        http://smarty.php.net/distributions/%{name}-%{version}.tar.gz
11 # Source0-md5:  cd9b9c78b43c0d0490b71111b2fe1a99
12 Source1:        http://smarty.php.net/distributions/manual/en/%{name}-%{_doc_version}-docs.tar.gz
13 # Source1-md5:  357510250885aab057853949e35845c7
14 Source2:        %{name}-function.html_input_image.php
15 URL:            http://smarty.php.net/
16 BuildRequires:  rpm-php-pearprov >= 4.3
17 Requires:       php-common
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _smartydir      %{_datadir}/php/Smarty
22
23 %description
24 Smarty is a template engine for PHP. Smarty provides your basic
25 variable substitution and dynamic block functionality, and also takes
26 a step further to be a "smart" template engine, adding features such
27 as configuration files, template functions, variable modifiers, and
28 making all of this functionality as easy as possible to use for both
29 programmers and template designers.
30
31 %description -l pl
32 Smarty jest systemem szablonów dla PHP. Pozwala na podstawowe
33 podstawianie warto¶ci zmiennych oraz dynamiczne operacje na blokach;
34 idzie o krok dalej, aby byæ "m±drym" silnikiem szablonów, dodaj±c
35 takie mo¿liwo¶ci jak pliki konfiguracyjne, funkcje, zmienne
36 modyfikatory oraz czyni±c ca³± funkcjonalno¶æ jak naj³atwiejsz± w
37 u¿yciu jednocze¶nie dla programistów i projektantów szablonów.
38
39 %package doc
40 Summary:        Template engine for PHP - documentation
41 Summary(pl):    System szablonów dla PHP - dokumentacja
42 Version:        %{_doc_version}
43 Group:          Development/Languages/PHP
44
45 %description doc
46 Documentation for Smarty template engine.
47
48 %description doc -l pl
49 Dokumentacja do systemu szablonów Smarty.
50
51 %prep
52 %setup -q -a 1
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_smartydir}/{internals,plugins},%{php_pear_dir}}
57
58 install libs/{Config_File,Smarty{,_Compiler}}.class.php $RPM_BUILD_ROOT%{_smartydir}
59 install libs/debug.tpl $RPM_BUILD_ROOT%{_smartydir}
60 install libs/internals/*.php $RPM_BUILD_ROOT%{_smartydir}/internals
61 install libs/plugins/*.php $RPM_BUILD_ROOT%{_smartydir}/plugins
62 install %{SOURCE2} $RPM_BUILD_ROOT%{_smartydir}/plugins/function.html_input_image.php
63
64 # backards compatible
65 ln -s %{_smartydir} $RPM_BUILD_ROOT%{php_pear_dir}/%{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 # make compat symlink, the symlink is discarded using %ghost on package uninstall
71 %triggerpostun -- Smarty < 2.6.10-4
72 if [ -d %{php_pear_dir}/%{name}/plugins ]; then
73         mv %{php_pear_dir}/%{name}/plugins/* %{_smartydir}/plugins
74         rmdir %{php_pear_dir}/%{name}/plugins 2>/dev/null
75 fi
76 rmdir %{php_pear_dir}/%{name} 2>/dev/null || mv -v %{php_pear_dir}/%{name}{,.rpmsave}
77 ln -s %{_smartydir} %{php_pear_dir}/%{name}
78
79 %post
80 [ -e %{php_pear_dir}/%{name} ] || ln -s %{_smartydir} %{php_pear_dir}/%{name}
81
82 %files
83 %defattr(644,root,root,755)
84 %doc BUGS ChangeLog FAQ INSTALL NEWS README RELEASE_NOTES TODO
85 %dir %{_smartydir}
86 %dir %{_smartydir}/internals
87 %dir %{_smartydir}/plugins
88 %{_smartydir}/*.class.php
89 %{_smartydir}/debug.tpl
90 %{_smartydir}/internals/*.php
91 %{_smartydir}/plugins/*.php
92
93 # for the sake of bc
94 %ghost %{php_pear_dir}/%{name}
95
96 %files doc
97 %defattr(644,root,root,755)
98 %doc manual/*
This page took 0.107741 seconds and 3 git commands to generate.