]> git.pld-linux.org Git - packages/SPQR.git/commitdiff
- updated to 1.3.1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Aug 2012 18:05:04 +0000 (20:05 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Aug 2012 18:05:04 +0000 (20:05 +0200)
- updated ufconfig,shared patches

SPQR-shared.patch
SPQR-ufconfig.patch
SPQR.spec

index 86fd9fa2180db3a696a81a415bd815f2e6d98071..9575a19976b8a0c92a23c8a01e286f5d29093c70 100644 (file)
  spqr_rmap.o: ../Source/spqr_rmap.cpp
 -      $(C) -c $<
 +      libtool --tag=CXX --mode=compile $(C) -c $<
  spqr_rmap.o: ../Source/spqr_rmap.cpp
 -      $(C) -c $<
 +      libtool --tag=CXX --mode=compile $(C) -c $<
---- SPQR/Demo/Makefile.orig    2012-06-27 19:01:18.418478492 +0200
-+++ SPQR/Demo/Makefile 2012-06-27 19:01:37.301811034 +0200
-@@ -23,7 +23,7 @@
+--- SPQR/Demo/Makefile.orig    2012-08-28 19:39:55.567055739 +0200
++++ SPQR/Demo/Makefile 2012-08-28 19:40:51.427054575 +0200
+@@ -25,7 +25,7 @@
  endif
  #-------------------------------------------------------------------------------
  
 -CLIB = ../Lib/libspqr.a \
 +CLIB = ../Lib/libspqr.la \
  endif
  #-------------------------------------------------------------------------------
  
 -CLIB = ../Lib/libspqr.a \
 +CLIB = ../Lib/libspqr.la \
+         -lsuitesparseconfig \
        -lcholmod -lamd \
        -lcolamd $(LIB_WITH_PARTITION)
        -lcholmod -lamd \
        -lcolamd $(LIB_WITH_PARTITION)
-@@ -140,22 +140,22 @@
+@@ -146,22 +146,22 @@
  LIBS = $(CLIB) $(LIB) $(FLIB) $(TBB)
  
  qrsimple: qrsimple.cpp library $(INC)
  LIBS = $(CLIB) $(LIB) $(FLIB) $(TBB)
  
  qrsimple: qrsimple.cpp library $(INC)
index 4a55cfe5657f0819c65a981f349807750f647f1a..e12585b656924f764f38ed262b27860e0200251a 100644 (file)
@@ -9,8 +9,8 @@
  
  default: all
  
  
  default: all
  
---- SPQR/Lib/Makefile.orig     2011-12-14 18:48:21.000000000 +0100
-+++ SPQR/Lib/Makefile  2012-01-07 15:36:22.723796599 +0100
+--- SPQR/Lib/Makefile.orig     2012-06-21 07:37:08.000000000 +0200
++++ SPQR/Lib/Makefile  2012-08-28 19:36:19.380393578 +0200
 @@ -6,7 +6,7 @@
  
  ccode: all
 @@ -6,7 +6,7 @@
  
  ccode: all
  
  #-------------------------------------------------------------------------------
  # the optional Partition module requires METIS, CAMD, and CCOLAMD
  
  #-------------------------------------------------------------------------------
  # the optional Partition module requires METIS, CAMD, and CCOLAMD
-@@ -14,13 +14,10 @@
+@@ -15,18 +15,13 @@
+ CONFIG = -DNPARTITION
  # check if METIS is requested and available
  ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
  # check if METIS is requested and available
  ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
-     # METIS is requested.  See if it is available
--    ifeq ($(METIS), $(wildcard $(METIS)))
+-    # METIS is requested.  See if it is available
+-    ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
 -        ifeq (../../CAMD, $(wildcard ../../CAMD))
 -            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
 -        ifeq (../../CAMD, $(wildcard ../../CAMD))
 -            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
++    # METIS is requested.
 +    ifeq ($(WITH_METIS), 1)
 +    ifeq ($(WITH_METIS), 1)
-+      # assume CAMD and CCOLAMD are available
-                 # METIS, CAMD, and CCOLAMD is available
+                 # METIS, CAMD, and CCOLAMD are available
+-                LIB_WITH_PARTITION = $(METIS) ../../CCOLAMD/Lib/libccolamd.a \
+-                    ../../CAMD/Lib/libcamd.a
+-                I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
+-                    -I../../CCOLAMD/Include -I../../CAMD/Include
++                LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
++                I_WITH_PARTITION = -I/usr/include/metis \
++                    -I/usr/include/ccolamd -I/usr/include/camd
                  CONFIG =
 -            endif
 -        endif
      endif
  endif
  #-------------------------------------------------------------------------------
                  CONFIG =
 -            endif
 -        endif
      endif
  endif
  #-------------------------------------------------------------------------------
-@@ -91,7 +88,7 @@
+@@ -97,7 +92,7 @@
  
  $(OBJ): $(INC)
  
  
  $(OBJ): $(INC)
  
@@ -45,8 +53,8 @@
  
  C = $(CXX) $(CF) $(SPQR_CONFIG) $(CONFIG) $(I)
  
  
  C = $(CXX) $(CF) $(SPQR_CONFIG) $(CONFIG) $(I)
  
---- SPQR/Demo/Makefile.orig    2012-05-28 15:15:40.000000000 +0200
-+++ SPQR/Demo/Makefile 2012-06-27 19:00:41.468480043 +0200
+--- SPQR/Demo/Makefile.orig    2012-06-21 07:47:51.000000000 +0200
++++ SPQR/Demo/Makefile 2012-08-28 19:38:04.650391386 +0200
 @@ -6,7 +6,7 @@
  
  ccode: all
 @@ -6,7 +6,7 @@
  
  ccode: all
  
  #-------------------------------------------------------------------------------
  # the optional Partition module requires METIS, CAMD, and CCOLAMD
  
  #-------------------------------------------------------------------------------
  # the optional Partition module requires METIS, CAMD, and CCOLAMD
-@@ -15,24 +15,17 @@
+@@ -15,26 +15,20 @@
+ CONFIG = -DNPARTITION
  # check if METIS is requested and available
  ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
  # check if METIS is requested and available
  ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
-     # METIS is requested.  See if it is available
--    ifeq ($(METIS), $(wildcard $(METIS)))
+-    # METIS is requested.  See if it is available
+-    ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
 -        ifeq (../../CAMD, $(wildcard ../../CAMD))
 -            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
 -        ifeq (../../CAMD, $(wildcard ../../CAMD))
 -            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
--                # METIS, CAMD, and CCOLAMD is available
+-                # METIS, CAMD, and CCOLAMD are available
+-                LIB_WITH_PARTITION = $(METIS) ../../CCOLAMD/Lib/libccolamd.a \
+-                    ../../CAMD/Lib/libcamd.a
+-                I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
+-                    -I../../CCOLAMD/Include -I../../CAMD/Include
++    # METIS is requested.
 +    ifeq ($(WITH_METIS), 1)
 +    ifeq ($(WITH_METIS), 1)
-+                # assume that METIS, CAMD, and CCOLAMD are available
++                LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
++                I_WITH_PARTITION = -I/usr/include/metis \
++                    -I/usr/include/ccolamd -I/usr/include/camd
                  CONFIG =
                  CONFIG =
--                LIB_WITH_PARTITION = $(METIS) \
--                    ../../CCOLAMD/Lib/libccolamd.a \
--                    ../../CAMD/Lib/libcamd.a
 -            endif
 -        endif
 -            endif
 -        endif
-+                LIB_WITH_PARTITION = $(METIS) -lccolamd -lcamd
      endif
  endif
  #-------------------------------------------------------------------------------
      endif
  endif
  #-------------------------------------------------------------------------------
 -        ../../SuiteSparse_config/libsuitesparseconfig.a \
 -      ../../CHOLMOD/Lib/libcholmod.a ../../AMD/Lib/libamd.a \
 -      ../../COLAMD/Lib/libcolamd.a $(LIB_WITH_PARTITION)
 -        ../../SuiteSparse_config/libsuitesparseconfig.a \
 -      ../../CHOLMOD/Lib/libcholmod.a ../../AMD/Lib/libamd.a \
 -      ../../COLAMD/Lib/libcolamd.a $(LIB_WITH_PARTITION)
++        -lsuitesparseconfig \
 +      -lcholmod -lamd \
 +      -lcolamd $(LIB_WITH_PARTITION)
  
  # use the BLAS and LAPACK defined by SuiteSparse_config.mk; do not use valgrind 
  FLIB = $(LAPACK) $(BLAS)
 +      -lcholmod -lamd \
 +      -lcolamd $(LIB_WITH_PARTITION)
  
  # use the BLAS and LAPACK defined by SuiteSparse_config.mk; do not use valgrind 
  FLIB = $(LAPACK) $(BLAS)
-@@ -140,7 +133,7 @@
+@@ -145,7 +139,7 @@
        ../Include/SuiteSparseQR_definitions.h \
        ../Include/SuiteSparseQR.hpp Makefile
  
        ../Include/SuiteSparseQR_definitions.h \
        ../Include/SuiteSparseQR.hpp Makefile
  
index 6238cd4089b12b4a66d0de75139c32a8586b6fd3..cb4dae59feb94c85e837239c1e8f51a443e77d5e 100644 (file)
--- a/SPQR.spec
+++ b/SPQR.spec
@@ -1,12 +1,12 @@
 Summary:       SuiteSparseQR: multithreaded multifrontal sparse QR factorization
 Summary(pl.UTF-8):     SuiteSparseQR - wielowątkowy, wielofrontalny rozkład QR dla macierzy rzadkich
 Name:          SPQR
 Summary:       SuiteSparseQR: multithreaded multifrontal sparse QR factorization
 Summary(pl.UTF-8):     SuiteSparseQR - wielowątkowy, wielofrontalny rozkład QR dla macierzy rzadkich
 Name:          SPQR
-Version:       1.3.0
+Version:       1.3.1
 Release:       1
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/SPQR/%{name}-%{version}.tar.gz
 Release:       1
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/SPQR/%{name}-%{version}.tar.gz
-# Source0-md5: 0c3838dda38b56b2186b0d225ffc089f
+# Source0-md5: c1a55e7ac6208f7657186aa01356c8f2
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 URL:           http://www.cise.ufl.edu/research/sparse/SPQR/
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 URL:           http://www.cise.ufl.edu/research/sparse/SPQR/
This page took 0.095348 seconds and 4 git commands to generate.