]> git.pld-linux.org Git - packages/SPIRV-LLVM-Translator.git/blob - SPIRV-LLVM-Translator.spec
e50ca90e9f9323c780977d8c57c609043a0e68b3
[packages/SPIRV-LLVM-Translator.git] / SPIRV-LLVM-Translator.spec
1
2 %define llvm_version 12.0.0
3
4 Summary:        LLVM/SPIR-V Bi-Directional Translator
5 Summary(pl.UTF-8):      Dwustronny translator LLVM/SPIR-V
6 Name:           SPIRV-LLVM-Translator
7 Version:        12.0.0
8 Release:        1
9 License:        University of Illinois/NCSA Open Source License
10 Group:          Libraries
11 #Source0Download: https://github.com/KhronosGroup/SPIRV-LLVM-Translator/releases
12 Source0:        https://github.com/KhronosGroup/SPIRV-LLVM-Translator/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  d1db52b9dc305eebb9ed11a5324c58a3
14 # from Intel opencl-clang
15 Patch0:         0001-Update-LowerOpenCL-pass-to-handle-new-blocks-represn.patch
16 URL:            https://github.com/KhronosGroup/SPIRV-LLVM-Translator/
17 BuildRequires:  cmake >= 3.3
18 BuildRequires:  libstdc++-devel >= 6:4.7
19 BuildRequires:  llvm-devel >= %{llvm_version}
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LLVM/SPIR-V Bi-Directional Translator - a library and tool for
25 translation between LLVM IR and SPIR-V.
26
27 %description -l pl.UTF-8
28 Dwustronny translator LLVM/SPIR-V - biblioteka i narzędzie do
29 tłumaczenia między IR LLVM a SPIR-V.
30
31 %package devel
32 Summary:        Header files for LLVMSPIRVLib library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LLVMSPIRVLib
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       libstdc++-devel >= 6:4.7
37 Requires:       llvm-devel >= %{llvm_version}
38
39 %description devel
40 Header files for LLVMSPIRVLib library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki LLVMSPIRVLib.
44
45 %prep
46 %setup -qn %{name}-%{version}
47
48 %build
49
50 install -d build
51 cd build
52 %cmake ..
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libLLVMSPIRVLib.so.12 $RPM_BUILD_ROOT%{_libdir}/libLLVMSPIRVLib.so.%{version}
63 ln -s libLLVMSPIRVLib.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libLLVMSPIRVLib.so.12
64 ln -sf libLLVMSPIRVLib.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libLLVMSPIRVLib.so
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.md LICENSE.TXT
75 %attr(755,root,root) %{_libdir}/libLLVMSPIRVLib.so.12.*.*
76 %ghost %attr(755,root,root) %{_libdir}/libLLVMSPIRVLib.so.12
77
78 %files devel
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_libdir}/libLLVMSPIRVLib.so
81 %{_includedir}/LLVMSPIRVLib
82 %{_pkgconfigdir}/LLVMSPIRVLib.pc
This page took 0.072189 seconds and 2 git commands to generate.