]> git.pld-linux.org Git - packages/SPE.git/blob - SPE.spec
BR: rpmbuild(macros) >= 1.710
[packages/SPE.git] / SPE.spec
1 # TODO:
2 # - fix %%files (doc to %%doc, no .py, remove unused files)
3 %define _wx     2.6.1.0
4 #
5 Summary:        SPE - Stani's Python Editor
6 Summary(pl.UTF-8):      SPE - pythonowy edytor Staniego
7 Name:           SPE
8 Version:        0.8.2.a
9 Release:        5
10 License:        LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
11 Group:          Applications/Text
12 Source0:        http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.tar.gz
13 # Source0-md5:  d5d5a55414aa2410ac430f7e79b271e5
14 Source1:        %{name}.desktop
15 Source2:        %{name}.png
16 URL:            http://spe.pycs.net/
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 BuildRequires:  python
19 BuildRequires:  python-devel
20 BuildRequires:  python-modules
21 BuildRequires:  rpm-pythonprov
22 Requires:       pydoc
23 %pyrequires_eq  python-modules
24 Requires:       python-wxPython >= %{_wx}
25 # below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
26 Requires:       python-wxPython >= 2.6.1.0-3
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Spe is a python IDE with auto-indentation, auto completion, call tips,
32 syntax coloring, syntax highlighting, class explorer, source index,
33 auto todo list, sticky notes, integrated pycrust shell, python file
34 browser, recent file browser, drag&drop, context help, ... Special is
35 its blender support with a blender 3d object browser and its ability
36 to run interactively inside blender. Spe is extensible with boa. 
37
38 %description -l pl.UTF-8
39 Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
40 wykonywaniem wcięć, automatycznym dopełnianiem, podpowiedziami
41 wywołań, kolorowaniem składni, podświetlaniem składni, eksploratorem
42 klas, indeksem źródeł, automatyczną listą TODO, przyklejanymi
43 notatkami, zintegrowaną powłoką pycrust, przeglądarką plików
44 pythonowych, przeglądarką ostatnio używanych plików, obsługą w stylu
45 przeciągnij-i-upuść, pomocą kontekstową... Specjalną rzeczą jest
46 wsparcie dla blendera z przeglądarką obiektów blendera 3D i
47 możliwością automatycznego uruchamiania z poziomu blendera. Spe jest
48 rozszerzalne przy pomocy boa.
49
50 %prep
51 %setup -q -n %{name}-%{version}-wx%{_wx}
52
53 %build
54 %py_build
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
59
60 %py_install
61
62 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
63 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
64
65 # SPE doesn't work without *.py files so don't remove them
66 #%%py_postclean
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README.txt
74 %attr(755,root,root) %{_bindir}/*
75 %{py_sitescriptdir}/*
76 %{_desktopdir}/*.desktop
77 %{_pixmapsdir}/*
This page took 0.23544 seconds and 3 git commands to generate.