]> git.pld-linux.org Git - packages/SDLmm.git/blob - SDLmm.spec
- release 3: fix %define _mandir macro.
[packages/SDLmm.git] / SDLmm.spec
1 Summary:        C++ glue to SDL (Simple DirectMedia Layer)
2 Summary(pl):    Interfejs C++ do SDL
3 Name:           SDLmm
4 Version:        0.1.8
5 Release:        3
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://prdownloads.sourceforge.net/sdlmm/%{name}-%{version}.tar.bz2
9 URL:            http://sdlmm.sourceforge.net/
10 BuildRequires:  SDL-devel
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _prefix         /usr/X11R6
17 %define         _mandir         %{_prefix}/man
18
19 %description
20 This is a C++ glue to SDL (Simple DirectMedia Layer) library- a
21 low-level, cross-platform multimedia library. SDLmm will utilize C++
22 features while still being close to SDL in syntax (and naming).
23
24 %description -l pl
25 Jest to ³±cznik miêdzy C++ a SDL (Simple DirectMedia Layer),
26 niskopoziomow± bibliotek± multimedialn±. SDLmm wykorzysta cechy C++
27 wci±¿ bêd±c w sk³adni (i w nazewnictwie) blisko SDL.
28
29 %package devel
30 Summary:        Header files and more to develop SDLmm applications
31 Summary(pl):    Pliki nag³ówkowe do rozwijania aplikacji u¿ywaj±cych SDLmm
32 Group:          X11/Development/Libraries
33 Requires:       %{name} = %{version}
34 Requires:       SDL-devel
35
36 %description devel
37 Header files and more to develop SDLmm applications.
38
39 %description -l pl devel
40 Pliki nag³ówkowe do rozwijania aplikacji u¿ywaj±cych SDLmm.
41
42 %package static
43 Summary:        Static SDLmm libraries
44 Summary(pl):    Statyczne biblioteki SDLmm
45 Group:          X11/Development/Libraries
46 Requires:       %{name}-devel = %{version}
47
48 %description static
49 Statis SDL_image libraries.
50
51 %description -l pl static
52 Statyczne biblioteki SDL_image.
53
54 %prep
55 %setup -q 
56
57 %build
58 rm -f missing
59 libtoolize --copy --force
60 aclocal
61 autoconf
62 automake -a -c -f
63 %configure 
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         m4datadir=%{_aclocaldir}
72
73 gzip -9nf NEWS README THANKS AUTHORS
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc *.gz
84 %attr(755,root,root) %{_libdir}/lib*.so.*.*
85
86 %files devel
87 %defattr(644,root,root,755)
88 %doc docs/html/*.html docs/html/*.gif docs/html/*.css
89 %attr(755,root,root) %{_bindir}/*
90 %attr(755,root,root) %{_libdir}/lib*.so
91 %{_includedir}/SDLmm
92 %{_aclocaldir}/*
93 %{_mandir}/man3/*
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/lib*.a
This page took 0.072036 seconds and 3 git commands to generate.