]> git.pld-linux.org Git - packages/SDL_image.git/blob - SDL_image.spec
- added using %%{__make} macro.
[packages/SDL_image.git] / SDL_image.spec
1 Summary:        Simple DirectMedia Layer - Sample Image Loading Library
2 Name:           SDL_image
3 Version:        1.0.4
4 Release:        3
5 License:        LGPL
6 Group:          Libraries
7 Source0:        http://www.devolution.com/~slouken/SDL/projects/SDL_image/src/%{name}-%{version}.tar.gz
8 BuildRequires:  SDL-devel >= 1.1.1
9 BuildRequires:  libjpeg-devel
10 BuildRequires:  libpng-devel
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _prefix         /usr/X11R6
14
15 %description
16 This is a simple library to load images of various formats as SDL
17 surfaces. This library currently supports BMP, PPM, PCX, GIF, JPEG,
18 and PNG formats.
19
20 %description -l pl
21 jest to prosta biblioteka s³u¿±ca do ³adowania ró¿nego formtu obrazków
22 jako powierzchni SDL. W chwili obecnej biblioteka obs³uguje
23 nastepuj±ce formaty: BMP, PPM, PCX, GIF, JPEG oraz PNG.
24
25 %package devel
26 Summary:        Header files and more to develop SDL_image applications
27 Group:          Development/Libraries
28 Group(fr):      Development/Librairies
29 Group(pl):      Programowanie/Biblioteki
30 Requires:       %{name} = %{version}
31 Requires:       SDL-devel
32
33 %description devel
34 Header files and more to develop SDL_image applications.
35
36 %package static
37 Summary:        Statis SDL_image libraries
38 Group:          Development/Libraries
39 Group(fr):      Development/Librairies
40 Group(pl):      Programowanie/Biblioteki
41 Requires:       %{name}-devel = %{version}
42
43 %description static
44 Statis SDL_image libraries.
45
46 %prep
47 %setup -q 
48
49 %build
50 LDFLAGS="-s"; export LDFLAGS
51 %configure \
52         --enable-bmp \
53         --enable-gif \
54         --enable-jpg \
55         --enable-pcx \
56         --enable-png \
57         --enable-ppm \
58         --enable-tif
59
60 make
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} install DESTDIR=$RPM_BUILD_ROOT
65
66 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
67
68 gzip -9nf README CHANGES
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/showimage
79 %attr(755,root,root) %{_libdir}/lib*.so.*.*
80
81 %files devel
82 %defattr(644,root,root,755)
83 %doc *.gz
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %{_includedir}/SDL/*
86
87 %files static
88 %defattr(644,root,root,755)
89 %{_libdir}/lib*.a
This page took 0.048966 seconds and 3 git commands to generate.