]> git.pld-linux.org Git - packages/SDL2.git/blobdiff - SDL2.spec
up to 2.0.12
[packages/SDL2.git] / SDL2.spec
index 6d16cc13191a15cc96b0e79c94e9ee267ec1fa4c..700b21013fba72d9fc2bae54af82d183ce287efc 100644 (file)
--- a/SDL2.spec
+++ b/SDL2.spec
@@ -1,3 +1,4 @@
+# TODO: fcitx
 #
 # Conditional build:
 %bcond_with    directfb        # DirectFB graphics support
@@ -5,9 +6,11 @@
 %bcond_without alsa            # ALSA audio support
 %bcond_with    arts            # aRts audio support
 %bcond_with    esd             # EsounD audio support
+%bcond_with    jack            # JACK audio support
 %bcond_without gl              # OpenGL (GLX) support
 %bcond_without gles            # OpenGL ES (EGL) support
-%bcond_with    mir             # Mir graphics support
+%bcond_with    kms             # KMS/DRM graphics support
+%bcond_without vulkan          # Vulkan graphics support
 %bcond_without wayland         # Wayland graphics support
 %bcond_without static_libs     # don't build static libraries
 %bcond_with    mmx             # MMX instructions
 # libasound.so.2               [if with alsa]
 # libaudio.so.2                        [if with nas]
 # libdirectfb-*.so --needs patch (-release not supported by configure)
+# libdrm.so.2                  [if with kms]
 # libesd.so.0                  [if with esd]
 # libfusionsound-*.so --needs patch (-release not supported by configure)
-# libmirclient.so.7            [if with mir]
+# libgbm.so.1                  [if with kms]
+# libjack.so.0                 [if with jack]
 # libpulse-simple.so.0
+# libsamplerate.so.0
 # libwayland-client.so.0       [if with wayland]
 # libwayland-cursor.so.0       [if with wayland]
 # libwayland-egl.so.1          [if with wayland]
-# libxkbcommon.so.0            [if with wayland or mir]
+# libxkbcommon.so.0            [if with wayland]
 # libX11.so.6
 # libXcursor.so.1
 # libXext.so.6
@@ -54,29 +60,32 @@ Summary:    SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Summary(pl.UTF-8):     SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
 Summary(zh_CN.UTF-8):  SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
 Name:          SDL2
-Version:       2.0.7
+Version:       2.0.12
 Release:       1
 License:       Zlib (BSD-like)
 Group:         Libraries
 Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
-# Source0-md5: cdb071009d250e1782371049f0d5ca42
+# Source0-md5: 783b6f2df8ff02b19bb5ce492b99c8ff
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-cflags.patch
 URL:           http://www.libsdl.org/
-%{?with_wayland:BuildRequires: Mesa-libwayland-egl-devel}
+%{?with_kms:BuildRequires:     Mesa-libgbm-devel >= 9.0.0}
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 1.0.0}
 %{?with_directfb:BuildRequires:        FusionSound-devel >= 1.1.1}
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gles:BuildRequires:    OpenGLES-devel}
-%{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
+%{?with_alsa:BuildRequires:    alsa-lib-devel >= 1.0.11}
 %{?with_arts:BuildRequires:    artsc-devel >= 1.1}
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake
 BuildRequires: dbus-devel
 %{?with_esd:BuildRequires:     esound-devel >= 0.2.8}
 BuildRequires: gcc >= 5:4.0
+BuildRequires: ibus-devel >= 1.0
+%{?with_jack:BuildRequires:    jack-audio-connection-kit-devel >= 0.125}
+%{?with_kms:BuildRequires:     libdrm-devel >= 2.4.46}
+BuildRequires: libsamplerate-devel
 BuildRequires: libtool >= 2:2.0
-%{?with_mir:BuildRequires:     mir-devel}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: perl-modules
 BuildRequires: pkgconfig >= 1:0.7
@@ -85,6 +94,7 @@ BuildRequires:        tslib-devel
 BuildRequires: udev-devel
 # wayland-client, wayland-cursor
 %{?with_wayland:BuildRequires: wayland-devel}
+%{?with_wayland:BuildRequires: wayland-egl-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXcursor-devel
@@ -94,7 +104,7 @@ BuildRequires:       xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-%if %{with mir} || %{with wayland}
+%if %{with wayland}
 BuildRequires: xorg-lib-libxkbcommon-devel
 %endif
 BuildRequires: xorg-proto-xextproto-devel
@@ -213,6 +223,7 @@ SDL - przykładowe programy.
        %{!?with_altiveca:--disable-altivec} \
        %{!?with_arts:--disable-arts} \
        %{!?with_esd:--disable-esd} \
+       %{!?with_jack:--disable-jack} \
        %{!?with_mmx:--disable-mmx} \
        %{!?with_nas:--disable-nas} \
        --enable-pthreads \
@@ -223,9 +234,10 @@ SDL - przykładowe programy.
        %{?with_sse:--enable-ssemath} \
        %{!?with_static_libs:--disable-static} \
        %{!?with_directfb:--disable-video-directfb} \
-       --enable-video-mir%{!?with_mir:=no} \
+       %{?with_kms:--enable-video-kmsdrm} \
        --enable-video-opengl%{!?with_gl:=no} \
        --enable-video-opengles%{!?with_gles:=no} \
+       --enable-video-vulkan%{!?with_vulkan:=no} \
        --enable-video-wayland%{!?with_wayland:=no} \
        --with-x
 
@@ -261,7 +273,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libSDL2.so
 %{_libdir}/libSDL2.la
 %{_libdir}/libSDL2_test.a
+%{_libdir}/libSDL2_test.la
 %{_libdir}/libSDL2main.a
+%{_libdir}/libSDL2main.la
 %{_includedir}/SDL2
 %{_aclocaldir}/sdl2.m4
 %{_pkgconfigdir}/sdl2.pc
This page took 0.061536 seconds and 4 git commands to generate.