]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- added conditional GGI support (don't use yet - buggy ggi crashes)
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
16 Name:           SDL
17 Version:        1.2.1
18 Release:        1
19 License:        LGPL
20 Group:          X11/Libraries
21 Group(de):      X11/Libraries
22 Group(es):      X11/Bibliotecas
23 Group(pl):      X11/Biblioteki
24 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
25 Patch0:         %{name}-byteorder.patch
26 URL:            http://www.libsdl.org/
27 %{!?_without_esound:BuildRequires:      esound-devel}
28 %{!?_without_arts:BuildRequires:        arts-devel}
29 BuildRequires:  gtk+-devel >= 1.2.1
30 BuildRequires:  XFree86-devel >= 4.0.2
31 BuildRequires:  OpenGL-devel
32 %ifnarch sparc sparc64
33 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
34 %endif
35 %{?_with_svgalib:BuildRequires: svgalib-devel}
36 %{?_with_aalib:BuildRequires:   aalib-devel}
37 %{?_with_ggi:BuildRequires:     libggi-devel}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _prefix         /usr/X11R6
41 %define         _mandir         %{_prefix}/man
42
43 %description
44 SDL (Simple DirectMedia Layer) is a library that allows you portable,
45 low level access to a video framebuffer, audio output, mouse, and
46 keyboard. It can support both windowed and DGA modes of XFree86, and
47 it is designed to be portable - applications linked with SDL can also
48 be built on Win32 and BeOS.
49
50 %description -l pl
51 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
52 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
53 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
54 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
55 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
56
57 %package devel
58 Summary:        SDL - Header files
59 Summary(pl):    SDL - Pliki nag³ówkowe
60 Group:          X11/Libraries
61 Group(de):      X11/Libraries
62 Group(es):      X11/Bibliotecas
63 Group(pl):      X11/Biblioteki
64 Requires:       %{name} = %{version}
65
66 %description devel
67 SDL - Header files.
68
69 %description -l pl devel
70 SDL - Pliki nag³ówkowe.
71
72 %package static
73 Summary:        SDL - static libraries
74 Summary(pl):    SDL - biblioteki statyczne
75 Group:          X11/Libraries
76 Group(de):      X11/Libraries
77 Group(es):      X11/Bibliotecas
78 Group(pl):      X11/Biblioteki
79 Requires:       %{name} = %{version}
80
81 %description static
82 SDL - static libraries.
83
84 %description -l pl static
85 SDL - biblioteki statyczne.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 %configure \
93 %ifnarch sparc sparc64
94         %{!?_without_alsa:--enable-alsa} \
95 %endif
96         --enable-nasm \
97         --enable-pthreads \
98         --enable-pthread-sem \
99         --with-x \
100         --enable-video-x11-vm \
101         --enable-video-x11-dga \
102         --enable-video-x11-mtrr \
103         --enable-video-x11-dgamouse \
104         --enable-video-opengl \
105         %{!?_without_esound:--enable-esd} \
106         %{!?_without_arts:--enable-arts} \
107         %{?_with_svga:--enable-video-svga} \
108         %{?_with_aalib:--enable-video-aalib} \
109         %{?_with_ggi:--enable-video-ggi}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         m4datadir=%{_aclocaldir}
117
118 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
119
120 gzip -9nf BUGS CREDITS README TODO WhatsNew
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/lib*.so.*.*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
135 %attr(755,root,root) %{_bindir}/sdl-config
136 %attr(755,root,root) %{_libdir}/lib*.so
137 %attr(755,root,root) %{_libdir}/lib*.la
138 %{_libdir}/libSDLmain.a
139 %{_includedir}/SDL
140 %{_aclocaldir}/*
141 %{_mandir}/man3/*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/lib*.a
This page took 0.556248 seconds and 4 git commands to generate.