]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
switch to new conditional builds macros (bcond_on_ -> _with_/bcond_off_ -> _without_...
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svgalib - with svgalib support
7 # _with_aalib - with aalib support
8 #
9 %ifarch alpha
10 %define _without_arts 1
11 %endif
12
13 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
14 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
15 Name:           SDL
16 Version:        1.2.0
17 Release:        3
18 License:        LGPL
19 Group:          X11/Libraries
20 Group(de):      X11/Libraries
21 Group(es):      X11/Bibliotecas
22 Group(pl):      X11/Biblioteki
23 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
24 Patch0:         %{name}-svga.patch
25 Patch1:         %{name}-byteorder.patch
26 URL:            http://www.libsdl.org/
27 %{!?_without_esound:BuildRequires:      esound-devel}
28 %{!?_without_arts:BuildRequires:        arts-devel}
29 BuildRequires:  gtk+-devel >= 1.2.1
30 BuildRequires:  XFree86-devel >= 4.0.2
31 BuildRequires:  OpenGL-devel
32 %ifnarch sparc sparc64
33 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
34 %endif
35 %{?_with_svgalib:BuildRequires: svgalib-devel}
36 %{?_with_aalib:BuildRequires:   aalib-devel}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _prefix         /usr/X11R6
40 %define         _mandir         %{_prefix}/man
41
42 %description
43 SDL (Simple DirectMedia Layer) is a library that allows you portable,
44 low level access to a video framebuffer, audio output, mouse, and
45 keyboard. It can support both windowed and DGA modes of XFree86, and
46 it is designed to be portable - applications linked with SDL can also
47 be built on Win32 and BeOS.
48
49 %description -l pl
50 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
51 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
52 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
53 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
54 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
55
56 %package devel
57 Summary:        SDL - Header files
58 Summary(pl):    SDL - Pliki nag³ówkowe
59 Group:          X11/Libraries
60 Group(de):      X11/Libraries
61 Group(es):      X11/Bibliotecas
62 Group(pl):      X11/Biblioteki
63 Requires:       %{name} = %{version}
64
65 %description devel
66 SDL - Header files.
67
68 %description -l pl devel
69 SDL - Pliki nag³ówkowe.
70
71 %package static
72 Summary:        SDL - static libraries
73 Summary(pl):    SDL - biblioteki statyczne
74 Group:          X11/Libraries
75 Group(de):      X11/Libraries
76 Group(es):      X11/Bibliotecas
77 Group(pl):      X11/Biblioteki
78 Requires:       %{name} = %{version}
79
80 %description static
81 SDL - static libraries.
82
83 %description -l pl static
84 SDL - biblioteki statyczne.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90
91 %build
92 %configure \
93 %ifnarch sparc sparc64
94         %{!?_without_alsa:--enable-alsa} \
95 %endif
96         --enable-nasm \
97         --enable-pthreads \
98         --enable-pthread-sem \
99         --with-x \
100         --enable-video-x11-vm \
101         --enable-video-x11-dga \
102         --enable-video-x11-mtrr \
103         --enable-video-x11-dgamouse \
104         --enable-video-opengl \
105         %{!?_without_esound:--enable-esd} \
106         %{!?_without_arts:--enable-arts} \
107         %{?_with_svga:--enable-video-svga} \
108         %{?_with_aalib:--enable-video-aalib}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         m4datadir=%{_aclocaldir}
116
117 rm -rf docs/man3
118
119 gzip -9nf BUGS README WhatsNew
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/lib*.so.*.*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %doc *gz docs.html docs
134 %attr(755,root,root) %{_bindir}/sdl-config
135 %attr(755,root,root) %{_libdir}/lib*.so
136 %attr(755,root,root) %{_libdir}/lib*.la
137 %{_libdir}/libSDLmain.a
138 %{_includedir}/SDL
139 %{_aclocaldir}/*
140 %{_mandir}/man3/*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*.a
This page took 0.470486 seconds and 4 git commands to generate.