]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- removed BuildRequires: gcc >= 5:4.0 (build on 3.3.6)
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 %bcond_with     aalib           # with aalib graphics support
4 %bcond_with     caca            # with caca graphics support
5 %bcond_with     directfb        # with DirectFB graphics support
6 %bcond_with     ggi             # with GGI graphics support
7 %bcond_with     nas             # with NAS audio support
8 %bcond_with     svga            # with svgalib graphics support
9 %bcond_without  alsa            # without ALSA audio support
10 %bcond_without  arts            # without aRts audio support
11 %bcond_without  esd             # without EsounD audio support
12 #
13 # NOTE: the following libraries are dlopened by soname detected at build time:
14 # libasound.so.2
15 # libesd.so.0
16 # libX11.so.6
17 # libXext.so.6
18 # libXrender.so.1
19 # libXrandr.so.2
20 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
21 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
22 Summary(zh_CN): SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
23 Name:           SDL
24 Version:        1.2.11
25 Release:        2
26 License:        LGPL
27 Group:          Libraries
28 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
29 # Source0-md5:  418b42956b7cd103bfab1b9077ccc149
30 Patch0:         %{name}-mmx-constraints.patch
31 Patch1:         %{name}-acfix.patch
32 Patch2:         %{name}-caca.patch
33 URL:            http://www.libsdl.org/
34 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.15}
35 BuildRequires:  OpenGL-GLU-devel
36 %{?with_aalib:BuildRequires:    aalib-devel}
37 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
38 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
39 BuildRequires:  autoconf >= 2.59-9
40 BuildRequires:  automake
41 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
42 %{?with_caca:BuildRequires:     libcaca-devel}
43 %{?with_ggi:BuildRequires:      libggi-devel}
44 BuildRequires:  libtool >= 2:1.4d
45 %{?with_nas:BuildRequires:      nas-devel}
46 %ifarch %{ix86}
47 BuildRequires:  nasm
48 %endif
49 BuildRequires:  perl-modules
50 %{?with_directfb:BuildRequires: pkgconfig >= 1:0.7}
51 %{?with_svga:BuildRequires:     svgalib-devel >= 1.4.0}
52 BuildRequires:  xorg-lib-libX11-devel
53 BuildRequires:  xorg-lib-libXext-devel
54 BuildRequires:  xorg-lib-libXrandr-devel
55 BuildRequires:  xorg-lib-libXrender-devel
56 BuildRequires:  xorg-proto-xextproto-devel
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 SDL (Simple DirectMedia Layer) is a library that allows you portable,
61 low level access to a video framebuffer, audio output, mouse, and
62 keyboard. It can support both windowed and DGA modes of XFree86, and
63 it is designed to be portable - applications linked with SDL can also
64 be built on Win32 and BeOS.
65
66 %description -l pl
67 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
68 przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
69 myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
70 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
71 konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
72
73 %description -l pt_BR
74 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
75 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
76
77 Essa biblioteca é usada por alguns jogos.
78
79 %description -l ru
80 SDL (Simple DirectMedia Layer) ÜÔÏ ÎÁÂÏÒ ÆÕÎËÃÉÊ, ÐÒÅÄÏÓÔÁ×ÌÑÀÝÉÊ
81 ÎÉÚËÏÕÒÏ×ÎÅ×ÙÊ ÄÏÓÔÕРˠÚ×ÕËÕ, ËÌÁ×ÉÁÔÕÒÅ, ÍÁÎÉÐÕÌÑÔÏÒÕ ÍÙÛØ É Ë
82 ÂÕÆÅÒÕ ÜËÒÁÎÁ ÎÁ ÍÎÏÖÅÓÔ×Å ÒÁÚÌÉÞÎÙÈ ÐÌÁÔÆÏÒÍ.
83
84 %package devel
85 Summary:        SDL - Header files
86 Summary(pl):    SDL - Pliki nag³ówkowe
87 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
88 Summary(ru):    æÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ, ÉÓÐÏÌØÚÕÀÝÉÈ SDL
89 Summary(uk):    æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
90 Summary(zh_CN): SDL (Simple DirectMedia Layer) ¿ª·¢¿â
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 %{?with_directfb:Requires:      DirectFB-devel >= 0.9.15}
94 %{?with_aa:Requires:    aalib-devel}
95 %{?with_caca:Requires:  libcaca-devel}
96 %{?with_ggi:Requires:   libggi-devel}
97 %{?with_nas:Requires:   nas-devel}
98 %{?with_svga:Requires:  svgalib-devel >= 1.4.0}
99
100 %description devel
101 SDL - Header files.
102
103 %description devel -l pl
104 SDL - Pliki nag³ówkowe.
105
106 %description devel -l pt_BR
107 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
108 recursos para o desenvolvimento de aplicativos com SDL.
109
110 %description devel -l ru
111 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
112 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
113
114 %description devel -l uk
115 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
116 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
117
118 %package static
119 Summary:        SDL - static libraries
120 Summary(pl):    SDL - biblioteki statyczne
121 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
122 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
123 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
124 Group:          Development/Libraries
125 Requires:       %{name}-devel = %{version}-%{release}
126
127 %description static
128 SDL - static libraries.
129
130 %description static -l pl
131 SDL - biblioteki statyczne.
132
133 %description static -l pt_BR
134 Biblioteca estática para desenvolvimento de aplicações com a SDL.
135
136 %description static -l ru
137 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
138 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
139
140 %description static -l uk
141 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
142 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
143
144 %package examples
145 Summary:        SDL - example programs
146 Summary(pl):    SDL - programy przyk³adowe
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149
150 %description examples
151 SDL - example programs.
152
153 %description examples -l pl
154 SDL - przyk³adowe programy.
155
156 %prep
157 %setup -q
158 %patch0 -p1
159 %patch1 -p1
160 #%patch2 -p1    # needs rewrite
161
162 %{!?with_alsa:echo 'AC_DEFUN([AM_PATH_ALSA],[$3])' >> acinclude.m4}
163 %{!?with_esd:echo 'AC_DEFUN([AM_PATH_ESD],[$3])' >> acinclude.m4}
164
165 %build
166 %{__libtoolize}
167 %{__aclocal}
168 %{__autoconf}
169 %configure \
170 %ifarch %{ix86}
171         --enable-nasm \
172 %else
173         --disable-nasm \
174 %endif
175         --disable-rpath \
176         %{!?with_alsa:--disable-alsa} \
177         %{!?with_arts:--disable-arts} \
178         --enable-dga \
179         %{!?with_esd:--disable-esd} \
180         %{!?with_nas:--disable-nas} \
181         --enable-pthreads \
182         --enable-pthread-sem \
183         %{?with_aalib:--enable-video-aalib} \
184         %{?with_caca:--enable-video-caca} \
185         %{!?with_directfb:--disable-video-directfb} \
186         --enable-video-dga \
187         --enable-video-fbcon \
188         %{?with_ggi:--enable-video-ggi} \
189         --enable-video-opengl \
190         %{!?with_svga:--disable-video-svga} \
191         --enable-video-x11-dgamouse \
192         --enable-video-x11-vm \
193         --enable-video-x11-xinerama \
194         --enable-video-x11-xme \
195         --enable-video-x11-xrandr \
196         --enable-video-x11-xv \
197         --with-x
198
199 %{__make}
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
204
205 %{__make} install \
206         DESTDIR=$RPM_BUILD_ROOT \
207         m4datadir=%{_aclocaldir}
208
209 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
210
211 rm -rf docs/man3
212
213 %clean
214 rm -rf $RPM_BUILD_ROOT
215
216 %post   -p /sbin/ldconfig
217 %postun -p /sbin/ldconfig
218
219 %files
220 %defattr(644,root,root,755)
221 %doc BUGS CREDITS README TODO WhatsNew
222 %attr(755,root,root) %{_libdir}/libSDL-*.so.*.*
223
224 %files devel
225 %defattr(644,root,root,755)
226 %doc docs.html docs
227 %attr(755,root,root) %{_bindir}/sdl-config
228 %attr(755,root,root) %{_libdir}/libSDL.so
229 %{_libdir}/libSDL.la
230 %{_libdir}/libSDLmain.a
231 %{_includedir}/SDL
232 %{_aclocaldir}/sdl.m4
233 %{_pkgconfigdir}/sdl.pc
234 %{_mandir}/man3/*
235
236 %files static
237 %defattr(644,root,root,755)
238 %{_libdir}/libSDL.a
239
240 %files examples
241 %defattr(644,root,root,755)
242 %{_examplesdir}/%{name}-%{version}
This page took 0.082027 seconds and 3 git commands to generate.