]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- amfix patch for automake 1.5
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.2
20 Release:        5
21 License:        LGPL
22 Group:          X11/Libraries
23 Group(de):      X11/Libraries
24 Group(es):      X11/Bibliotecas
25 Group(fr):      X11/Librairies
26 Group(pl):      X11/Biblioteki
27 Group(pt_BR):   X11/Bibliotecas
28 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
29 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
30 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
31 Patch0:         %{name}-byteorder.patch
32 Patch1:         %{name}-fixlibs.patch
33 Patch2:         %{name}-amfix.patch
34 Patch3:         %{name}-lpthread.patch
35 URL:            http://www.libsdl.org/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{!?_without_esound:BuildRequires:      esound-devel}
39 %{!?_without_arts:BuildRequires:        arts-devel}
40 BuildRequires:  gtk+-devel >= 1.2.1
41 BuildRequires:  XFree86-devel >= 4.0.2
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  perl-modules
44 %ifnarch sparc sparc64
45 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
46 %endif
47 %{?_with_svgalib:BuildRequires: svgalib-devel}
48 %{?_with_aalib:BuildRequires:   aalib-devel}
49 %{?_with_ggi:BuildRequires:     libggi-devel}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _prefix         /usr/X11R6
53 %define         _mandir         %{_prefix}/man
54
55 %description
56 SDL (Simple DirectMedia Layer) is a library that allows you portable,
57 low level access to a video framebuffer, audio output, mouse, and
58 keyboard. It can support both windowed and DGA modes of XFree86, and
59 it is designed to be portable - applications linked with SDL can also
60 be built on Win32 and BeOS.
61
62 %description -l pl
63 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
64 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
65 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
66 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
67 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
68
69 %description -l pt_BR
70 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
71 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
72
73 Essa biblioteca é usada por alguns jogos.
74
75 %package devel
76 Summary:        SDL - Header files
77 Summary(pl):    SDL - Pliki nag³ówkowe
78 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
79 Group:          X11/Libraries
80 Group(de):      X11/Libraries
81 Group(es):      X11/Bibliotecas
82 Group(fr):      X11/Librairies
83 Group(pl):      X11/Biblioteki
84 Group(pt_BR):   X11/Bibliotecas
85 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
86 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
87 Requires:       %{name} = %{version}
88 %ifnarch sparc sparc64
89 %{!?_without_alsa:Requires:     alsa-lib-devel}
90 %endif
91 %{!?_without_esound:Requires:   esound-devel}
92 %{!?_without_arts:Requires:     arts-devel}
93
94 %description devel
95 SDL - Header files.
96
97 %description -l pl devel
98 SDL - Pliki nag³ówkowe.
99
100 %description -l pt_BR devel
101 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
102 recursos para o desenvolvimento de aplicativos com SDL.
103
104 %package static
105 Summary:        SDL - static libraries
106 Summary(pl):    SDL - biblioteki statyczne
107 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
108 Group:          X11/Libraries
109 Group(de):      X11/Libraries
110 Group(es):      X11/Bibliotecas
111 Group(fr):      X11/Librairies
112 Group(pl):      X11/Biblioteki
113 Group(pt_BR):   X11/Bibliotecas
114 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
115 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
116 Requires:       %{name}-devel = %{version}
117
118 %description static
119 SDL - static libraries.
120
121 %description -l pl static
122 SDL - biblioteki statyczne.
123
124 %description -l pt_BR static
125 Biblioteca estática para desenvolvimento de aplicações com a SDL.
126
127 %prep
128 %setup -q
129 %patch0 -p1
130 %patch1 -p1
131 %patch2 -p1
132 %patch3 -p1
133
134 %build
135 aclocal
136 autoconf
137 automake -a -c
138 %configure \
139 %ifnarch sparc sparc64
140         %{!?_without_alsa:--enable-alsa} \
141 %endif
142         --enable-nasm \
143         --enable-pthreads \
144         --enable-pthread-sem \
145         --with-x \
146         --enable-video-x11-vm \
147         --enable-video-x11-dga \
148         --enable-video-x11-mtrr \
149         --enable-video-x11-dgamouse \
150         --enable-video-opengl \
151         %{!?_without_esound:--enable-esd} \
152         %{!?_without_arts:--enable-arts} \
153         %{?_with_svga:--enable-video-svga} \
154         %{?_with_aalib:--enable-video-aalib} \
155         %{?_with_ggi:--enable-video-ggi}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT \
162         m4datadir=%{_aclocaldir}
163
164 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
165
166 gzip -9nf BUGS CREDITS README TODO WhatsNew
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %files
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/lib*.so.*.*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
181 %attr(755,root,root) %{_bindir}/sdl-config
182 %attr(755,root,root) %{_libdir}/lib*.so
183 %attr(755,root,root) %{_libdir}/lib*.la
184 %{_libdir}/libSDLmain.a
185 %{_includedir}/SDL
186 %{_aclocaldir}/*
187 %{_mandir}/man3/*
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/lib*.a
This page took 0.037173 seconds and 3 git commands to generate.