]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- man regina fix by Piotr Michoński
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3 Summary:        Rexx interpreter
4 Summary(pl):    Interpreter jêzyka REXX
5 Name:           Regina
6 Version:        3.3
7 Release:        0.1
8 License:        GPL
9 Group:          Applications
10 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
11 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
12 Source1:        %{name}.init
13 Patch0:         %{name}-makefileinfix.patch
14 URL:            http://regina-rexx.sourceforge.net
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Provides:       rexx
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Regina is a Rexx interpreter that has been ported to most Unix
24 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
25 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
26 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
27 programming language that was designed to be easy to use for
28 inexperienced programmers yet powerful enough for experienced users.
29 It is also a language ideally suited as a macro language for other
30 applications.
31
32 There are two major goals for Regina:
33 - become 100% compliant with the ANSI Standard.
34 - be available on as many platforms as possible
35
36 %description -l pl
37 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
38 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
39 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
40 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
41 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
42 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
43 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
44 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
45
46 Dwa g³ówne cele tego interpretera, to
47 - Stuprocentowa kompatybilno¶æ ze standardemi ANSI
48 - dostêpno¶æ na jak najwiêkszej liczbie platform
49
50 %package devel
51 Summary:        Header files for Regina
52 Summary(pl):    Pliki nag³ówkowe dla Regina
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Development files for Regina.
58
59 %description devel -l pl
60 Pliki nag³ówkowe dla Regina.
61
62 %package libs
63 Summary:        Libraries for Regina
64 Summary(pl):    Biblioteki dla Regina
65 Group:          Libraries
66 Provides:       libregina.so
67 Provides:       libregina.so(REXXSAA_API)
68 Provides:       libregina.so(regina_2.0)
69
70 %description libs
71 Regina libraries.
72
73 %description libs -l pl
74 Biblioteki dla packietu Regina.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 ./configure
82 %{__make} \
83         CC="%{__cc}" \
84         CFLAGS="%{rpmcflags}"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_mandir}/man1}
89 %{__make} install \
90     DESTDIR=$RPM_BUILD_ROOT
91 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
92 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
93 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
94 rm -f $RPM_BUILD_ROOT/usr/man1/regina.1
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/chkconfig --add rxstack
101 %service rxstack restart
102
103 %preun
104 if [ "$1" = "0" ] ; then
105         %service rxstack stop
106         /sbin/chkconfig --del rxstack
107 fi
108
109 %post libs -p /sbin/ldconfig
110 %postun libs -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc COPYING-LIB README* demo
115 %attr(755,root,root) %{_bindir}/*
116 %attr(754,root,root) /etc/rc.d/init.d/rxstack
117 %dir %{_datadir}/regina
118 %attr(755,root,root) %{_datadir}/regina/*.rexx
119 %{_datadir}/regina/*.mtb
120 %{_mandir}/man1/regina.1*
121
122 %files libs
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/*.so
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/*.a
129 %{_includedir}/rexxsaa.h
This page took 0.058014 seconds and 3 git commands to generate.