]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- split into packages
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3
4 Summary:        Rexx interpreter
5 Summary(pl):    Interpreter jêzyka REXX
6 Name:           Regina
7 Version:        3.3
8 Release:        0.1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
13 Source1:        %{name}.init
14 Patch0:         %{name}-makefileinfix.patch
15 URL:            http://regina-rexx.sourceforge.net
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 Requires(post,preun):   /sbin/chkconfig
20 Provides:       rexx
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Regina is a Rexx interpreter that has been ported to most Unix
25 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
26 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
27 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
28 programming language that was designed to be easy to use for
29 inexperienced programmers yet powerful enough for experienced users.
30 It is also a language ideally suited as a macro language for other
31 applications.
32
33 There are two major goals for Regina:
34
35     - become 100% compliant with the ANSI Standard.
36     - be available on as many platforms as possible
37
38 %description -l pl
39 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
40 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
41 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
42 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
43 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
44 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
45 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
46 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
47
48 Dwa g³ówne cele tego interpretera, to
49  - Stuprocentowa kompatybilno¶æ ze standardemi ANSI
50  - dostêpno¶æ na jak najwiêkszej liczbie platform
51
52 %package devel
53 Summary:        Header files for Regina
54 Summary(pl):    Pliki nag³ówkowe dla Regina
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Development files for Regina.
60
61 %description devel -l pl
62 Pliki nag³ówkowe dla Regina.
63
64 %package libs
65 Summary:        Libraries for Regina
66 Summary(pl):    Biblioteki dla Regina
67 Group:          Libraries
68 Provides:       libregina.so
69 Provides:       libregina.so(REXXSAA_API)
70 Provides:       libregina.so(regina_2.0)
71
72 %description libs
73 Regina libraries.
74
75 %description libs -l pl
76 Biblioteki dla packietu Regina.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 ./configure
84 %{__make} \
85         CC="%{__cc}" \
86         CFLAGS="%{rpmcflags}"
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_mandir}/man1}
91 %{__make} install \
92     DESTDIR=$RPM_BUILD_ROOT
93 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
94 install $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1 $RPM_BUILD_ROOT%{_mandir}/man1/
95 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
96 rm -f $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 /sbin/chkconfig --add rxstack
103
104 %preun
105 if [ "$1" = "0" ] ; then
106         %service rxstack stop
107         /sbin/chkconfig --del rxstack
108 fi
109
110 %post libs -p /sbin/ldconfig
111 %postun libs -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc COPYING-LIB README* demo
116 %attr(755,root,root) %{_bindir}/*
117 %attr(754,root,root) /etc/rc.d/init.d/rxstack
118 %attr(755,root,root) %{_datadir}/regina/*.rexx
119 %{_datadir}/regina/*.mtb
120 %{_mandir}/man1/regina.1*
121
122 %files libs
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/*.so
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/*.a
129 %{_includedir}/rexxsaa.h
This page took 0.042033 seconds and 3 git commands to generate.