]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- small patch to fix build on amd64
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3 Summary:        Rexx interpreter
4 Summary(de.UTF-8):      Ein Interpreter für REXX
5 Summary(pl.UTF-8):      Interpreter języka REXX
6 Name:           Regina
7 Version:        3.4
8 Release:        0.1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  3300e28b39134211a45aedb0e760cd44
13 Source1:        %{name}.init
14 Patch0:         %{name}-x86_64.patch
15 URL:            http://regina-rexx.sourceforge.net
16 BuildRequires:  automake
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  sed >= 4.0
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 Provides:       rexx
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Regina is a Rexx interpreter that has been ported to most Unix
28 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
29 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
30 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
31 programming language that was designed to be easy to use for
32 inexperienced programmers yet powerful enough for experienced users.
33 It is also a language ideally suited as a macro language for other
34 applications.
35
36 There are two major goals for Regina:
37 - become 100% compliant with the ANSI Standard.
38 - be available on as many platforms as possible
39
40 %description -l de.UTF-8
41 Regina ist ein Rexx Interpreter der für die meisten Unix Platformen
42 übersetzt worden ist (Linux, FreeBSD, Solaris, AIX, HP-UX, usw.) und
43 auser dem auch für OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, Aros,
44 QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS und
45 OpenEdition. Rexx ist eine Programiersprache die für unerfahrene
46 Programierer entwickelt wurde aber Stark genug für erfahrene
47 Programierer ist. Es ist ebenfalls eine Sprache die sich ideal als
48 Makrosprache für andere Applikationen eignet.
49
50 Regina hat zwei Hauptziele:
51 - es soll 100% kompatibel mit dem ANSI Standard sein
52 - es soll auf so vielen Platformen wie nur möglich laufen
53
54 %description -l pl.UTF-8
55 Regina jest interpreterem języka REXX, który został już
56 przeniesiony na większość Unixowych platform (Linux, FreeBSD,
57 Solaris, AIX, HP-UX, itp.) a także OS/2, eCS, DOS, Win9x/Me/NT/2k/XP,
58 Amiga, AROS, QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS,
59 SkyOS and OpenEdition. Rexx jest językiem programowania, który
60 został zaprojektowany, by być prostym w użyciu przez
61 niedoświadczonych programistów oraz wystarczająco użytecznym, by
62 być używanym przez doświadczonych. Idealnie sprawdza się jako
63 język pisania makr dla innych aplikacji
64
65 Dwa główne cele tego interpretera, to
66 - Stuprocentowa kompatybilność ze standardem ANSI
67 - dostępność na jak największej liczbie platform
68
69 %package libs
70 Summary:        Libraries for Regina
71 Summary(de.UTF-8):      Regina Libraries
72 Summary(pl.UTF-8):      Biblioteki interpretera Regina
73 Group:          Libraries
74
75 %description libs
76 Regina libraries.
77
78 %description libs -l de.UTF-8
79 Regina Libraries.
80
81 %description libs -l pl.UTF-8
82 Biblioteki dla interpretera Regina.
83
84 %package devel
85 Summary:        Header files for Regina
86 Summary(de.UTF-8):      Header Dateien für Regina
87 Summary(pl.UTF-8):      Pliki nagłówkowe interpretera Regina
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description devel
92 Development files for Regina.
93
94 %description devel -l de.UTF-8
95 Header Dateien für Regina.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe interpretera Regina.
99
100 %package static
101 Summary:        Static Regina library
102 Summary(de.UTF-8):      Statische Regina Libraries
103 Summary(pl.UTF-8):      Statyczna biblioteka Regina
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Regina library.
109
110 %description static -l de.UTF-8
111 Statische Regina Libraries.
112
113 %description static -l pl.UTF-8
114 Statyczna biblioteka Regina.
115
116 %prep
117 %setup -q
118 %patch0 -p0
119
120 # hacks for weak tests for gcc
121 sed -i -e 's/gcc)/*gcc)/;s/= "gcc"/= "%{__cc}"/' configure
122 # unnecessary libs
123 sed -i -e 's/nsl nsl_s socket//' configure
124 # set soname
125 sed -i -e 's/\$(ABI) -shared/$(ABI) -Wl,-soname=${SHLPRE}${SHLFILE}${SHLPST}.\\$(ABI) -shared/' configure
126
127 %build
128 cp -f /usr/share/automake/config.* .
129 %configure2_13
130 %{__make} -j 1 \
131         CC="%{__cc}" \
132         CFLAGS="%{rpmcflags}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man1}
137
138 %{__make} install -j 1 \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
142 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
143 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
144 rm -f $RPM_BUILD_ROOT%{_prefix}/man1/regina.1
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add rxstack
151 %service rxstack restart
152
153 %preun
154 if [ "$1" = "0" ] ; then
155         %service rxstack stop
156         /sbin/chkconfig --del rxstack
157 fi
158
159 %post   libs -p /sbin/ldconfig
160 %postun libs -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc COPYING-LIB README* demo
165 %attr(755,root,root) %{_bindir}/*
166 %attr(754,root,root) /etc/rc.d/init.d/rxstack
167 %dir %{_datadir}/regina
168 %attr(755,root,root) %{_datadir}/regina/*.rexx
169 %{_datadir}/regina/*.mtb
170 %{_mandir}/man1/regina.1*
171
172 %files libs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libregina.so.*.*
175 %attr(755,root,root) %{_libdir}/librxtest*.so
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libregina.so
180 %{_includedir}/rexxsaa.h
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libregina.a
This page took 0.065612 seconds and 3 git commands to generate.