]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- release 1. works fine
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds (???)
3 Summary:        Rexx interpreter
4 Summary(de.UTF-8):      Ein Interpreter für REXX
5 Summary(pl.UTF-8):      Interpreter języka REXX
6 Name:           Regina
7 Version:        3.4
8 Release:        1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  3300e28b39134211a45aedb0e760cd44
13 Source1:        %{name}.init
14 Patch0:         %{name}-gci_convert.patch
15 URL:            http://regina-rexx.sourceforge.net
16 BuildRequires:  automake
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  sed >= 4.0
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 Provides:       rexx
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Regina is a Rexx interpreter that has been ported to most Unix
28 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
29 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
30 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
31 programming language that was designed to be easy to use for
32 inexperienced programmers yet powerful enough for experienced users.
33 It is also a language ideally suited as a macro language for other
34 applications.
35
36 There are two major goals for Regina:
37 - become 100% compliant with the ANSI Standard.
38 - be available on as many platforms as possible
39
40 %description -l de.UTF-8
41 Regina ist ein Rexx Interpreter der für die meisten Unix Platformen
42 übersetzt worden ist (Linux, FreeBSD, Solaris, AIX, HP-UX, usw.) und
43 auser dem auch für OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, Aros,
44 QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS und
45 OpenEdition. Rexx ist eine Programiersprache die für unerfahrene
46 Programierer entwickelt wurde aber Stark genug für erfahrene
47 Programierer ist. Es ist ebenfalls eine Sprache die sich ideal als
48 Makrosprache für andere Applikationen eignet.
49
50 Regina hat zwei Hauptziele:
51 - es soll 100% kompatibel mit dem ANSI Standard sein
52 - es soll auf so vielen Platformen wie nur möglich laufen
53
54 %description -l pl.UTF-8
55 Regina jest interpreterem języka REXX, który został już
56 przeniesiony na większość Unixowych platform (Linux, FreeBSD,
57 Solaris, AIX, HP-UX, itp.) a także OS/2, eCS, DOS, Win9x/Me/NT/2k/XP,
58 Amiga, AROS, QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS,
59 SkyOS and OpenEdition. Rexx jest językiem programowania, który
60 został zaprojektowany, by być prostym w użyciu przez
61 niedoświadczonych programistów oraz wystarczająco użytecznym, by
62 być używanym przez doświadczonych. Idealnie sprawdza się jako
63 język pisania makr dla innych aplikacji
64
65 Dwa główne cele tego interpretera, to
66 - Stuprocentowa kompatybilność ze standardem ANSI
67 - dostępność na jak największej liczbie platform
68
69 %package libs
70 Summary:        Libraries for Regina
71 Summary(de.UTF-8):      Regina Libraries
72 Summary(pl.UTF-8):      Biblioteki interpretera Regina
73 Group:          Libraries
74
75 %description libs
76 Regina libraries.
77
78 %description libs -l de.UTF-8
79 Regina Libraries.
80
81 %description libs -l pl.UTF-8
82 Biblioteki dla interpretera Regina.
83
84 %package devel
85 Summary:        Header files for Regina
86 Summary(de.UTF-8):      Header Dateien für Regina
87 Summary(pl.UTF-8):      Pliki nagłówkowe interpretera Regina
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description devel
92 Development files for Regina.
93
94 %description devel -l de.UTF-8
95 Header Dateien für Regina.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe interpretera Regina.
99
100 %package static
101 Summary:        Static Regina library
102 Summary(de.UTF-8):      Statische Regina Libraries
103 Summary(pl.UTF-8):      Statyczna biblioteka Regina
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Regina library.
109
110 %description static -l de.UTF-8
111 Statische Regina Libraries.
112
113 %description static -l pl.UTF-8
114 Statyczna biblioteka Regina.
115
116 %prep
117 %setup -q
118 %patch0 -p0
119
120 # unnecessary libs
121 sed -i -e 's/nsl nsl_s socket//' configure
122 # set soname
123 sed -i -e 's/\$(ABI) -shared/$(ABI) -Wl,-soname=${SHLPRE}${SHLFILE}${SHLPST}.\\$(ABI) -shared/' configure
124
125 %build
126 %configure
127 %{__make} -j 1 \
128         CC="%{__cc}" \
129         CFLAGS="%{rpmcflags}"
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man1}
134
135 %{__make} install -j 1 \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
139 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
140 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
141 rm -f $RPM_BUILD_ROOT%{_prefix}/man1/regina.1
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/chkconfig --add rxstack
148 %service rxstack restart
149
150 %preun
151 if [ "$1" = "0" ] ; then
152         %service rxstack stop
153         /sbin/chkconfig --del rxstack
154 fi
155
156 %post   libs -p /sbin/ldconfig
157 %postun libs -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc COPYING-LIB README* demo
162 %attr(755,root,root) %{_bindir}/*
163 %attr(754,root,root) /etc/rc.d/init.d/rxstack
164 %dir %{_datadir}/regina
165 %attr(755,root,root) %{_datadir}/regina/*.rexx
166 %{_datadir}/regina/*.mtb
167 %{_mandir}/man1/regina.1*
168
169 %files libs
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libregina.so.*.*
172 %attr(755,root,root) %{_libdir}/librxtest*.so
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libregina.so
177 %{_includedir}/rexxsaa.h
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libregina.a
This page took 0.061832 seconds and 3 git commands to generate.