]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- de supplement by -static
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3 Summary:        Rexx interpreter
4 Summary(de):    Ein Interpreter für REXX
5 Summary(pl):    Interpreter jêzyka REXX
6 Name:           Regina
7 Version:        3.3
8 Release:        0.1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
13 Source1:        %{name}.init
14 Patch0:         %{name}-makefileinfix.patch
15 URL:            http://regina-rexx.sourceforge.net
16 BuildRequires:  automake
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  sed >= 4.0
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 Provides:       rexx
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Regina is a Rexx interpreter that has been ported to most Unix
28 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
29 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
30 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
31 programming language that was designed to be easy to use for
32 inexperienced programmers yet powerful enough for experienced users.
33 It is also a language ideally suited as a macro language for other
34 applications.
35
36 There are two major goals for Regina:
37 - become 100% compliant with the ANSI Standard.
38 - be available on as many platforms as possible
39
40 %description -l de
41 Regina ist ein Rexx Interpreter der für die meisten Unix Platformen
42 übersetzt worden ist (Linux, FreeBSD, Solaris, AIX, HP-UX, usw.) und
43 auser dem auch für OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, Aros,
44 QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS und
45 OpenEdition. Rexx ist eine Programiersprache die für unerfahrene
46 Programierer entwickelt wurde aber Stark genug für erfahrene
47 Programierer ist. Es ist ebenfalls eine Sprache die sich ideal als
48 Makrosprache für andere Applikationen eignet.
49
50 Regina hat zwei Hauptziele:
51 - es soll 100% kompatibel mit dem ANSI Standard sein
52 - es soll auf so vielen Platformen wie nur möglich laufen
53
54 %description -l pl
55 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
56 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
57 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
58 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
59 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
60 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
61 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
62 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
63
64 Dwa g³ówne cele tego interpretera, to
65 - Stuprocentowa kompatybilno¶æ ze standardem ANSI
66 - dostêpno¶æ na jak najwiêkszej liczbie platform
67
68 %package libs
69 Summary:        Libraries for Regina
70 Summary(de):    Regina Libraries
71 Summary(pl):    Biblioteki interpretera Regina
72 Group:          Libraries
73
74 %description libs
75 Regina libraries.
76
77 %description libs -l de
78 Regina Libraries.
79
80 %description libs -l pl
81 Biblioteki dla interpretera Regina.
82
83 %package devel
84 Summary:        Header files for Regina
85 Summary(de):    Header Dateien für Regina
86 Summary(pl):    Pliki nag³ówkowe interpretera Regina
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description devel
91 Development files for Regina.
92
93 %description devel -l de
94 Header Dateien für Regina.
95
96 %description devel -l pl
97 Pliki nag³ówkowe interpretera Regina.
98
99 %package static
100 Summary:        Static Regina library
101 Summary(de):    Statische Regina Libraries
102 Summary(pl):    Statyczna biblioteka Regina
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static Regina library.
108
109 %description static -l pl
110 Statyczna biblioteka Regina.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 # hacks for weak tests for gcc
117 sed -i -e 's/gcc)/*gcc)/;s/= "gcc"/= "%{__cc}"/' configure
118 # unnecessary libs
119 sed -i -e 's/nsl nsl_s socket//' configure
120 # set soname
121 sed -i -e 's/\$(ABI) -shared/$(ABI) -Wl,-soname=${SHLPRE}${SHLFILE}${SHLPST}.\\$(ABI) -shared/' configure
122
123 %build
124 cp -f /usr/share/automake/config.* .
125 %configure2_13
126 %{__make} \
127         CC="%{__cc}" \
128         CFLAGS="%{rpmcflags}"
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man1}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
138 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
139 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
140 rm -f $RPM_BUILD_ROOT%{_prefix}/man1/regina.1
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 /sbin/chkconfig --add rxstack
147 %service rxstack restart
148
149 %preun
150 if [ "$1" = "0" ] ; then
151         %service rxstack stop
152         /sbin/chkconfig --del rxstack
153 fi
154
155 %post   libs -p /sbin/ldconfig
156 %postun libs -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc COPYING-LIB README* demo
161 %attr(755,root,root) %{_bindir}/*
162 %attr(754,root,root) /etc/rc.d/init.d/rxstack
163 %dir %{_datadir}/regina
164 %attr(755,root,root) %{_datadir}/regina/*.rexx
165 %{_datadir}/regina/*.mtb
166 %{_mandir}/man1/regina.1*
167
168 %files libs
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libregina.so.*.*
171 %attr(755,root,root) %{_libdir}/libtest*.so
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libregina.so
176 %{_includedir}/rexxsaa.h
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libregina.a
This page took 0.234264 seconds and 3 git commands to generate.