]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- up to 3.4, adapterized, patch not needed
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - use bconds
3 Summary:        Rexx interpreter
4 Summary(de.UTF-8):      Ein Interpreter für REXX
5 Summary(pl.UTF-8):      Interpreter języka REXX
6 Name:           Regina
7 Version:        3.4
8 Release:        0.1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
12 # Source0-md5:  3300e28b39134211a45aedb0e760cd44
13 Source1:        %{name}.init
14 URL:            http://regina-rexx.sourceforge.net
15 BuildRequires:  automake
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 BuildRequires:  sed >= 4.0
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       %{name}-libs = %{version}-%{release}
22 Provides:       rexx
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Regina is a Rexx interpreter that has been ported to most Unix
27 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
28 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
29 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
30 programming language that was designed to be easy to use for
31 inexperienced programmers yet powerful enough for experienced users.
32 It is also a language ideally suited as a macro language for other
33 applications.
34
35 There are two major goals for Regina:
36 - become 100% compliant with the ANSI Standard.
37 - be available on as many platforms as possible
38
39 %description -l de.UTF-8
40 Regina ist ein Rexx Interpreter der für die meisten Unix Platformen
41 übersetzt worden ist (Linux, FreeBSD, Solaris, AIX, HP-UX, usw.) und
42 auser dem auch für OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, Aros,
43 QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS und
44 OpenEdition. Rexx ist eine Programiersprache die für unerfahrene
45 Programierer entwickelt wurde aber Stark genug für erfahrene
46 Programierer ist. Es ist ebenfalls eine Sprache die sich ideal als
47 Makrosprache für andere Applikationen eignet.
48
49 Regina hat zwei Hauptziele:
50 - es soll 100% kompatibel mit dem ANSI Standard sein
51 - es soll auf so vielen Platformen wie nur möglich laufen
52
53 %description -l pl.UTF-8
54 Regina jest interpreterem języka REXX, który został już
55 przeniesiony na większość Unixowych platform (Linux, FreeBSD,
56 Solaris, AIX, HP-UX, itp.) a także OS/2, eCS, DOS, Win9x/Me/NT/2k/XP,
57 Amiga, AROS, QNX4.x, QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS,
58 SkyOS and OpenEdition. Rexx jest językiem programowania, który
59 został zaprojektowany, by być prostym w użyciu przez
60 niedoświadczonych programistów oraz wystarczająco użytecznym, by
61 być używanym przez doświadczonych. Idealnie sprawdza się jako
62 język pisania makr dla innych aplikacji
63
64 Dwa główne cele tego interpretera, to
65 - Stuprocentowa kompatybilność ze standardem ANSI
66 - dostępność na jak największej liczbie platform
67
68 %package libs
69 Summary:        Libraries for Regina
70 Summary(de.UTF-8):      Regina Libraries
71 Summary(pl.UTF-8):      Biblioteki interpretera Regina
72 Group:          Libraries
73
74 %description libs
75 Regina libraries.
76
77 %description libs -l de.UTF-8
78 Regina Libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki dla interpretera Regina.
82
83 %package devel
84 Summary:        Header files for Regina
85 Summary(de.UTF-8):      Header Dateien für Regina
86 Summary(pl.UTF-8):      Pliki nagłówkowe interpretera Regina
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description devel
91 Development files for Regina.
92
93 %description devel -l de.UTF-8
94 Header Dateien für Regina.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe interpretera Regina.
98
99 %package static
100 Summary:        Static Regina library
101 Summary(de.UTF-8):      Statische Regina Libraries
102 Summary(pl.UTF-8):      Statyczna biblioteka Regina
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static Regina library.
108
109 %description static -l de.UTF-8
110 Statische Regina Libraries.
111
112 %description static -l pl.UTF-8
113 Statyczna biblioteka Regina.
114
115 %prep
116 %setup -q
117
118 # hacks for weak tests for gcc
119 sed -i -e 's/gcc)/*gcc)/;s/= "gcc"/= "%{__cc}"/' configure
120 # unnecessary libs
121 sed -i -e 's/nsl nsl_s socket//' configure
122 # set soname
123 sed -i -e 's/\$(ABI) -shared/$(ABI) -Wl,-soname=${SHLPRE}${SHLFILE}${SHLPST}.\\$(ABI) -shared/' configure
124
125 %build
126 cp -f /usr/share/automake/config.* .
127 %configure2_13
128 %{__make} -j 1 \
129         CC="%{__cc}" \
130         CFLAGS="%{rpmcflags}"
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man1}
135
136 %{__make} install -j 1 \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
140 install regina.1 $RPM_BUILD_ROOT%{_mandir}/man1
141 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
142 rm -f $RPM_BUILD_ROOT%{_prefix}/man1/regina.1
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/chkconfig --add rxstack
149 %service rxstack restart
150
151 %preun
152 if [ "$1" = "0" ] ; then
153         %service rxstack stop
154         /sbin/chkconfig --del rxstack
155 fi
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc COPYING-LIB README* demo
163 %attr(755,root,root) %{_bindir}/*
164 %attr(754,root,root) /etc/rc.d/init.d/rxstack
165 %dir %{_datadir}/regina
166 %attr(755,root,root) %{_datadir}/regina/*.rexx
167 %{_datadir}/regina/*.mtb
168 %{_mandir}/man1/regina.1*
169
170 %files libs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libregina.so.*.*
173 %attr(755,root,root) %{_libdir}/librxtest*.so
174
175 %files devel
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libregina.so
178 %{_includedir}/rexxsaa.h
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libregina.a
This page took 0.078872 seconds and 3 git commands to generate.