]> git.pld-linux.org Git - packages/RealPlayer.git/blob - RealPlayer.spec
- provide helix-core
[packages/RealPlayer.git] / RealPlayer.spec
1 #
2 # Todo:
3 #       - replace mozilla-* plugins with browser-plugins
4 #       - add the licence agreement mechanism
5 #
6 %define         _name   realplay
7 Summary:        RealPlayer - RealAudio and RealVideo player
8 Summary(pl):    RealPlayer - odtwarzacz RealAudio i RealVideo
9 Name:           RealPlayer
10 %ifarch %{ix86}
11 %define         minor_ver       6
12 %else
13 %define         minor_ver       5
14 %endif
15 Version:        10.0.%{minor_ver}
16 Release:        0.1
17 License:        Helix DNA Technology Binary Research Use License (not distributable, see LICENSE)
18 Group:          X11/Applications/Multimedia
19 # download from https://helixcommunity.org/project/showfiles.php?group_id=154
20 %ifarch %{ix86}
21 Source0:        https://helixcommunity.org/download.php/1589/%{name}-%{version}.776-20050929.i586.rpm
22 # NoSource0-md5:        870215a8ed4f50c76bbc42212511e8e7
23 NoSource:       0
24 %endif
25 %ifarch ppc
26 Source1:        https://helixcommunity.org/download.php/1346/realplay-%{version}.756-linux-2.2-libc6-gcc32-powerpc.bin
27 # NoSource1-md5:        d87d35617f07ab9435341f37229dd3ae
28 NoSource:       1
29 %endif
30 URL:            http://www.real.com/
31 BuildRequires:  cpio
32 BuildRequires:  sed >= 4.0
33 Provides:       helix-core
34 Requires:       sed >= 4.0
35 Obsoletes:      G2player
36 Obsoletes:      RealPlayer-gnome
37 Conflicts:      realplayer
38 ExclusiveArch:  %{ix86} ppc
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Streaming audio/video/flash/pix/text player.
43
44 %description -l pl
45 Odtwarzacz strumieni audio/video/flash/pix/tekst.
46
47 %package -n mozilla-plugin-%{name}
48 Summary:        RealPlayer Mozilla plugin
49 Summary(pl):    Wtyczka Mozilli RealPlayer
50 Group:          X11/Applications/Multimedia
51 PreReq:         mozilla-embedded
52 Requires:       %{name} = %{version}-%{release}
53
54 %description -n mozilla-plugin-%{name}
55 RealPlayer Mozilla plugin
56
57 %description -n mozilla-plugin-%{name} -l pl
58 Wtyczka Mozilli RealPlayer
59
60 %package -n mozilla-firefox-plugin-%{name}
61 Summary:        RealPlayer Mozilla Firefox plugin
62 Summary(pl):    Wtyczka Mozilli Firefox RealPlayer
63 Group:          X11/Applications/Multimedia
64 PreReq:         mozilla-firefox
65 Requires:       %{name} = %{version}-%{release}
66
67 %description -n mozilla-firefox-plugin-%{name}
68 RealPlayer Mozilla plugin
69
70 %description -n mozilla-firefox-plugin-%{name} -l pl
71 Wtyczka Mozilli RealPlayer
72
73 %prep
74 %setup -q -c -T
75 %ifarch %{ix86}
76 rpm2cpio %{SOURCE0} | cpio -dimu
77 mv -f usr/local/RealPlayer/* .
78 %endif
79 %ifarch ppc
80 dd if=%{SOURCE1} bs=1 skip=158895 | tar xjf -
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_desktopdir} \
86         $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins \
87         $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins \
88         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name},%{_datadir}/locale} \
89         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{48x48,128x128}/mimetypes \
90         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,32x32,48x48,128x128}/apps
91
92 cp -a codecs common plugins lib $RPM_BUILD_ROOT%{_libdir}/%{_name}
93
94 icons="mime-application-generic \
95 mime-application-ogg \
96 mime-application-ram \
97 mime-application-rpm \
98 mime-application-smil \
99 mime-audio-aiff \
100 mime-audio-au \
101 mime-audio-generic \
102 mime-audio-mp3 \
103 mime-audio-mp4 \
104 mime-audio-ogg \
105 mime-audio-ra \
106 mime-audio-wav \
107 mime-text-realtext \
108 mime-video-avi \
109 mime-video-generic \
110 mime-video-mov \
111 mime-video-ogg \
112 mime-video-rv \
113 mime-video-swf"
114
115 cd share/icons
116 for i in $icons; 
117 do
118 install ${i}_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/mimetypes/${i}.png
119 # SIC! there is no 192 size defined in hicolor, therefore use 128
120 install ${i}_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/mimetypes/${i}.png
121 done
122 install realplay_16x16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/realplay.png
123 install realplay_32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/realplay.png
124 install realplay_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/realplay.png
125 install realplay_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/apps/realplay.png
126 cd -
127
128 cp -rf share/locale/* $RPM_BUILD_ROOT%{_datadir}/locale
129
130 install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
131 install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
132
133 install realplay* $RPM_BUILD_ROOT%{_libdir}/%{_name}
134 ln -sf ../lib/%{_name}/realplay $RPM_BUILD_ROOT%{_bindir}/realplay
135
136 install share/realplay.desktop $RPM_BUILD_ROOT%{_desktopdir}
137
138 install -d $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/{default,realplay}
139
140 install share/realplay/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/realplay
141 install share/default/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/default
142 install share/*.html $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
143 install share/*.css $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
144
145 %{__sed} -i -e 's&#[ \t]*HELIX_LIBS[ \t]*=.*$&HELIX_LIBS=%{_libdir}/%{_name} ; export HELIX_LIBS&' \
146         $RPM_BUILD_ROOT%{_libdir}/realplay/realplay
147
148 # "player" and "widget" domains
149 %find_lang %{name} --all-name
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 umask 022
156 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
157
158 %postun
159 umask 022
160 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %doc LICENSE README 
165 %attr(755,root,root) %{_bindir}/realplay
166 %dir %{_libdir}/%{_name}
167 %dir %{_libdir}/%{_name}/codecs
168 %attr(755,root,root) %{_libdir}/%{_name}/codecs/*.so*
169 %dir %{_libdir}/%{_name}/common
170 %attr(755,root,root) %{_libdir}/%{_name}/common/*.so*
171 %dir %{_libdir}/%{_name}/lib
172 %attr(755,root,root) %{_libdir}/%{_name}/lib/*.so*
173 %dir %{_libdir}/%{_name}/plugins
174 %attr(755,root,root) %{_libdir}/%{_name}/plugins/*.so*
175 %attr(755,root,root) %{_libdir}/%{_name}/realplay
176 %attr(755,root,root) %{_libdir}/%{_name}/realplay.bin
177
178 %{_libdir}/%{_name}/share
179
180 %{_iconsdir}/hicolor/*/*/*.png
181 %{_desktopdir}/*.desktop
182
183 %files -n mozilla-plugin-%{name}
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/mozilla/plugins/*.so
186 %{_libdir}/mozilla/plugins/*.xpt
187
188 %files -n mozilla-firefox-plugin-%{name}
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
191 %{_libdir}/mozilla-firefox/plugins/*.xpt
This page took 0.21002 seconds and 4 git commands to generate.