]> git.pld-linux.org Git - packages/RealPlayer.git/blob - RealPlayer.spec
- 10.0.7 for x86 (dont know any serious D/L link but since its NoSource
[packages/RealPlayer.git] / RealPlayer.spec
1 #
2 # Todo:
3 #       - add the licence agreement mechanism
4 #
5 %define         _name   realplay
6 Summary:        RealPlayer - RealAudio and RealVideo player
7 Summary(pl):    RealPlayer - odtwarzacz RealAudio i RealVideo
8 Name:           RealPlayer
9 %ifarch %{ix86}
10 %define         minor_ver       7
11 %else
12 %define         minor_ver       5
13 %endif
14 Version:        10.0.%{minor_ver}
15 Release:        1
16 License:        Helix DNA Technology Binary Research Use License (not distributable, see LICENSE)
17 Group:          X11/Applications/Multimedia
18 # download from https://helixcommunity.org/project/showfiles.php?group_id=154
19 %ifarch %{ix86}
20 Source0:        RealPlayer10GOLD.rpm
21 # NoSource0-md5:        3de2e377fd6f00ea1de8f3016469fe5e
22 NoSource:       0
23 %endif
24 %ifarch ppc
25 Source1:        https://helixcommunity.org/download.php/1346/realplay-%{version}.756-linux-2.2-libc6-gcc32-powerpc.bin
26 # NoSource1-md5:        d87d35617f07ab9435341f37229dd3ae
27 NoSource:       1
28 %endif
29 URL:            http://www.real.com/linux/
30 BuildRequires:  cpio
31 BuildRequires:  rpmbuild(macros) >= 1.312
32 BuildRequires:  sed >= 4.0
33 Provides:       helix-core
34 Requires:       sed >= 4.0
35 Obsoletes:      G2player
36 Obsoletes:      RealPlayer-gnome
37 Conflicts:      realplayer
38 ExclusiveArch:  %{ix86} ppc
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _plugindir      %{_libdir}/browser-plugins
42 %define         browsers        mozilla, mozilla-firefox, netscape, seamonkey
43
44 %description
45 Streaming audio/video/flash/pix/text player.
46
47 %description -l pl
48 Odtwarzacz strumieni audio/video/flash/pix/tekst.
49
50 %package -n browser-plugin-%{name}
51 Summary:        RealPlayer plugin for WWW browsers
52 Summary(pl):    Wtyczka RealPlayer do przegl±darek WWW
53 Group:          X11/Applications/Multimedia
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       browser-plugins(%{_target_base_arch})
56
57 %description -n browser-plugin-%{name}
58 RealPlayer plugin for WWW browsers.
59
60 Supported browsers: %{browsers}.
61
62 %description -n browser-plugin-%{name} -l pl
63 Wtyczka RealPlayer dla przegl±darek WWW.
64
65 Obs³ugiwane przegl±darki: %{browsers}.
66
67 %prep
68 %setup -q -c -T
69 %ifarch %{ix86}
70 rpm2cpio %{SOURCE0} | cpio -dimu
71 mv -f usr/local/RealPlayer/* .
72 %endif
73 %ifarch ppc
74 dd if=%{SOURCE1} bs=1 skip=158895 | tar xjf -
75 %endif
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_desktopdir} \
80         $RPM_BUILD_ROOT%{_plugindir} \
81         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name},%{_datadir}/locale} \
82         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{48x48,128x128}/mimetypes \
83         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,32x32,48x48,128x128}/apps
84
85 cp -a codecs common plugins lib $RPM_BUILD_ROOT%{_libdir}/%{_name}
86
87 icons="mime-application-generic \
88 mime-application-ogg \
89 mime-application-ram \
90 mime-application-rpm \
91 mime-application-smil \
92 mime-audio-aiff \
93 mime-audio-au \
94 mime-audio-generic \
95 mime-audio-mp3 \
96 mime-audio-mp4 \
97 mime-audio-ogg \
98 mime-audio-ra \
99 mime-audio-wav \
100 mime-text-realtext \
101 mime-video-avi \
102 mime-video-generic \
103 mime-video-mov \
104 mime-video-ogg \
105 mime-video-rv \
106 mime-video-swf"
107
108 cd share/icons
109 for i in $icons; 
110 do
111 install ${i}_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/mimetypes/${i}.png
112 # SIC! there is no 192 size defined in hicolor, therefore use 128
113 install ${i}_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/mimetypes/${i}.png
114 done
115 install realplay_16x16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/realplay.png
116 install realplay_32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/realplay.png
117 install realplay_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/realplay.png
118 install realplay_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/apps/realplay.png
119 cd -
120
121 cp -rf share/locale/* $RPM_BUILD_ROOT%{_datadir}/locale
122
123 install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
124
125 install realplay* $RPM_BUILD_ROOT%{_libdir}/%{_name}
126 ln -sf ../lib/%{_name}/realplay $RPM_BUILD_ROOT%{_bindir}/realplay
127
128 install share/realplay.desktop $RPM_BUILD_ROOT%{_desktopdir}
129
130 install -d $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/{default,realplay}
131
132 install share/realplay/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/realplay
133 install share/default/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/default
134 install share/*.html $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
135 install share/*.css $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
136
137 %{__sed} -i -e 's&#[ \t]*HELIX_LIBS[ \t]*=.*$&HELIX_LIBS=%{_libdir}/%{_name} ; export HELIX_LIBS&' \
138         $RPM_BUILD_ROOT%{_libdir}/realplay/realplay
139
140 # "player" and "widget" domains
141 %find_lang %{name} --all-name
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 umask 022
148 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
149 %update_icon_cache hicolor
150
151 %postun
152 umask 022
153 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
154 %update_icon_cache hicolor
155
156 %triggerin -- mozilla-firefox
157 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
158
159 %triggerun -- mozilla-firefox
160 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
161
162 %triggerin -- mozilla
163 %nsplugin_install -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
164
165 %triggerun -- mozilla
166 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
167
168 %triggerin -- konqueror
169 %nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nphelix.so
170
171 %triggerun -- konqueror
172 %nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nphelix.so
173
174 %triggerin -- opera
175 %nsplugin_install -d %{_libdir}/opera/plugins nphelix.so
176
177 %triggerun -- opera
178 %nsplugin_uninstall -d %{_libdir}/opera/plugins nphelix.so
179
180 %triggerin -- seamonkey
181 %nsplugin_install -d %{_libdir}/seamonkey/plugins nphelix.so nphelix.xpt
182
183 %triggerun -- seamonkey
184 %nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nphelix.so nphelix.xpt
185
186 # as rpm removes the old obsoleted package files after the triggers
187 # above are ran, add another trigger to make the links there.
188 %triggerpostun -- mozilla-firefox-plugin-macromedia-flash
189 %nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
190
191 %triggerpostun -- mozilla-plugin-macromedia-flash
192 %nsplugin_install -f -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc LICENSE README 
197 %attr(755,root,root) %{_bindir}/realplay
198 %dir %{_libdir}/%{_name}
199 %dir %{_libdir}/%{_name}/codecs
200 %attr(755,root,root) %{_libdir}/%{_name}/codecs/*.so*
201 %dir %{_libdir}/%{_name}/common
202 %attr(755,root,root) %{_libdir}/%{_name}/common/*.so*
203 %dir %{_libdir}/%{_name}/lib
204 %attr(755,root,root) %{_libdir}/%{_name}/lib/*.so*
205 %dir %{_libdir}/%{_name}/plugins
206 %attr(755,root,root) %{_libdir}/%{_name}/plugins/*.so*
207 %attr(755,root,root) %{_libdir}/%{_name}/realplay
208 %attr(755,root,root) %{_libdir}/%{_name}/realplay.bin
209
210 %{_libdir}/%{_name}/share
211
212 %{_iconsdir}/hicolor/*/*/*.png
213 %{_desktopdir}/*.desktop
214
215 %files -n browser-plugin-%{name}
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_plugindir}/*.so
218 %{_plugindir}/*.xpt
This page took 0.06426 seconds and 3 git commands to generate.