]> git.pld-linux.org Git - packages/R.git/blobdiff - R.spec
S: rkward (gui)
[packages/R.git] / R.spec
diff --git a/R.spec b/R.spec
index f7a5c7b93929eb93c347a22e19122b26e8007847..f60e849bcb410bef0f4457c645473a401a0da9d9 100644 (file)
--- a/R.spec
+++ b/R.spec
@@ -1,57 +1,69 @@
+#
+# Conditional build
+%bcond_without tcl             # disable tcl support
+%bcond_without tests           # do not run "make check"
+#
+# NOTE:
+# - /etc/localtime must be present for tests to work
+#
 # TODO:
+# - faulty build on i486 (test stats-Ex.R):
+#      error in optim(init[mask], getLike, method = "L-BFGS-B", lower = rep(0,  :
+#          non-finite value supplied by optim
 # - script for rpm to autoprovides/autorequires R internals
 #
-%define        KernSmooth_version      2.22r19
-%define        VR_version              7.2r30
-%define        boot_version            1.2r27
-%define        cluster_version         1.11.4
-%define        foreign_version         0.8r18
-%define        lattice_version         0.14r16
-%define        mgcv_version            1.3r22
-%define        nlme_version            3.1r78
-%define        rpart_version           3.1r33
-%define        survival_version        2.30
-
 %include       /usr/lib/rpm/macros.perl
 Summary:       A language for data analysis and graphics
-Summary(pl):   Jêzyk do analizy danych oraz grafiki
+Summary(pl.UTF-8):     Język do analizy danych oraz grafiki
 Name:          R
-Version:       2.4.1
-Release:       0.2
+Version:       2.11.0
+Release:       2
 License:       Mixed (distributable), mostly GPL
 Group:         Development/Languages
 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
 Source0:       ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
-# Source0-md5: 92b33fd2c3e770d595c1a472889230d5
+# Source0-md5: c6c1e866299f533617750889c729bfb3
 Source1:       %{name}.desktop
 URL:           http://www.r-project.org/
-BuildRequires: XFree86-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: blas-devel
 BuildRequires: bzip2-devel
+BuildRequires: cairo-devel
 BuildRequires: gcc-c++
-BuildRequires: gcc-g77
+BuildRequires: gcc-fortran
 BuildRequires: gettext-devel
-BuildRequires: lapack-devel
+BuildRequires: lapack-devel >= 3.1.1-4
+BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.0.5
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2.6.26
-#BuildRequires:        lpr
+BuildRequires: pango-devel
 BuildRequires: pcre-devel
 BuildRequires: perl-base >= 1:5.6
+BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
-BuildRequires: tcl-devel
+%{?with_tcl:BuildRequires:     tcl-devel}
 BuildRequires: tetex-dvips
 BuildRequires: tetex-latex
 BuildRequires: tetex-pdftex
-BuildRequires: tk-devel
+%{?with_tcl:BuildRequires:     tk-devel}
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xz-devel
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.1.3
 #Requires:     lpr
+Requires(post):        perl-base
+Requires(post):        textutils
+Suggests:      rkward
+Obsoletes:     R-base
+Obsoletes:     R-contrib
+Obsoletes:     R-recommended
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -65,166 +77,93 @@ Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
 resulting language is very similar in appearance to S, the underlying
 implementation and semantics are derived from Scheme.
 
-%description -l pl
-System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
-oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
-niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
+%description -l pl.UTF-8
+System do obliczeń statystycznych i grafiki. R składa się z języka
+oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
+niektórych funkcji systemowych oraz możliwością uruchamiania programów
 zapisanych w skryptach.
 
-Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
+Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
-implementacja i semantyka wywodzi siê ze Scheme.
-
-%package base
-Summary:       The R base distribution
-Summary(pl):   Podstawowa dystrybucja R
-License:       GPL v2 / LGPL
-Group:         Development/Languages
-Requires(post):        perl-base
-Requires(post):        textutils
-Provides:      R-cran-base
-Provides:      R-cran-datasets
-Provides:      R-cran-grDevices
-Provides:      R-cran-graphics
-Provides:      R-cran-grid
-Provides:      R-cran-methods
-Provides:      R-cran-splines
-Provides:      R-cran-stats
-Provides:      R-cran-stats4
-Provides:      R-cran-tcltk
-Provides:      R-cran-tools
-Provides:      R-cran-utils
-
-%description base
-R is a language and run-time environment for carrying out interactive
-statistical data analysis. It is not entirely dissimilar to the S
-language developed at AT&T Bell Laboratories (and now Lucent
-Technologies). Indeed, S users will find the environment quite
-familiar and a good deal of S software will run without change under
-R.
-
-%description base -l pl
-R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
-analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
-S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
-mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
-oprogramowania w S bêdzie dzia³a³a bez zmian w R.
-
-%package recommended
-Summary:       Recommended contributed packages for the R language
-Summary(pl):   Zalecane dodatkowe pakiety do jêzyka R
-License:       GPL, free or free for non-commercial use
-Group:         Development/Languages
-URL:           http://www.ci.tuwien.ac.at/R/
-Requires(post,postun): R-base
-Requires(post,postun): perl-base
-Requires(post,postun): textutils
-Requires:      R-base = %{version}-%{release}
-Obsoletes:     R-cran-KernSmooth
-Obsoletes:     R-cran-VR
-Obsoletes:     R-cran-MASS
-Obsoletes:     R-cran-class
-Obsoletes:     R-cran-nnet
-Obsoletes:     R-cran-spatial
-Obsoletes:     R-cran-boot
-Obsoletes:     R-cran-cluster
-Obsoletes:     R-cran-foreign
-Obsoletes:     R-cran-lattice
-Obsoletes:     R-cran-mgcv
-Obsoletes:     R-cran-nlme
-Obsoletes:     R-cran-rpart
-Obsoletes:     R-cran-survival
-Provides:      R-cran-KernSmooth = %{KernSmooth_version}
-Provides:      R-cran-VR = %{VR_version}
-Provides:      R-cran-MASS = %{VR_version}
-Provides:      R-cran-class = %{VR_version}
-Provides:      R-cran-nnet = %{VR_version}
-Provides:      R-cran-spatial = %{VR_version}
-Provides:      R-cran-boot = %{boot_version}
-Provides:      R-cran-cluster = %{cluster_version}
-Provides:      R-cran-foreign = %{foreign_version}
-Provides:      R-cran-lattice = %{lattice_version}
-Provides:      R-cran-mgcv = %{mgcv_version}
-Provides:      R-cran-nlme = %{nlme_version}
-Provides:      R-cran-rpart = %{rpart_version}
-Provides:      R-cran-survival = %{survival_version}
-Obsoletes:     R-contrib
-
-%description recommended
-Packages which extend the capabilities of the R base distribution and
-are distributed on the Comprehensive R Archive Network (CRAN).
-
-%description recommended -l pl
-Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
-dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
+implementacja i semantyka wywodzi się ze Scheme.
 
 %prep
 %setup -q
 
 %build
+%{__aclocal} -I m4
+%{__autoconf}
 %configure \
        --enable-R-shlib \
        --enable-linux-lfs \
        --with-system-zlib \
        --with-system-bzlib \
        --with-system-pcre \
+       --with-system-xz \
        --with-libpng \
        --with-jpeglib \
        --with-blas \
        --with-lapack \
        --with-readline \
-       --with-tcltk \
+       --with%{!?with_tcl:out}-tcltk \
+       --with-cairo \
+       --with-libpng \
+       --with-jpeglib \
+       --with-system-zlib \
+       --with-system-bzlib \
+       --with-system-pcre \
+       --with-iconv \
+       --with-ICU \
+       --with-x \
        --with-recommended-packages
 
 %{__make}
-LANG=C LC_ALL=C %{__make} check
-%{__make} docs
-%{__make} help
-%{__make} html
-%{__make} info
+%if %{with tests}
+%{__make} check
+%endif
+%{__make} docs pdf info
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
 
-%{__make} install \
-       rhome=$RPM_BUILD_ROOT%{_libdir}/R \
-       mandir=$RPM_BUILD_ROOT%{_mandir} \
-       bindir=$RPM_BUILD_ROOT%{_bindir} \
-
+%{__make} -j1 install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
-find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
-rm $RPM_BUILD_ROOT%{_bindir}/%{name}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
-ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
 
-(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/perl/R/
-ln -s * $RPM_BUILD_ROOT%{perl_vendorlib}/R/)
-(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/perl/Text
-ln -s * $RPM_BUILD_ROOT%{perl_vendorlib}/Text/)
+(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
+for f in * ; do
+  ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
+done)
+(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
+for f in * ; do
+  ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
+done)
+
+rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/R
+rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/File
+mv    $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-(cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
- R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
-/sbin/ldconfig
-
-%postun        -p /sbin/ldconfig
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
-%files base
+%files
 %defattr(644,root,root,755)
 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
 
 %{_mandir}/man1/R.1*
+%{_mandir}/man1/Rscript*
 %attr(755,root,root) %{_bindir}/R
+%attr(755,root,root) %{_bindir}/Rscript
 %dir %{_libdir}/R
 %attr(755,root,root) %{_libdir}/R/bin
 %attr(755,root,root) %{_libdir}/libR*.so
@@ -243,26 +182,23 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/R/doc/html
 %{_libdir}/R/doc/html/*.css
 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
-%{_libdir}/R/doc/html/packages-head.html
+%{_libdir}/R/doc/html/packages-head*.html
 %{_libdir}/R/doc/html/*.jpg
-%dir %{_libdir}/R/doc/html/search
-%{_libdir}/R/doc/html/search/[A-Z]*
-%ghost %{_libdir}/R/doc/html/search/index.txt
 %ghost %{_libdir}/R/doc/html/packages.html
 %{_desktopdir}/*.desktop
 
-%dir %{perl_vendorlib}/R
-%{perl_vendorlib}/R/*
-%{perl_vendorlib}/Text/*
+%{perl_vendorlib}/R
 
 %attr(755,root,root) %{_libdir}/%{name}/modules
 
 %{_libdir}/%{name}/library/KernSmooth
 %{_libdir}/%{name}/library/MASS
+%{_libdir}/%{name}/library/Matrix
 %{_libdir}/%{name}/library/base
 %{_libdir}/%{name}/library/boot
 %{_libdir}/%{name}/library/class
 %{_libdir}/%{name}/library/cluster
+%{_libdir}/%{name}/library/codetools
 %{_libdir}/%{name}/library/datasets
 %{_libdir}/%{name}/library/foreign
 %{_libdir}/%{name}/library/grDevices
@@ -275,13 +211,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/library/nnet
 %{_libdir}/%{name}/library/rpart
 %{_libdir}/%{name}/library/spatial
-%{_libdir}/%{name}/library/survival
 %{_libdir}/%{name}/library/splines
 %{_libdir}/%{name}/library/stats
 %{_libdir}/%{name}/library/stats4
+%{_libdir}/%{name}/library/survival
 %{_libdir}/%{name}/library/tcltk
 %{_libdir}/%{name}/library/tools
 %{_libdir}/%{name}/library/utils
 
-%files recommended
-%defattr(644,root,root,755)
+%{_pkgconfigdir}/*.pc
This page took 0.114931 seconds and 4 git commands to generate.