]> git.pld-linux.org Git - packages/R.git/blobdiff - R.spec
S: rkward (gui)
[packages/R.git] / R.spec
diff --git a/R.spec b/R.spec
index 014b467ae0765f4cc62714054c6e9fcaf2d5cb40..f60e849bcb410bef0f4457c645473a401a0da9d9 100644 (file)
--- a/R.spec
+++ b/R.spec
@@ -3,32 +3,26 @@
 %bcond_without tcl             # disable tcl support
 %bcond_without tests           # do not run "make check"
 #
+# NOTE:
+# - /etc/localtime must be present for tests to work
+#
 # TODO:
-# - WTF is empty -recommended package with P/O which belong to -base ???
+# - faulty build on i486 (test stats-Ex.R):
+#      error in optim(init[mask], getLike, method = "L-BFGS-B", lower = rep(0,  :
+#          non-finite value supplied by optim
 # - script for rpm to autoprovides/autorequires R internals
 #
-%define        KernSmooth_version      2.22r22
-%define        VR_version              7.2r45
-%define        boot_version            1.2r34
-%define        cluster_version         1.11.11
-%define        foreign_version         0.8r29
-%define        lattice_version         0.17r17
-%define        mgcv_version            1.4r1.1
-%define        nlme_version            3.1r89
-%define        rpart_version           3.1r42
-%define        survival_version        2.34r1
-
 %include       /usr/lib/rpm/macros.perl
 Summary:       A language for data analysis and graphics
 Summary(pl.UTF-8):     Język do analizy danych oraz grafiki
 Name:          R
-Version:       2.8.1
-Release:       0.1
+Version:       2.11.0
+Release:       2
 License:       Mixed (distributable), mostly GPL
 Group:         Development/Languages
 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
 Source0:       ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
-# Source0-md5: acd40621b8942a2464daa2f9cef3273d
+# Source0-md5: c6c1e866299f533617750889c729bfb3
 Source1:       %{name}.desktop
 URL:           http://www.r-project.org/
 BuildRequires: autoconf
@@ -49,6 +43,7 @@ BuildRequires:        libxml2-devel >= 2.6.26
 BuildRequires: pango-devel
 BuildRequires: pcre-devel
 BuildRequires: perl-base >= 1:5.6
+BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
 %{?with_tcl:BuildRequires:     tcl-devel}
@@ -59,9 +54,16 @@ BuildRequires:       tetex-pdftex
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXmu-devel
 BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xz-devel
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.1.3
 #Requires:     lpr
+Requires(post):        perl-base
+Requires(post):        textutils
+Suggests:      rkward
+Obsoletes:     R-base
+Obsoletes:     R-contrib
+Obsoletes:     R-recommended
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -85,99 +87,19 @@ Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
 implementacja i semantyka wywodzi się ze Scheme.
 
-%package base
-Summary:       The R base distribution
-Summary(pl.UTF-8):     Podstawowa dystrybucja R
-License:       GPL v2 / LGPL
-Group:         Development/Languages
-Requires(post):        perl-base
-Requires(post):        textutils
-Provides:      R-cran-base
-Provides:      R-cran-datasets
-Provides:      R-cran-grDevices
-Provides:      R-cran-graphics
-Provides:      R-cran-grid
-Provides:      R-cran-methods
-Provides:      R-cran-splines
-Provides:      R-cran-stats
-Provides:      R-cran-stats4
-Provides:      R-cran-tcltk
-Provides:      R-cran-tools
-Provides:      R-cran-utils
-
-%description base
-R is a language and run-time environment for carrying out interactive
-statistical data analysis. It is not entirely dissimilar to the S
-language developed at AT&T Bell Laboratories (and now Lucent
-Technologies). Indeed, S users will find the environment quite
-familiar and a good deal of S software will run without change under
-R.
-
-%description base -l pl.UTF-8
-R jest językiem i środowiskiem uruchomieniowym do interaktywnej
-analizy danych statystycznych. R nie jest całkowicie zgodny z językiem
-S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
-mimo to użytkownicy S zauważą zbliżone środowisko, a duża część
-oprogramowania w S będzie działała bez zmian w R.
-
-%package recommended
-Summary:       Recommended contributed packages for the R language
-Summary(pl.UTF-8):     Zalecane dodatkowe pakiety do języka R
-License:       GPL, free or free for non-commercial use
-Group:         Development/Languages
-URL:           http://www.ci.tuwien.ac.at/R/
-Requires(post,postun): R-base = %{version}-%{release}
-Requires(post,postun): perl-base
-Requires(post,postun): textutils
-Requires:      R-base = %{version}-%{release}
-Provides:      R-cran-KernSmooth = %{KernSmooth_version}
-Provides:      R-cran-MASS = %{VR_version}
-Provides:      R-cran-VR = %{VR_version}
-Provides:      R-cran-boot = %{boot_version}
-Provides:      R-cran-class = %{VR_version}
-Provides:      R-cran-cluster = %{cluster_version}
-Provides:      R-cran-foreign = %{foreign_version}
-Provides:      R-cran-lattice = %{lattice_version}
-Provides:      R-cran-mgcv = %{mgcv_version}
-Provides:      R-cran-nlme = %{nlme_version}
-Provides:      R-cran-nnet = %{VR_version}
-Provides:      R-cran-rpart = %{rpart_version}
-Provides:      R-cran-spatial = %{VR_version}
-Provides:      R-cran-survival = %{survival_version}
-Obsoletes:     R-contrib
-Obsoletes:     R-cran-KernSmooth
-Obsoletes:     R-cran-MASS
-Obsoletes:     R-cran-VR
-Obsoletes:     R-cran-boot
-Obsoletes:     R-cran-class
-Obsoletes:     R-cran-cluster
-Obsoletes:     R-cran-foreign
-Obsoletes:     R-cran-lattice
-Obsoletes:     R-cran-mgcv
-Obsoletes:     R-cran-nlme
-Obsoletes:     R-cran-nnet
-Obsoletes:     R-cran-rpart
-Obsoletes:     R-cran-spatial
-Obsoletes:     R-cran-survival
-
-%description recommended
-Packages which extend the capabilities of the R base distribution and
-are distributed on the Comprehensive R Archive Network (CRAN).
-
-%description recommended -l pl.UTF-8
-Pakiety rozszerzające możliwości podstawowej dystrybucji języka R,
-dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
-
 %prep
 %setup -q
 
 %build
+%{__aclocal} -I m4
+%{__autoconf}
 %configure \
        --enable-R-shlib \
        --enable-linux-lfs \
        --with-system-zlib \
        --with-system-bzlib \
        --with-system-pcre \
+       --with-system-xz \
        --with-libpng \
        --with-jpeglib \
        --with-blas \
@@ -199,25 +121,21 @@ dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
 %if %{with tests}
 %{__make} check
 %endif
-%{__make} docs help html info
+%{__make} docs pdf info
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
-find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
-rm $RPM_BUILD_ROOT%{_bindir}/%{name}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
-ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
 
 (cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
 for f in * ; do
@@ -228,21 +146,17 @@ for f in * ; do
   ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
 done)
 
-rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/{Text,R}
-rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/{File,Text}
+rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/R
+rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/File
 mv    $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-(cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
- R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
-/sbin/ldconfig
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
-%postun        -p /sbin/ldconfig
-
-%files base
+%files
 %defattr(644,root,root,755)
 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
 
@@ -270,9 +184,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
 %{_libdir}/R/doc/html/packages-head*.html
 %{_libdir}/R/doc/html/*.jpg
-%dir %{_libdir}/R/doc/html/search
-%{_libdir}/R/doc/html/search/[A-Z]*
-%ghost %{_libdir}/R/doc/html/search/index.txt
 %ghost %{_libdir}/R/doc/html/packages.html
 %{_desktopdir}/*.desktop
 
@@ -282,6 +193,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_libdir}/%{name}/library/KernSmooth
 %{_libdir}/%{name}/library/MASS
+%{_libdir}/%{name}/library/Matrix
 %{_libdir}/%{name}/library/base
 %{_libdir}/%{name}/library/boot
 %{_libdir}/%{name}/library/class
@@ -297,18 +209,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/library/mgcv
 %{_libdir}/%{name}/library/nlme
 %{_libdir}/%{name}/library/nnet
-%{_libdir}/%{name}/library/rcompgen
 %{_libdir}/%{name}/library/rpart
 %{_libdir}/%{name}/library/spatial
-%{_libdir}/%{name}/library/survival
 %{_libdir}/%{name}/library/splines
 %{_libdir}/%{name}/library/stats
 %{_libdir}/%{name}/library/stats4
+%{_libdir}/%{name}/library/survival
 %{_libdir}/%{name}/library/tcltk
 %{_libdir}/%{name}/library/tools
 %{_libdir}/%{name}/library/utils
 
 %{_pkgconfigdir}/*.pc
-
-%files recommended
-%defattr(644,root,root,755)
This page took 0.088688 seconds and 4 git commands to generate.