]> git.pld-linux.org Git - packages/R.git/blob - R.spec
90a7049057d69e29b68fc45e584d93327b150b25
[packages/R.git] / R.spec
1 #
2 # Conditional build
3 %bcond_without  tcl             # disable tcl support
4 %bcond_without  tests           # do not run "make check"
5 #
6 # NOTE:
7 # - /etc/localtime must be present for tests to work
8 #
9 # TODO:
10 # - script for rpm to autoprovides/autorequires R internals
11 #
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        A language for data analysis and graphics
14 Summary(pl.UTF-8):      Język do analizy danych oraz grafiki
15 Name:           R
16 Version:        2.15.1
17 Release:        4
18 License:        Mixed (distributable), mostly GPL v2+
19 Group:          Development/Languages
20 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
21 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
22 # Source0-md5:  fcdf247e707fdade82b78bcf911a54f1
23 Source1:        %{name}.desktop
24 Source2:        %{name}.xpm
25 URL:            http://www.r-project.org/
26 BuildRequires:  autoconf >= 2.62
27 BuildRequires:  automake
28 BuildRequires:  blas-devel >= 3.2.2-2
29 BuildRequires:  bzip2-devel >= 1.0.6
30 BuildRequires:  cairo-devel >= 1.6
31 BuildRequires:  gcc-fortran
32 BuildRequires:  gettext-devel >= 0.14.5
33 BuildRequires:  lapack-devel >= 3.2.2-2
34 BuildRequires:  libicu-devel
35 BuildRequires:  libjpeg-devel >= 6b
36 BuildRequires:  libpng-devel >= 1.2.7
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel
39 BuildRequires:  libtool >= 2:2.0
40 BuildRequires:  libxml2-devel >= 2.6.26
41 BuildRequires:  pango-devel
42 BuildRequires:  pcre-devel >= 7.6
43 BuildRequires:  perl-base >= 1:5.6
44 BuildRequires:  pkgconfig
45 BuildRequires:  readline-devel
46 BuildRequires:  rpm-perlprov
47 %{?with_tcl:BuildRequires:      tcl-devel >= 8.4}
48 BuildRequires:  tetex-dvips
49 BuildRequires:  tetex-latex
50 BuildRequires:  tetex-pdftex
51 BuildRequires:  texinfo-texi2dvi >= 4.7
52 %{?with_tcl:BuildRequires:      tk-devel >= 8.4}
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXmu-devel
55 BuildRequires:  xorg-lib-libXt-devel
56 BuildRequires:  xz-devel >= 4.999
57 BuildRequires:  zip
58 BuildRequires:  zlib-devel >= 1.2.3
59 #Requires:      lpr
60 Requires(post): perl-base
61 Requires(post): textutils
62 Requires:       blas >= 3.2.2-2
63 Suggests:       rkward
64 Obsoletes:      R-base
65 Obsoletes:      R-contrib
66 Obsoletes:      R-recommended
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 A system for statistical computation and graphics. R consists of a
71 language plus a run-time environment with graphics, a debugger, access
72 to certain system functions, and the ability to run programs stored in
73 script files.
74
75 The design of R has been heavily influenced by two existing languages:
76 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
77 resulting language is very similar in appearance to S, the underlying
78 implementation and semantics are derived from Scheme.
79
80 %description -l pl.UTF-8
81 System do obliczeń statystycznych i grafiki. R składa się z języka
82 oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
83 niektórych funkcji systemowych oraz możliwością uruchamiania programów
84 zapisanych w skryptach.
85
86 Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
87 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
88 implementacja i semantyka wywodzi się ze Scheme.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__aclocal} -I m4
95 %{__autoconf}
96 install -d build
97 cd build
98 ../%configure \
99         F77=gfortran \
100         FC=gfortran \
101         --enable-R-shlib \
102         --enable-largefile \
103         --with-ICU \
104         --with-blas \
105         --with-cairo \
106         --with-jpeglib \
107         --with-lapack \
108         --with-libpng \
109         --with-readline \
110         --with-recommended-packages \
111         --with-system-bzlib \
112         --with-system-pcre \
113         --with-system-xz \
114         --with-system-zlib \
115         --with%{!?with_tcl:out}-tcltk \
116         --with-x
117
118 %{__make} -j1
119
120 %if %{with tests}
121 %{__make} check
122 %endif
123
124 %{__make} docs pdf info
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir},%{_pixmapsdir}}
129
130 %{__make} -C build -j1 install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
135
136 ln -sf %{_libdir}/R/lib/libR.so $RPM_BUILD_ROOT%{_libdir}
137
138 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
139 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
140
141 gen_lang() {
142         dir="$1"
143         for d in $RPM_BUILD_ROOT${dir}/* ; do
144                 bd=$(basename $d)
145                 lang="${bd%@*}"
146                 echo "%lang($lang) ${dir}/${bd}"
147         done
148 }
149
150 gen_lang %{_libdir}/R/share/locale > R.files
151 for moddir in $RPM_BUILD_ROOT%{_libdir}/R/library/* ; do
152         module=$(basename $moddir)
153         echo "%dir %{_libdir}/R/library/${module}"
154         for f in $moddir/* ; do
155                 bf=$(basename $f)
156                 case "$bf" in
157                   po)
158                         echo "%dir %{_libdir}/R/library/${module}/po"
159                         gen_lang %{_libdir}/R/library/${module}/po
160                         ;;
161                   libs)
162                         echo "%dir %{_libdir}/R/library/${module}/libs"
163                         echo "%attr(755,root,root) %{_libdir}/R/library/${module}/libs/*.so"
164                         ;;
165                   *)
166                         echo "%{_libdir}/R/library/${module}/${bf}"
167                         ;;
168                 esac
169         done
170 done >> R.files
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files -f R.files
179 %defattr(644,root,root,755)
180 %doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
181 %attr(755,root,root) %{_bindir}/R
182 %attr(755,root,root) %{_bindir}/Rscript
183 %dir %{_libdir}/R
184 %dir %{_libdir}/R/lib
185 %attr(755,root,root) %{_libdir}/R/lib/libR.so
186 %attr(755,root,root) %{_libdir}/libR.so
187 %{_libdir}/R/COPYING
188 %{_libdir}/R/NEWS
189 %{_libdir}/R/SVN-REVISION
190 %attr(755,root,root) %{_libdir}/R/bin
191 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
192 %dir %{_libdir}/R/doc
193 %{_libdir}/R/doc/[KRm]*
194 %dir %{_libdir}/R/doc/html
195 %{_libdir}/R/doc/html/*.css
196 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
197 %{_libdir}/R/doc/html/packages-head*.html
198 %{_libdir}/R/doc/html/*.jpg
199 %ghost %{_libdir}/R/doc/html/packages.html
200 %{_libdir}/R/etc
201 %{_libdir}/R/include
202 %dir %{_libdir}/R/library
203 # library files list is autogenerated (see R.files above)
204 %attr(755,root,root) %{_libdir}/R/modules
205 %dir %{_libdir}/R/share
206 %{_libdir}/R/share/R
207 %{_libdir}/R/share/encodings
208 %{_libdir}/R/share/java
209 %{_libdir}/R/share/licenses
210 %dir %{_libdir}/R/share/locale
211 # locale files list is autogenerated (see R.files above)
212 %{_libdir}/R/share/make
213 %{_libdir}/R/share/sh
214 %{_libdir}/R/share/texmf
215 %{_desktopdir}/R.desktop
216 %{_pixmapsdir}/R.xpm
217 %{_includedir}/R
218 %{_pkgconfigdir}/libR.pc
219 %{_mandir}/man1/R.1*
220 %{_mandir}/man1/Rscript*
This page took 0.038836 seconds and 2 git commands to generate.