]> git.pld-linux.org Git - packages/R.git/blame_incremental - R.spec
S: rkward (gui)
[packages/R.git] / R.spec
... / ...
CommitLineData
1#
2# Conditional build
3%bcond_without tcl # disable tcl support
4%bcond_without tests # do not run "make check"
5#
6# NOTE:
7# - /etc/localtime must be present for tests to work
8#
9# TODO:
10# - faulty build on i486 (test stats-Ex.R):
11# error in optim(init[mask], getLike, method = "L-BFGS-B", lower = rep(0, :
12# non-finite value supplied by optim
13# - script for rpm to autoprovides/autorequires R internals
14#
15%include /usr/lib/rpm/macros.perl
16Summary: A language for data analysis and graphics
17Summary(pl.UTF-8): Język do analizy danych oraz grafiki
18Name: R
19Version: 2.11.0
20Release: 2
21License: Mixed (distributable), mostly GPL
22Group: Development/Languages
23# CRAN master site: ftp://cran.r-project.org/pub/R/src/
24Source0: ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
25# Source0-md5: c6c1e866299f533617750889c729bfb3
26Source1: %{name}.desktop
27URL: http://www.r-project.org/
28BuildRequires: autoconf
29BuildRequires: automake
30BuildRequires: blas-devel
31BuildRequires: bzip2-devel
32BuildRequires: cairo-devel
33BuildRequires: gcc-c++
34BuildRequires: gcc-fortran
35BuildRequires: gettext-devel
36BuildRequires: lapack-devel >= 3.1.1-4
37BuildRequires: libicu-devel
38BuildRequires: libjpeg-devel >= 6b
39BuildRequires: libpng-devel >= 1.0.5
40BuildRequires: libstdc++-devel
41BuildRequires: libtool
42BuildRequires: libxml2-devel >= 2.6.26
43BuildRequires: pango-devel
44BuildRequires: pcre-devel
45BuildRequires: perl-base >= 1:5.6
46BuildRequires: pkgconfig
47BuildRequires: readline-devel
48BuildRequires: rpm-perlprov
49%{?with_tcl:BuildRequires: tcl-devel}
50BuildRequires: tetex-dvips
51BuildRequires: tetex-latex
52BuildRequires: tetex-pdftex
53%{?with_tcl:BuildRequires: tk-devel}
54BuildRequires: xorg-lib-libX11-devel
55BuildRequires: xorg-lib-libXmu-devel
56BuildRequires: xorg-lib-libXt-devel
57BuildRequires: xz-devel
58BuildRequires: zip
59BuildRequires: zlib-devel >= 1.1.3
60#Requires: lpr
61Requires(post): perl-base
62Requires(post): textutils
63Suggests: rkward
64Obsoletes: R-base
65Obsoletes: R-contrib
66Obsoletes: R-recommended
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
70A system for statistical computation and graphics. R consists of a
71language plus a run-time environment with graphics, a debugger, access
72to certain system functions, and the ability to run programs stored in
73script files.
74
75The design of R has been heavily influenced by two existing languages:
76Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
77resulting language is very similar in appearance to S, the underlying
78implementation and semantics are derived from Scheme.
79
80%description -l pl.UTF-8
81System do obliczeń statystycznych i grafiki. R składa się z języka
82oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
83niektórych funkcji systemowych oraz możliwością uruchamiania programów
84zapisanych w skryptach.
85
86Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
87Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
88implementacja i semantyka wywodzi się ze Scheme.
89
90%prep
91%setup -q
92
93%build
94%{__aclocal} -I m4
95%{__autoconf}
96%configure \
97 --enable-R-shlib \
98 --enable-linux-lfs \
99 --with-system-zlib \
100 --with-system-bzlib \
101 --with-system-pcre \
102 --with-system-xz \
103 --with-libpng \
104 --with-jpeglib \
105 --with-blas \
106 --with-lapack \
107 --with-readline \
108 --with%{!?with_tcl:out}-tcltk \
109 --with-cairo \
110 --with-libpng \
111 --with-jpeglib \
112 --with-system-zlib \
113 --with-system-bzlib \
114 --with-system-pcre \
115 --with-iconv \
116 --with-ICU \
117 --with-x \
118 --with-recommended-packages
119
120%{__make}
121%if %{with tests}
122%{__make} check
123%endif
124%{__make} docs pdf info
125
126%install
127rm -rf $RPM_BUILD_ROOT
128install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
129install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
130
131%{__make} -j1 install \
132 DESTDIR=$RPM_BUILD_ROOT
133
134install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
135
136mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
137mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
138ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
139
140(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
141for f in * ; do
142 ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
143done)
144(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
145for f in * ; do
146 ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
147done)
148
149rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/R
150rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/File
151mv $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post -p /sbin/ldconfig
157%postun -p /sbin/ldconfig
158
159%files
160%defattr(644,root,root,755)
161%doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
162
163%{_mandir}/man1/R.1*
164%{_mandir}/man1/Rscript*
165%attr(755,root,root) %{_bindir}/R
166%attr(755,root,root) %{_bindir}/Rscript
167%dir %{_libdir}/R
168%attr(755,root,root) %{_libdir}/R/bin
169%attr(755,root,root) %{_libdir}/libR*.so
170%{_libdir}/R/etc
171%{_libdir}/R/include
172%{_includedir}/R
173%{_libdir}/R/share
174%{_libdir}/R/COPYING
175%{_libdir}/R/NEWS
176%{_libdir}/R/SVN-REVISION
177%dir %{_libdir}/R/library
178%{_libdir}/%{name}/library/R.css
179# %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
180%dir %{_libdir}/R/doc
181%{_libdir}/R/doc/[KRm]*
182%dir %{_libdir}/R/doc/html
183%{_libdir}/R/doc/html/*.css
184%{_libdir}/R/doc/html/[Ra-lr-u]*.html
185%{_libdir}/R/doc/html/packages-head*.html
186%{_libdir}/R/doc/html/*.jpg
187%ghost %{_libdir}/R/doc/html/packages.html
188%{_desktopdir}/*.desktop
189
190%{perl_vendorlib}/R
191
192%attr(755,root,root) %{_libdir}/%{name}/modules
193
194%{_libdir}/%{name}/library/KernSmooth
195%{_libdir}/%{name}/library/MASS
196%{_libdir}/%{name}/library/Matrix
197%{_libdir}/%{name}/library/base
198%{_libdir}/%{name}/library/boot
199%{_libdir}/%{name}/library/class
200%{_libdir}/%{name}/library/cluster
201%{_libdir}/%{name}/library/codetools
202%{_libdir}/%{name}/library/datasets
203%{_libdir}/%{name}/library/foreign
204%{_libdir}/%{name}/library/grDevices
205%{_libdir}/%{name}/library/graphics
206%{_libdir}/%{name}/library/grid
207%{_libdir}/%{name}/library/lattice
208%{_libdir}/%{name}/library/methods
209%{_libdir}/%{name}/library/mgcv
210%{_libdir}/%{name}/library/nlme
211%{_libdir}/%{name}/library/nnet
212%{_libdir}/%{name}/library/rpart
213%{_libdir}/%{name}/library/spatial
214%{_libdir}/%{name}/library/splines
215%{_libdir}/%{name}/library/stats
216%{_libdir}/%{name}/library/stats4
217%{_libdir}/%{name}/library/survival
218%{_libdir}/%{name}/library/tcltk
219%{_libdir}/%{name}/library/tools
220%{_libdir}/%{name}/library/utils
221
222%{_pkgconfigdir}/*.pc
This page took 0.056266 seconds and 4 git commands to generate.