]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- rel 2
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop?
4 #
5 # Conditional build:
6 %bcond_with     gtk     # build GTK styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 #
9 %define         kde_ver         0.55.1
10 %define         gtk2_ver        0.55.1
11 %define         gtk1_ver        0.42.2
12 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
13 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
14 Name:           QtCurve
15 Version:        0.55.1
16 Release:        2
17 License:        GPL
18 Group:          Themes
19 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
20 # Source0-md5:  1ba394626a40e8926966739500dbf87d
21 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
22 # Source1-md5:  0d5eeb45990c3ecf060daa68a2ed2e6f
23 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
24 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
25 Patch0:         %{name}-Gtk2-userjs.patch
26 Patch1:         %{name}-Gtk2-mailto.patch
27 URL:            http://www.kde-look.org/content/show.php?content=40492
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  cmake
31 %{?with_gtk:BuildRequires:      gtk+-devel}
32 %{?with_gtk2:BuildRequires:     gtk+2-devel}
33 BuildRequires:  kdelibs-devel >= 3.1
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.293
37 BuildRequires:  sed > 4.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A free and corrected port of Red Hat's GTK+/Qt theme.
42
43 %description -l pl.UTF-8
44 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
45
46 %package -n kde-style-QtCurve
47 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
48 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
49 Group:          Themes
50 Requires:       kdelibs >= 3.1
51
52 %description -n kde-style-QtCurve
53 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
54
55 %description -n kde-style-QtCurve -l pl.UTF-8
56 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
57 Wersja pod KDE.
58
59 %package -n gtk-theme-QtCurve
60 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
61 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
62 Group:          Themes
63 Requires:       theme-QtCurve-common = %{version}-%{release}
64
65 %description -n gtk-theme-QtCurve
66 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
67
68 %description -n gtk-theme-QtCurve -l pl.UTF-8
69 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
70 Wersja pod GTK+.
71
72 %package -n gtk2-theme-QtCurve
73 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
74 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
75 Group:          Themes
76 Requires:       theme-QtCurve-common = %{version}-%{release}
77
78 %description -n gtk2-theme-QtCurve
79 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
80
81 %description -n gtk2-theme-QtCurve -l pl.UTF-8
82 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
83 Wersja pod GTK+2.
84
85 %package -n theme-QtCurve-common
86 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
87 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
88 Group:          Themes
89 Obsoletes:      gtk-theme-bluecurve
90 Obsoletes:      gtk2-theme-bluecurve
91 Obsoletes:      kde-style-bluecurve
92 Obsoletes:      kde-theme-bluecurve
93 Obsoletes:      theme-bluecurve-common
94
95 %description -n theme-QtCurve-common
96 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
97 and common files package.
98
99 %description -n theme-QtCurve-common -l pl.UTF-8
100 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
101 Pakiet z dokumentacja i plikami współdzielonymi.
102
103 %prep
104 %setup -q -c %{?with_gtk2:-a1} %{?with_gtk:-a2}
105 %if %{with gtk2}
106 cd %{name}-Gtk2-%{gtk2_ver}
107 %patch0 -p1
108 %patch1 -p0
109 cd -
110 %endif
111
112 %build
113 cd %{name}-KDE3-%{kde_ver}
114 %cmake \
115         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
116         .
117 %{__make}
118 cd -
119
120 %if %{with gtk}
121 cd %{name}-Gtk1-%{gtk1_ver}
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure
128 %{__make}
129 cd -
130 %endif
131
132 %if %{with gtk2}
133 cd %{name}-Gtk2-%{gtk2_ver}
134 %cmake \
135         -DQTC_ADD_EVENT_FILTER=true \
136         -DQTC_MODIFY_MOZILLA=true \
137         -DQTC_MODIFY_MOZILLA_USER_JS=true \
138         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
139         .
140 %{__make}
141 cd -
142 %endif
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} -C %{name}-KDE3-%{kde_ver} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %if %{with gtk}
151 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
152         DESTDIR=$RPM_BUILD_ROOT
153 %endif
154
155 %if %{with gtk2}
156 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
157         DESTDIR=$RPM_BUILD_ROOT
158 %endif
159
160 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
161 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/mozilla/mailto.sh
162
163 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files -n kde-style-QtCurve
169 %defattr(644,root,root,755)
170 %{_libdir}/kde3/kstyle_qtcurve_config.la
171 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
172 #%{_libdir}/kde3/plugins/styles/*.la
173 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
174 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
175 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
176 %{_datadir}/apps/QtCurve
177
178 %if %{with gtk}
179 %files -n gtk-theme-QtCurve
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
182 %{_datadir}/themes/QtCurve/gtk
183 %endif
184
185 %if %{with gtk2}
186 %files -n gtk2-theme-QtCurve
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
189 %dir %{_datadir}/themes/QtCurve/gtk-2.0
190 %{_datadir}/themes/QtCurve/gtk-2.0/gtkrc
191 %{_datadir}/themes/QtCurve/gtk-2.0/icons3
192 %{_datadir}/themes/QtCurve/gtk-2.0/icons4
193 %attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
194 %dir %{_datadir}/themes/QtCurve/mozilla
195 %{_datadir}/themes/QtCurve/mozilla/QtCurve.css
196 %{_datadir}/themes/QtCurve/mozilla/firefox-user.js
197 %{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
198 %attr(755,root,root) %{_datadir}/themes/QtCurve/mozilla/mailto.sh
199 %endif
200
201 %files -n theme-QtCurve-common
202 %defattr(644,root,root,755)
203 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
204 %dir %{_datadir}/themes/QtCurve
This page took 0.247253 seconds and 4 git commands to generate.