]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- updated gtk bcond desc
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop after dropping last gtk+ 1.x app
4 #
5 # Conditional build:
6 %bcond_without  gtk     # don't build GTK+ styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 %bcond_without  kde     # don't build KDE styles
9 #
10 %define         ver             0.55.1
11 %define         kde_ver         0.55.1
12 %define         gtk2_ver        0.55.1
13 %define         gtk1_ver        0.42.2
14 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
15 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16 Name:           QtCurve
17 Version:        %{ver}
18 Release:        2
19 License:        GPL
20 Group:          Themes
21 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22 # Source0-md5:  1ba394626a40e8926966739500dbf87d
23 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24 # Source1-md5:  0d5eeb45990c3ecf060daa68a2ed2e6f
25 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
27 Patch0:         %{name}-Gtk2-userjs.patch
28 Patch1:         %{name}-Gtk2-mailto.patch
29 URL:            http://www.kde-look.org/content/show.php?content=40492
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  cmake
33 %{?with_gtk:BuildRequires:      gtk+-devel}
34 %{?with_gtk2:BuildRequires:     gtk+2-devel}
35 %{?with_kde:BuildRequires:      kdelibs-devel >= 3.1}
36 BuildRequires:  libtool
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.293
39 BuildRequires:  sed > 4.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 A free and corrected port of Red Hat's GTK+/Qt theme.
44
45 %description -l pl.UTF-8
46 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
47
48 %package -n kde-style-QtCurve
49 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
50 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
51 Group:          Themes
52 Requires:       kdelibs >= 3.1
53
54 %description -n kde-style-QtCurve
55 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
56
57 %description -n kde-style-QtCurve -l pl.UTF-8
58 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
59 Wersja pod KDE.
60
61 %package -n gtk-theme-QtCurve
62 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
63 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
64 Version:        %{gtk1_ver}
65 Group:          Themes
66 Requires:       theme-QtCurve-common = %{ver}-%{release}
67
68 %description -n gtk-theme-QtCurve
69 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
70
71 %description -n gtk-theme-QtCurve -l pl.UTF-8
72 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
73 Wersja pod GTK+.
74
75 %package -n gtk2-theme-QtCurve
76 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
77 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
78 Version:        %{gtk2_ver}
79 Group:          Themes
80 Requires:       theme-QtCurve-common = %{ver}-%{release}
81
82 %description -n gtk2-theme-QtCurve
83 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
84
85 %description -n gtk2-theme-QtCurve -l pl.UTF-8
86 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
87 Wersja pod GTK+2.
88
89 %package -n theme-QtCurve-common
90 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
91 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
92 Version:        %{kde_ver}
93 Group:          Themes
94 Obsoletes:      gtk-theme-bluecurve
95 Obsoletes:      gtk2-theme-bluecurve
96 Obsoletes:      kde-style-bluecurve
97 Obsoletes:      kde-theme-bluecurve
98 Obsoletes:      theme-bluecurve-common
99
100 %description -n theme-QtCurve-common
101 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
102 and common files package.
103
104 %description -n theme-QtCurve-common -l pl.UTF-8
105 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
106 Pakiet z dokumentacja i plikami współdzielonymi.
107
108 %prep
109 %setup -q -c -D %{?with_kde:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
110 %if %{with gtk2}
111 cd %{name}-Gtk2-%{gtk2_ver}
112 %patch0 -p1
113 %patch1 -p0
114 cd -
115 %endif
116
117 %build
118 %if %{with kde}
119 cd %{name}-KDE3-%{kde_ver}
120 %cmake \
121         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
122         .
123 %{__make}
124 cd -
125 %endif
126
127 %if %{with gtk}
128 cd %{name}-Gtk1-%{gtk1_ver}
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure
135 %{__make}
136 cd -
137 %endif
138
139 %if %{with gtk2}
140 cd %{name}-Gtk2-%{gtk2_ver}
141 %cmake \
142         -DQTC_ADD_EVENT_FILTER=true \
143         -DQTC_MODIFY_MOZILLA=true \
144         -DQTC_MODIFY_MOZILLA_USER_JS=true \
145         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
146         .
147 %{__make}
148 cd -
149 %endif
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %if %{with kde}
155 %{__make} -C %{name}-KDE3-%{kde_ver} install \
156         DESTDIR=$RPM_BUILD_ROOT
157 %endif
158
159 %if %{with gtk}
160 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
161         DESTDIR=$RPM_BUILD_ROOT
162 %endif
163
164 %if %{with gtk2}
165 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
169 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/mozilla/mailto.sh
170 %endif
171
172 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %if %{with kde}
178 %files -n kde-style-QtCurve
179 %defattr(644,root,root,755)
180 %{_libdir}/kde3/kstyle_qtcurve_config.la
181 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
182 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
183 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
184 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
185 %{_datadir}/apps/QtCurve
186 %endif
187
188 %if %{with gtk}
189 %files -n gtk-theme-QtCurve
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
192 %{_datadir}/themes/QtCurve/gtk
193 %endif
194
195 %if %{with gtk2}
196 %files -n gtk2-theme-QtCurve
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
199 %dir %{_datadir}/themes/QtCurve/gtk-2.0
200 %{_datadir}/themes/QtCurve/gtk-2.0/gtkrc
201 %{_datadir}/themes/QtCurve/gtk-2.0/icons3
202 %{_datadir}/themes/QtCurve/gtk-2.0/icons4
203 %attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
204 %dir %{_datadir}/themes/QtCurve/mozilla
205 %{_datadir}/themes/QtCurve/mozilla/QtCurve.css
206 %{_datadir}/themes/QtCurve/mozilla/firefox-user.js
207 %{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
208 %attr(755,root,root) %{_datadir}/themes/QtCurve/mozilla/mailto.sh
209 %endif
210
211 %files -n theme-QtCurve-common
212 %defattr(644,root,root,755)
213 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
214 %dir %{_datadir}/themes/QtCurve
This page took 0.124865 seconds and 3 git commands to generate.