]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- md5
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop after dropping last gtk+ 1.x app
4 #
5 # Conditional build:
6 %bcond_without  gtk     # don't build GTK+ styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 %bcond_without  kde     # don't build KDE styles
9 #
10 %define         ver             0.59.1
11 %define         kde_ver         0.59.0
12 %define         gtk2_ver        0.59.1
13 %define         gtk1_ver        0.42.2
14 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
15 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16 Name:           QtCurve
17 Version:        %{ver}
18 Release:        4
19 License:        GPL
20 Group:          Themes
21 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22 # Source0-md5:  5d7a2e2c5fc35fed7fb50e7ec2ecc5f4
23 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24 # Source1-md5:  5ffb6966d1077526bfdb57de8258a57f
25 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
27 Patch0:         %{name}-Gtk2-userjs.patch
28 Patch1:         %{name}-Gtk2-mailto.patch
29 Patch2:         %{name}-Gtk1-lib64.patch
30 URL:            http://www.kde-look.org/content/show.php?content=40492
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  cmake
34 %{?with_gtk:BuildRequires:      gtk+-devel}
35 %{?with_gtk2:BuildRequires:     gtk+2-devel}
36 %{?with_kde:BuildRequires:      kdelibs-devel >= 3.1}
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 BuildRequires:  rpmbuild(macros) >= 1.293
40 BuildRequires:  sed > 4.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A free and corrected port of Red Hat's GTK+/Qt theme.
45
46 %description -l pl.UTF-8
47 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
48
49 %package -n kde-style-QtCurve
50 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
51 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
52 Version:        %{kde_ver}
53 Group:          Themes
54 Requires:       kdelibs >= 3.1
55
56 %description -n kde-style-QtCurve
57 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
58
59 %description -n kde-style-QtCurve -l pl.UTF-8
60 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
61 Wersja pod KDE.
62
63 %package -n gtk-theme-QtCurve
64 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
65 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
66 Version:        %{gtk1_ver}
67 Group:          Themes
68 Requires:       theme-QtCurve-common = %{ver}-%{release}
69
70 %description -n gtk-theme-QtCurve
71 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
72
73 %description -n gtk-theme-QtCurve -l pl.UTF-8
74 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
75 Wersja pod GTK+.
76
77 %package -n gtk2-theme-QtCurve
78 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
79 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
80 Version:        %{gtk2_ver}
81 Group:          Themes
82 Requires:       theme-QtCurve-common = %{ver}-%{release}
83
84 %description -n gtk2-theme-QtCurve
85 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
86
87 %description -n gtk2-theme-QtCurve -l pl.UTF-8
88 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
89 Wersja pod GTK+2.
90
91 %package -n theme-QtCurve-common
92 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
93 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
94 Version:        %{ver}
95 Group:          Themes
96 Obsoletes:      gtk-theme-bluecurve
97 Obsoletes:      gtk2-theme-bluecurve
98 Obsoletes:      kde-style-bluecurve
99 Obsoletes:      kde-theme-bluecurve
100 Obsoletes:      theme-bluecurve-common
101
102 %description -n theme-QtCurve-common
103 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
104 and common files package.
105
106 %description -n theme-QtCurve-common -l pl.UTF-8
107 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
108 Pakiet z dokumentacja i plikami współdzielonymi.
109
110 %prep
111 %setup -q -c -D %{?with_kde:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
112 %if %{with gtk2}
113 cd %{name}-Gtk2-%{gtk2_ver}
114 %patch0 -p1
115 %patch1 -p0
116 cd -
117 %endif
118
119 %if %{with gtk}
120 %if "%{_lib}" == "lib64"
121 cd %{name}-Gtk1-%{gtk1_ver}
122 %patch2 -p1
123 cd -
124 %endif
125 %endif
126
127
128 %build
129 %if %{with kde}
130 cd %{name}-KDE3-%{kde_ver}
131 %cmake \
132         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
133         .
134 %{__make}
135 cd -
136 %endif
137
138 %if %{with gtk}
139 cd %{name}-Gtk1-%{gtk1_ver}
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoconf}
143 %{__autoheader}
144 %{__automake}
145 %configure
146 %{__make}
147 cd -
148 %endif
149
150 %if %{with gtk2}
151 cd %{name}-Gtk2-%{gtk2_ver}
152 %cmake \
153         -DQTC_ADD_EVENT_FILTER=true \
154         -DQTC_MODIFY_MOZILLA=true \
155         -DQTC_MODIFY_MOZILLA_USER_JS=true \
156         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
157         .
158 %{__make}
159 cd -
160 %endif
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %if %{with kde}
166 %{__make} -C %{name}-KDE3-%{kde_ver} install \
167         DESTDIR=$RPM_BUILD_ROOT
168 %endif
169
170 %if %{with gtk}
171 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
172         DESTDIR=$RPM_BUILD_ROOT
173 %endif
174
175 %if %{with gtk2}
176 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
180 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/mozilla/mailto.sh
181 %endif
182
183 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %if %{with kde}
189 %files -n kde-style-QtCurve
190 %defattr(644,root,root,755)
191 %{_libdir}/kde3/kstyle_qtcurve_config.la
192 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
193 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
194 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
195 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
196 %{_datadir}/apps/QtCurve
197 %endif
198
199 %if %{with gtk}
200 %files -n gtk-theme-QtCurve
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
203 %{_datadir}/themes/QtCurve/gtk
204 %endif
205
206 %if %{with gtk2}
207 %files -n gtk2-theme-QtCurve
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
210 %dir %{_datadir}/themes/QtCurve/gtk-2.0
211 %{_datadir}/themes/QtCurve/gtk-2.0/gtkrc
212 %{_datadir}/themes/QtCurve/gtk-2.0/icons3
213 %{_datadir}/themes/QtCurve/gtk-2.0/icons4
214 %attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
215 %dir %{_datadir}/themes/QtCurve/mozilla
216 %{_datadir}/themes/QtCurve/mozilla/QtCurve.css
217 %{_datadir}/themes/QtCurve/mozilla/firefox-user.js
218 %{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
219 %attr(755,root,root) %{_datadir}/themes/QtCurve/mozilla/mailto.sh
220 %endif
221
222 %files -n theme-QtCurve-common
223 %defattr(644,root,root,755)
224 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
225 %dir %{_datadir}/themes/QtCurve
This page took 0.411133 seconds and 3 git commands to generate.