]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- fix problems with autoconf 2.60 which creates configure that runs in POSIX mode
[packages/QtCurve.git] / QtCurve.spec
1 #
2 # ToDo:
3 #  - include /usr/share/themes/QtCurve/mozilla somewhere
4 #
5 # Conditional build:
6 %bcond_with     gtk     # build GTK styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 #
9 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
10 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
11 Name:           QtCurve
12 Version:        0.38
13 Release:        1
14 License:        GPL
15 Group:          Themes
16 Source0:        http://www.cpdrummond.freeuk.com/%{name}-%{version}.tar.gz
17 # Source0-md5:  1e9145e20e2df5a1f572767d158f66d5
18 URL:            http://www.kde-look.org/content/show.php?content=40492
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_gtk:BuildRequires:      gtk+-devel}
22 %{?with_gtk2:BuildRequires:     gtk+2-devel}
23 BuildRequires:  kdelibs-devel >= 3.1
24 BuildRequires:  pkgconfig
25 BuildRequires:  sed > 4.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A free and corrected port of Red Hat's GTK+/Qt theme.
30
31 %description -l pl
32 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
33
34 %package -n kde-style-QtCurve
35 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
36 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
37 Group:          Themes
38 Requires:       kdelibs >= 3.1
39
40 %description -n kde-style-QtCurve
41 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
42
43 %description -n kde-style-QtCurve -l pl
44 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
45 Wersja pod KDE.
46
47 %package -n gtk-theme-QtCurve
48 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
49 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
50 Group:          Themes
51 Requires:       theme-QtCurve-common = %{version}-%{release}
52
53 %description -n gtk-theme-QtCurve
54 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
55
56 %description -n gtk-theme-QtCurve -l pl
57 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
58 Wersja pod GTK+.
59
60 %package -n gtk2-theme-QtCurve
61 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
62 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
63 Group:          Themes
64 Requires:       theme-QtCurve-common = %{version}-%{release}
65
66 %description -n gtk2-theme-QtCurve
67 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
68
69 %description -n gtk2-theme-QtCurve -l pl
70 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
71 Wersja pod GTK+2.
72
73 %package -n theme-QtCurve-common
74 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
75 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
76 Group:          Themes
77 Obsoletes:      theme-bluecurve-common
78 Obsoletes:      gtk2-theme-bluecurve
79 Obsoletes:      gtk-theme-bluecurve
80 Obsoletes:      kde-style-bluecurve
81 Obsoletes:      kde-theme-bluecurve
82
83 %description -n theme-QtCurve-common
84 A free and corrected port of Red Hat's GTK+/Qt theme.
85 Documentation and common files package.
86
87 %description -n theme-QtCurve-common -l pl
88 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
89 Pakiet z dokumentacja i plikami wspó³dzielonymi.
90
91 %prep
92 %setup -q
93 sed -i "s#/lib/gtk/#/%{_lib}/gtk/#g" gtk/Makefile.am
94 sed -i "s#/lib/gtk-2.0/#/%{_lib}/gtk-2.0/#g" gtk2/Makefile.am
95
96 %build
97 cp /usr/share/automake/config.sub admin
98
99 %{__make} -f admin/Makefile.common cvs
100 %configure \
101         --with-qt-libraries=%{_libdir}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files -n kde-style-QtCurve
117 %defattr(644,root,root,755)
118 %{_libdir}/kde3/kstyle_qtcurve_config.la
119 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
120 %{_libdir}/kde3/plugins/styles/*.la
121 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
122 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
123 %{_datadir}/apps/qtcurve
124
125 %if %{with gtk}
126 %files -n gtk-theme-QtCurve
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
129 %{_datadir}/themes/QtCurve*/gtk
130 %endif
131
132 %if %{with gtk2}
133 %files -n gtk2-theme-QtCurve
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
136 %{_datadir}/themes/QtCurve*/gtk-2.0
137 %endif
138
139 %files -n theme-QtCurve-common
140 %defattr(644,root,root,755)
141 %doc ChangeLog README TODO
142 %dir %{_datadir}/themes/QtCurve*
This page took 0.212893 seconds and 3 git commands to generate.