]> git.pld-linux.org Git - packages/PyMSNt.git/blob - PyMSNt.spec
- /etc/init.d belongs to rc-scripts
[packages/PyMSNt.git] / PyMSNt.spec
1 #
2 # TODO:
3 # - goto and see workaround (!)
4 # - summary and description (both),
5 # ATTENTION! ACHTUNG!
6 # - SNAPSHOT VERSION!
7
8 Summary:        Python MSN jabber transport
9 Summary(pl.UTF-8):      Python MSN jabber transport
10 Name:           PyMSNt
11 Version:        0.12
12 Release:        0.1
13 Epoch:          1
14 License:        GPL
15 Group:          Applications/Communications
16 Source0:        http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17 # Source0-md5:  878a3df019c3e56b832feb751a4b4502
18 Source1:        %{name}-config.xml
19 Source2:        %{name}.init
20 URL:            http://delx.cjb.net/pymsnt/
21 BuildRequires:  python
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires:       python-Twisted
25 Requires:       python-Twisted-ssl
26 Requires:       python-TwistedWords
27 Requires:       python-TwistedWeb
28 Requires:       python-TwistedXish
29 Requires:       python-Imaging
30 Requires:       python-pyOpenSSL 
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35
36 %description -l pl.UTF-8
37
38 %prep
39 %setup -q -n pymsnt-snapshot
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 install -d $RPM_BUILD_ROOT/{%{_datadir}/pymsnt/src/{twistfix/words/{xish/,protocols/jabber/},legacy/msn/,baseproto/},%{_var}/lib/pymsnt}
45 install -d $RPM_BUILD_ROOT/%{_sysconfdir}/{jabber,init.d}
46 install -d $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
47 install src/twistfix/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/
48 install src/twistfix/words/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/
49 install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/xish/
50 install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/
51 install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
52 install src/legacy/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/
53 install src/legacy/msn/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/msn/
54 install src/baseproto/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/baseproto/
55 install src/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/
56 install data/* $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
57 install PyMSNt.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/
58
59 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/jabber/PyMSNt.xml
60 install %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/PyMSNt
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 #ugly workaround (maybe fix in twisted words/xish package?)
66 %post
67 ln -s %{py_sitescriptdir}/twisted/words/ %{py_sitedir}/twisted/words
68 ln -s %{py_sitescriptdir}/twisted/xish/ %{py_sitedir}/twisted/xish
69
70 if [ -f %{_sysconfdir}/jabber/secret ] ; then
71         SECRET=`cat %{_sysconfdir}/jabber/secret`
72         if [ -n "$SECRET" ] ; then
73                 echo "Updating component authentication secret in PyMSNt.xml..."
74                 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
75         fi
76 fi
77 /sbin/chkconfig --add PyMSNt
78 %service PyMSNt restart "Jabber MSN transport"
79
80 %preun
81 if [ "$1" = "0" ]; then
82         %service PyMSNt stop
83         /sbin/chkconfig --del PyMSNt
84 fi
85
86 %postun
87 echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
88 rm -f %{py_sitedir}/twisted/words
89 rm -f %{py_sitedir}/twisted/xish
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README TODO docs
94 %dir %{_datadir}/pymsnt/src/twistfix/
95 %{_datadir}/pymsnt/src/twistfix/*.py
96 %dir %{_datadir}/pymsnt/src/twistfix/words/
97 %{_datadir}/pymsnt/src/twistfix/words/*.py
98 %dir %{_datadir}/pymsnt/src/twistfix/words/xish/
99 %{_datadir}/pymsnt/src/twistfix/words/xish/*.py
100 %dir %{_datadir}/pymsnt/src/twistfix/words/protocols/
101 %{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
102 %dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
103 %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
104 %dir %{_datadir}/pymsnt/src/legacy/
105 %{_datadir}/pymsnt/src/legacy/*.py
106 %dir %{_datadir}/pymsnt/src/legacy/msn/
107 %{_datadir}/pymsnt/src/legacy/msn/*.py
108 %dir %{_datadir}/pymsnt/src/baseproto/
109 %{_datadir}/pymsnt/src/baseproto/*.py
110 %dir %{_datadir}/pymsnt/src
111 %{_datadir}/pymsnt/src/*.py
112 %dir %{_datadir}/pymsnt/data/
113 %{_datadir}/pymsnt/data/*
114 %dir %{_datadir}/pymsnt
115 %attr(755,root,root) %{_datadir}/pymsnt/*.py
116 %dir %{_var}/lib/pymsnt
117 %attr(755,root,root) %{_sysconfdir}/init.d/PyMSNt
118 %dir %{_sysconfdir}/jabber/
119 %attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.114594 seconds and 3 git commands to generate.