]> git.pld-linux.org Git - packages/PyMSNt.git/blame - PyMSNt.spec
- path fixes
[packages/PyMSNt.git] / PyMSNt.spec
CommitLineData
e697c636 1#
2# TODO:
4646aa2a 3# - goto and see workaround (!)
e697c636 4# - summary and description (both),
100a449a 5# ATTENTION! ACHTUNG!
4e2bf44f 6# - SNAPSHOT VERSION!
e697c636 7
8Summary: Python MSN jabber transport
e1d9f758 9Summary(pl.UTF-8): Transport MSN dla jabbera napisany w pythonie
e697c636 10Name: PyMSNt
71c8d932 11Version: 0.11.3
e697c636 12Release: 0.1
4646aa2a 13Epoch: 1
e697c636 14License: GPL
9c076029 15Group: Applications/Communications
e697c636 16Source0: http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17# Source0-md5: 878a3df019c3e56b832feb751a4b4502
4646aa2a 18Source1: %{name}-config.xml
19Source2: %{name}.init
e697c636 20URL: http://delx.cjb.net/pymsnt/
21BuildRequires: python
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.219
54c7fb66 24Requires: python-Imaging
63bf010c 25Requires: python-Twisted
26Requires: python-Twisted-ssl
63bf010c 27Requires: python-TwistedWeb
54c7fb66 28Requires: python-TwistedWords
63bf010c 29Requires: python-TwistedXish
54c7fb66 30Requires: python-pyOpenSSL
e697c636 31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35
e697c636 36%prep
37%setup -q -n pymsnt-snapshot
38
e697c636 39%install
40rm -rf $RPM_BUILD_ROOT
41
54c7fb66
ER
42install -d $RPM_BUILD_ROOT{%{_datadir}/pymsnt/src/{twistfix/words/{xish/,protocols/jabber/},legacy/msn/,baseproto/},%{_var}/lib/pymsnt}
43install -d $RPM_BUILD_ROOT{%{_sysconfdir}/jabber,/etc/rc.d/init.d}
44install -d $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
45install src/twistfix/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix
46install src/twistfix/words/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words
47install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/xish
48install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols
49install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber
50install src/legacy/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy
51install src/legacy/msn/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy/msn
52install src/baseproto/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/baseproto
53install src/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src
54install data/* $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
55install PyMSNt.py $RPM_BUILD_ROOT%{_datadir}/pymsnt
e697c636 56
b450d60f
ER
57install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/jabber/PyMSNt.xml
58install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/PyMSNt
4646aa2a 59
e697c636 60%clean
61rm -rf $RPM_BUILD_ROOT
62
54c7fb66 63# ugly workaround (maybe fix in twisted words/xish package?)
63bf010c 64%post
54c7fb66
ER
65ln -s %{py_sitescriptdir}/twisted/words %{py_sitedir}/twisted/words
66ln -s %{py_sitescriptdir}/twisted/xish %{py_sitedir}/twisted/xish
63bf010c 67
54c7fb66
ER
68if [ -f %{_sysconfdir}/jabber/secret ]; then
69 SECRET=`cat %{_sysconfdir}/jabber/secret`
70 if [ -n "$SECRET" ] ; then
71 echo "Updating component authentication secret in PyMSNt.xml..."
72 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
73 fi
4646aa2a 74fi
4e2bf44f 75/sbin/chkconfig --add PyMSNt
76%service PyMSNt restart "Jabber MSN transport"
4646aa2a 77
78%preun
79if [ "$1" = "0" ]; then
54c7fb66
ER
80 %service PyMSNt stop
81 /sbin/chkconfig --del PyMSNt
4646aa2a 82fi
83
63bf010c 84%postun
aeaf816d 85echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
86rm -f %{py_sitedir}/twisted/words
87rm -f %{py_sitedir}/twisted/xish
63bf010c 88
e697c636 89%files
90%defattr(644,root,root,755)
91%doc README TODO docs
92%dir %{_datadir}/pymsnt/src/twistfix/
93%{_datadir}/pymsnt/src/twistfix/*.py
94%dir %{_datadir}/pymsnt/src/twistfix/words/
95%{_datadir}/pymsnt/src/twistfix/words/*.py
96%dir %{_datadir}/pymsnt/src/twistfix/words/xish/
97%{_datadir}/pymsnt/src/twistfix/words/xish/*.py
98%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/
99%{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
100%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
101%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
102%dir %{_datadir}/pymsnt/src/legacy/
103%{_datadir}/pymsnt/src/legacy/*.py
104%dir %{_datadir}/pymsnt/src/legacy/msn/
105%{_datadir}/pymsnt/src/legacy/msn/*.py
106%dir %{_datadir}/pymsnt/src/baseproto/
107%{_datadir}/pymsnt/src/baseproto/*.py
108%dir %{_datadir}/pymsnt/src
109%{_datadir}/pymsnt/src/*.py
aeaf816d 110%dir %{_datadir}/pymsnt/data/
111%{_datadir}/pymsnt/data/*
e697c636 112%dir %{_datadir}/pymsnt
aeaf816d 113%attr(755,root,root) %{_datadir}/pymsnt/*.py
4646aa2a 114%dir %{_var}/lib/pymsnt
54c7fb66 115%attr(754,root,root) /etc/rc.d/init.d/PyMSNt
8ba2f93e 116%attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.079156 seconds and 4 git commands to generate.