]> git.pld-linux.org Git - packages/PyMSNt.git/blame - PyMSNt.spec
- fixed group,
[packages/PyMSNt.git] / PyMSNt.spec
CommitLineData
e697c636 1#
2# TODO:
4646aa2a 3# - goto and see workaround (!)
e697c636 4# - summary and description (both),
4e2bf44f 5# ATTENTION! AHTUNG!
6# - SNAPSHOT VERSION!
e697c636 7
8Summary: Python MSN jabber transport
9Summary(pl.UTF-8): Python MSN jabber transport
10Name: PyMSNt
11Version: 0.12
12Release: 0.1
4646aa2a 13Epoch: 1
e697c636 14License: GPL
9c076029 15Group: Applications/Communications
e697c636 16Source0: http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17# Source0-md5: 878a3df019c3e56b832feb751a4b4502
4646aa2a 18Source1: %{name}-config.xml
19Source2: %{name}.init
e697c636 20URL: http://delx.cjb.net/pymsnt/
21BuildRequires: python
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.219
63bf010c 24Requires: python-Twisted
25Requires: python-Twisted-ssl
26Requires: python-TwistedWords
27Requires: python-TwistedWeb
28Requires: python-TwistedXish
29Requires: python-Imaging
30Requires: python-pyOpenSSL
e697c636 31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35
36%description -l pl.UTF-8
37
38%prep
39%setup -q -n pymsnt-snapshot
40
41%build
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
4646aa2a 46install -d $RPM_BUILD_ROOT/{%{_datadir}/pymsnt/src/{twistfix/words/{xish/,protocols/jabber/},legacy/msn/,baseproto/},%{_var}/lib/pymsnt}
47install -d $RPM_BUILD_ROOT/%{_sysconfdir}/{jabber,init.d}
aeaf816d 48install -d $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
e697c636 49install src/twistfix/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/
50install src/twistfix/words/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/
51install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/xish/
52install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/
53install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
54install src/legacy/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/
55install src/legacy/msn/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/msn/
56install src/baseproto/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/baseproto/
57install src/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/
aeaf816d 58install data/* $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
e697c636 59install PyMSNt.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/
60
4e2bf44f 61install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/jabber/PyMSNt.xml
62install %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/PyMSNt
4646aa2a 63
e697c636 64%clean
65rm -rf $RPM_BUILD_ROOT
66
63bf010c 67#ugly workaround (maybe fix in twisted words/xish package?)
68%post
69ln -s %{py_sitescriptdir}/twisted/words/ %{py_sitedir}/twisted/words
70ln -s %{py_sitescriptdir}/twisted/xish/ %{py_sitedir}/twisted/xish
71
4646aa2a 72if [ -f %{_sysconfdir}/jabber/secret ] ; then
73 SECRET=`cat %{_sysconfdir}/jabber/secret`
74 if [ -n "$SECRET" ] ; then
75 echo "Updating component authentication secret in PyMSNt.xml..."
76 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
77 fi
78fi
4e2bf44f 79/sbin/chkconfig --add PyMSNt
80%service PyMSNt restart "Jabber MSN transport"
4646aa2a 81
82%preun
83if [ "$1" = "0" ]; then
4e2bf44f 84 %service PyMSNt stop
85 /sbin/chkconfig --del PyMSNt
4646aa2a 86fi
87
63bf010c 88%postun
aeaf816d 89echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
90rm -f %{py_sitedir}/twisted/words
91rm -f %{py_sitedir}/twisted/xish
63bf010c 92
e697c636 93%files
94%defattr(644,root,root,755)
95%doc README TODO docs
96%dir %{_datadir}/pymsnt/src/twistfix/
97%{_datadir}/pymsnt/src/twistfix/*.py
98%dir %{_datadir}/pymsnt/src/twistfix/words/
99%{_datadir}/pymsnt/src/twistfix/words/*.py
100%dir %{_datadir}/pymsnt/src/twistfix/words/xish/
101%{_datadir}/pymsnt/src/twistfix/words/xish/*.py
102%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/
103%{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
104%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
105%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
106%dir %{_datadir}/pymsnt/src/legacy/
107%{_datadir}/pymsnt/src/legacy/*.py
108%dir %{_datadir}/pymsnt/src/legacy/msn/
109%{_datadir}/pymsnt/src/legacy/msn/*.py
110%dir %{_datadir}/pymsnt/src/baseproto/
111%{_datadir}/pymsnt/src/baseproto/*.py
112%dir %{_datadir}/pymsnt/src
113%{_datadir}/pymsnt/src/*.py
aeaf816d 114%dir %{_datadir}/pymsnt/data/
115%{_datadir}/pymsnt/data/*
e697c636 116%dir %{_datadir}/pymsnt
aeaf816d 117%attr(755,root,root) %{_datadir}/pymsnt/*.py
4646aa2a 118%dir %{_var}/lib/pymsnt
4e2bf44f 119%dir %{_sysconfdir}/init.d/
aeaf816d 120%attr(755,root,root) %{_sysconfdir}/init.d/PyMSNt
4e2bf44f 121%dir %{_sysconfdir}/jabber/
8ba2f93e 122%attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.096153 seconds and 4 git commands to generate.