]> git.pld-linux.org Git - packages/PyMSNt.git/blame - PyMSNt.spec
- GPL v2
[packages/PyMSNt.git] / PyMSNt.spec
CommitLineData
e697c636 1#
2# TODO:
4646aa2a 3# - goto and see workaround (!)
daf8d9f9 4# - real descriptions
100a449a 5# ATTENTION! ACHTUNG!
4e2bf44f 6# - SNAPSHOT VERSION!
e697c636 7
daf8d9f9
JB
8Summary: Python MSN Jabber transport
9Summary(pl.UTF-8): Transport MSN dla Jabbera napisany w Pythonie
e697c636 10Name: PyMSNt
71c8d932 11Version: 0.11.3
e697c636 12Release: 0.1
4646aa2a 13Epoch: 1
281c966e 14License: GPL v2
9c076029 15Group: Applications/Communications
e697c636 16Source0: http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17# Source0-md5: 878a3df019c3e56b832feb751a4b4502
4646aa2a 18Source1: %{name}-config.xml
19Source2: %{name}.init
e697c636 20URL: http://delx.cjb.net/pymsnt/
21BuildRequires: python
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.219
54c7fb66 24Requires: python-Imaging
63bf010c 25Requires: python-Twisted
26Requires: python-Twisted-ssl
63bf010c 27Requires: python-TwistedWeb
54c7fb66 28Requires: python-TwistedWords
63bf010c 29Requires: python-TwistedXish
54c7fb66 30Requires: python-pyOpenSSL
e697c636 31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
daf8d9f9
JB
35Python MSN Jabber transport.
36
37%description -l pl.UTF-8
38Transport MSN dla Jabbera napisany w Pythonie.
e697c636 39
e697c636 40%prep
41%setup -q -n pymsnt-snapshot
42
e697c636 43%install
44rm -rf $RPM_BUILD_ROOT
45
daf8d9f9 46install -d $RPM_BUILD_ROOT{%{_datadir}/pymsnt/src/{twistfix/words/{xish,protocols/jabber},legacy/msn,baseproto},%{_var}/lib/pymsnt}
54c7fb66
ER
47install -d $RPM_BUILD_ROOT{%{_sysconfdir}/jabber,/etc/rc.d/init.d}
48install -d $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
49install src/twistfix/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix
50install src/twistfix/words/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words
51install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/xish
52install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols
53install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber
54install src/legacy/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy
55install src/legacy/msn/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/legacy/msn
56install src/baseproto/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src/baseproto
57install src/*.py $RPM_BUILD_ROOT%{_datadir}/pymsnt/src
58install data/* $RPM_BUILD_ROOT%{_datadir}/pymsnt/data
59install PyMSNt.py $RPM_BUILD_ROOT%{_datadir}/pymsnt
e697c636 60
b450d60f
ER
61install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/jabber/PyMSNt.xml
62install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/PyMSNt
4646aa2a 63
e697c636 64%clean
65rm -rf $RPM_BUILD_ROOT
66
63bf010c 67%post
daf8d9f9
JB
68# ugly workaround (FIX it here or in twisted words/xish packages)
69#ln -s %{py_sitescriptdir}/twisted/words %{py_sitedir}/twisted/words
70#ln -s %{py_sitescriptdir}/twisted/xish %{py_sitedir}/twisted/xish
63bf010c 71
54c7fb66
ER
72if [ -f %{_sysconfdir}/jabber/secret ]; then
73 SECRET=`cat %{_sysconfdir}/jabber/secret`
74 if [ -n "$SECRET" ] ; then
75 echo "Updating component authentication secret in PyMSNt.xml..."
76 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
77 fi
4646aa2a 78fi
4e2bf44f 79/sbin/chkconfig --add PyMSNt
80%service PyMSNt restart "Jabber MSN transport"
4646aa2a 81
82%preun
83if [ "$1" = "0" ]; then
54c7fb66
ER
84 %service PyMSNt stop
85 /sbin/chkconfig --del PyMSNt
4646aa2a 86fi
87
daf8d9f9
JB
88#%postun
89#echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
90#rm -f %{py_sitedir}/twisted/words
91#rm -f %{py_sitedir}/twisted/xish
63bf010c 92
e697c636 93%files
94%defattr(644,root,root,755)
95%doc README TODO docs
daf8d9f9 96%dir %{_datadir}/pymsnt/src/twistfix
e697c636 97%{_datadir}/pymsnt/src/twistfix/*.py
daf8d9f9 98%dir %{_datadir}/pymsnt/src/twistfix/words
e697c636 99%{_datadir}/pymsnt/src/twistfix/words/*.py
daf8d9f9 100%dir %{_datadir}/pymsnt/src/twistfix/words/xish
e697c636 101%{_datadir}/pymsnt/src/twistfix/words/xish/*.py
daf8d9f9 102%dir %{_datadir}/pymsnt/src/twistfix/words/protocols
e697c636 103%{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
daf8d9f9 104%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber
e697c636 105%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
daf8d9f9 106%dir %{_datadir}/pymsnt/src/legacy
e697c636 107%{_datadir}/pymsnt/src/legacy/*.py
daf8d9f9 108%dir %{_datadir}/pymsnt/src/legacy/msn
e697c636 109%{_datadir}/pymsnt/src/legacy/msn/*.py
daf8d9f9 110%dir %{_datadir}/pymsnt/src/baseproto
e697c636 111%{_datadir}/pymsnt/src/baseproto/*.py
112%dir %{_datadir}/pymsnt/src
113%{_datadir}/pymsnt/src/*.py
daf8d9f9 114%dir %{_datadir}/pymsnt/data
aeaf816d 115%{_datadir}/pymsnt/data/*
e697c636 116%dir %{_datadir}/pymsnt
aeaf816d 117%attr(755,root,root) %{_datadir}/pymsnt/*.py
4646aa2a 118%dir %{_var}/lib/pymsnt
54c7fb66 119%attr(754,root,root) /etc/rc.d/init.d/PyMSNt
8ba2f93e 120%attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.075759 seconds and 4 git commands to generate.