]> git.pld-linux.org Git - packages/PyMSNt.git/blame - PyMSNt.spec
- typo in TODO
[packages/PyMSNt.git] / PyMSNt.spec
CommitLineData
e697c636 1#
2# TODO:
4646aa2a 3# - goto and see workaround (!)
e697c636 4# - summary and description (both),
100a449a 5# ATTENTION! ACHTUNG!
4e2bf44f 6# - SNAPSHOT VERSION!
e697c636 7
8Summary: Python MSN jabber transport
9Summary(pl.UTF-8): Python MSN jabber transport
10Name: PyMSNt
11Version: 0.12
12Release: 0.1
4646aa2a 13Epoch: 1
e697c636 14License: GPL
9c076029 15Group: Applications/Communications
e697c636 16Source0: http://delx.cjb.net/pymsnt/tarballs/pymsnt-snapshot.tar.gz
17# Source0-md5: 878a3df019c3e56b832feb751a4b4502
4646aa2a 18Source1: %{name}-config.xml
19Source2: %{name}.init
e697c636 20URL: http://delx.cjb.net/pymsnt/
21BuildRequires: python
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.219
63bf010c 24Requires: python-Twisted
25Requires: python-Twisted-ssl
26Requires: python-TwistedWords
27Requires: python-TwistedWeb
28Requires: python-TwistedXish
29Requires: python-Imaging
30Requires: python-pyOpenSSL
e697c636 31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35
36%description -l pl.UTF-8
37
38%prep
39%setup -q -n pymsnt-snapshot
40
e697c636 41%install
42rm -rf $RPM_BUILD_ROOT
43
4646aa2a 44install -d $RPM_BUILD_ROOT/{%{_datadir}/pymsnt/src/{twistfix/words/{xish/,protocols/jabber/},legacy/msn/,baseproto/},%{_var}/lib/pymsnt}
45install -d $RPM_BUILD_ROOT/%{_sysconfdir}/{jabber,init.d}
aeaf816d 46install -d $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
e697c636 47install src/twistfix/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/
48install src/twistfix/words/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/
49install src/twistfix/words/xish/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/xish/
50install src/twistfix/words/protocols/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/
51install src/twistfix/words/protocols/jabber/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
52install src/legacy/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/
53install src/legacy/msn/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/legacy/msn/
54install src/baseproto/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/baseproto/
55install src/*.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/src/
aeaf816d 56install data/* $RPM_BUILD_ROOT/%{_datadir}/pymsnt/data/
e697c636 57install PyMSNt.py $RPM_BUILD_ROOT/%{_datadir}/pymsnt/
58
4e2bf44f 59install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/jabber/PyMSNt.xml
60install %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/PyMSNt
4646aa2a 61
e697c636 62%clean
63rm -rf $RPM_BUILD_ROOT
64
63bf010c 65#ugly workaround (maybe fix in twisted words/xish package?)
66%post
67ln -s %{py_sitescriptdir}/twisted/words/ %{py_sitedir}/twisted/words
68ln -s %{py_sitescriptdir}/twisted/xish/ %{py_sitedir}/twisted/xish
69
4646aa2a 70if [ -f %{_sysconfdir}/jabber/secret ] ; then
71 SECRET=`cat %{_sysconfdir}/jabber/secret`
72 if [ -n "$SECRET" ] ; then
73 echo "Updating component authentication secret in PyMSNt.xml..."
74 %{__sed} -i -e "s/>secret</>$SECRET</" /etc/jabber/PyMSNt.xml
75 fi
76fi
4e2bf44f 77/sbin/chkconfig --add PyMSNt
78%service PyMSNt restart "Jabber MSN transport"
4646aa2a 79
80%preun
81if [ "$1" = "0" ]; then
4e2bf44f 82 %service PyMSNt stop
83 /sbin/chkconfig --del PyMSNt
4646aa2a 84fi
85
63bf010c 86%postun
aeaf816d 87echo "Cleaing ugly workaround (%{py_sitedir}/twisted/{words,xish})"
88rm -f %{py_sitedir}/twisted/words
89rm -f %{py_sitedir}/twisted/xish
63bf010c 90
e697c636 91%files
92%defattr(644,root,root,755)
93%doc README TODO docs
94%dir %{_datadir}/pymsnt/src/twistfix/
95%{_datadir}/pymsnt/src/twistfix/*.py
96%dir %{_datadir}/pymsnt/src/twistfix/words/
97%{_datadir}/pymsnt/src/twistfix/words/*.py
98%dir %{_datadir}/pymsnt/src/twistfix/words/xish/
99%{_datadir}/pymsnt/src/twistfix/words/xish/*.py
100%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/
101%{_datadir}/pymsnt/src/twistfix/words/protocols/*.py
102%dir %{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/
103%{_datadir}/pymsnt/src/twistfix/words/protocols/jabber/*.py
104%dir %{_datadir}/pymsnt/src/legacy/
105%{_datadir}/pymsnt/src/legacy/*.py
106%dir %{_datadir}/pymsnt/src/legacy/msn/
107%{_datadir}/pymsnt/src/legacy/msn/*.py
108%dir %{_datadir}/pymsnt/src/baseproto/
109%{_datadir}/pymsnt/src/baseproto/*.py
110%dir %{_datadir}/pymsnt/src
111%{_datadir}/pymsnt/src/*.py
aeaf816d 112%dir %{_datadir}/pymsnt/data/
113%{_datadir}/pymsnt/data/*
e697c636 114%dir %{_datadir}/pymsnt
aeaf816d 115%attr(755,root,root) %{_datadir}/pymsnt/*.py
4646aa2a 116%dir %{_var}/lib/pymsnt
4e2bf44f 117%dir %{_sysconfdir}/init.d/
aeaf816d 118%attr(755,root,root) %{_sysconfdir}/init.d/PyMSNt
4e2bf44f 119%dir %{_sysconfdir}/jabber/
8ba2f93e 120%attr(640,root,jabber) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/jabber/PyMSNt.xml
This page took 0.054251 seconds and 4 git commands to generate.