]> git.pld-linux.org Git - packages/PyAuthD.git/blob - PyAuthD.spec
- summaries, pl, BRs
[packages/PyAuthD.git] / PyAuthD.spec
1 %define snap    20070218
2 Summary:        PyAuthD - authentication daemon which implements a unified NSS/PAM infractructure
3 Summary(pl.UTF-8):      PyAuthD - demon uwierzytelniania implementujący jednolitą infrastrukturę NSS/PAM
4 Name:           PyAuthD
5 Version:        0.1
6 Release:        0.%{snap}.1
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        %{name}-%{snap}.tar.gz
10 # Source0-md5:  2b7d72bd6c75f0fa58707c25e398f87e
11 URL:            http://svn.asta.mh-hannover.de/categories/python/pyauthd/
12 BuildRequires:  pam-devel
13 BuildRequires:  python
14 BuildRequires:  rpm-pythonprov
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 PyAuthD is an authentication daemon which implements a unified NSS/PAM
19 infrastructure for creating virtual user accounts under Unix. It is
20 similar to the combination of {nss,pam}_ldap to authenticate against a
21 user database in LDAP, but is more extensible.
22
23 %description -l pl.UTF-8
24 PyAuthD to demon uwierzytelniania implementujący jednolitą
25 infrastrukturę NSS/PAM do tworzenia wirtualnych kont użytkowników pod
26 Uniksem. Jest podobny do kombinacji {nss,pam}_ldap przy
27 uwierzytelnianiu względem bazy użytkowników w LDAP, ale jest bardziej
28 rozszerzalny.
29
30 %prep
31 %setup -q -n %{name}
32
33 %build
34 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_client.o src/PyAuthD_client.c
35 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PAM.o src/PyAuthD_PAM.c
36 %{__cc} %{rpmldflags} -shared PyAuthD_client.o PyAuthD_PAM.o -o pam_PyAuthD.so -lpam
37
38 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_passwd.o src/PyAuthD_NSS_passwd.c
39 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_shadow.o src/PyAuthD_NSS_shadow.c
40 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_group.o src/PyAuthD_NSS_group.c
41 %{__cc} %{rpmldflags} -shared PyAuthD_NSS_passwd.o PyAuthD_NSS_shadow.o PyAuthD_NSS_group.o -o libnss_PyAuthD.so.2 -Wl,-soname -Wl,libnss_PyAuthD.so.2
42
43 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PPP.o src/PyAuthD_PPP.c
44 %{__cc} %{rpmldflags} -shared PyAuthD_PPP.o PyAuthD_client.o -o ppp_PyAuthD.so
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 python setup.py install \
50         --root=$RPM_BUILD_ROOT \
51         --optimize=2
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc *.html
59 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.087303 seconds and 3 git commands to generate.