]> git.pld-linux.org Git - packages/Producer.git/blob - Producer.spec
- use soname
[packages/Producer.git] / Producer.spec
1 %define fversion        %(echo %{version} | tr "r" "-" )
2 Summary:        Cross-platform libray for Opengl rendering
3 Name:           Producer
4 Version:        0.8.4r2
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.andesengineering.com/Producer/Download/%{name}-%{fversion}.tar.gz
9 # Source0-md5:  9e14c27a0e927a19bb3666fa73755652
10 Patch0:         %{name}-soname.patch
11 URL:            http://www.andesengineering.com/Producer/index.html
12 Provides:       OpenProducer = %{version}
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Open Producer (or simply Producer) is a cross-platform, C++ library
17 for managing OpenGL rendering contexts in a windowing system
18 independent manner. Producer provides a simple, yet powerfully
19 scalable approach for real-time 3D applications wishing to run within
20 a single window to large, multidisplay systems. Producer is highly
21 portable and has been tested on Linux, Windows, Mac OSX, Solaris and
22 IRIX. Producer works on all Unix based OS's (including Mac OSX)
23 through the X11 Windowing system, and through the native win32 on
24 Windows. Producer is written with productivity, performance and
25 scalability in mind by adhering to industry standard and employing
26 advanced software engineering practices. Software developers wishing
27 to produce 3D rendering software that can display on a desktop, and
28 move to a large system or clustered system of displays by simply
29 changing a configuration file, can depend on Open Producer to handle
30 all the complexity for them.
31
32 %package devel
33 Summary:        Devel files for Producent
34 Summary(pl):    Pliki developerskie dla Producer
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Devel files for Producent.
40
41 %prep
42 %setup -q -n %{name}
43 %patch0 -p0
44
45 find -type d -name CVS |xargs rm -rf
46
47 %build
48 %{__make} \
49         CXX="%{__cxx} %{rpmcflags} -fPIC -fpermissive"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} install \
54          INST_LOCATION=$RPM_BUILD_ROOT%{_prefix}
55 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_libdir}/lib*.so.*
63
64 %files devel
65 %defattr(644,root,root,755)
66 %doc README.txt doc
67 %{_includedir}/%{name}
68 %attr(755,root,root) %{_libdir}/lib*.so
This page took 0.052255 seconds and 3 git commands to generate.