]> git.pld-linux.org Git - packages/ParaView.git/blobdiff - ParaView.spec
- don't require vtk libs (it's internal)
[packages/ParaView.git] / ParaView.spec
index a3b9e7b78112349e3ff0edb96be2fbe9b22b9857..e643426bfaa511423c0824615d67c635d7c6158e 100644 (file)
@@ -1,7 +1,11 @@
+#
+# Conditional build:
+%bcond_with    system_protobuf         # build with system protobuf library
+#
 Summary:       Parallel visualization application
 Name:          ParaView
 Version:       4.0.1
-Release:       2
+Release:       12
 License:       BSD
 Group:         Applications/Engineering
 URL:           http://www.paraview.org/
@@ -14,6 +18,7 @@ Patch1:               %{name}-install.patch
 Patch2:                %{name}-system-Protobuf.patch
 Patch3:                %{name}-system-netcdf.patch
 Patch4:                disable-broken-tests.patch
+Patch5:                protobuf.patch
 BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: QtDesigner-devel
 BuildRequires: QtHelp-devel
@@ -28,6 +33,7 @@ BuildRequires:        desktop-file-utils
 BuildRequires: doxygen
 BuildRequires: expat-devel
 BuildRequires: freetype-devel
+BuildRequires: gl2ps-devel
 BuildRequires: gnuplot
 BuildRequires: graphviz
 BuildRequires: hdf5-devel
@@ -38,7 +44,7 @@ BuildRequires:        libtiff-devel
 BuildRequires: netcdf-devel
 BuildRequires: netcdf-cxx-devel
 BuildRequires: openssl-devel
-BuildRequires: protobuf-devel
+%{?with_system_protobuf:BuildRequires: protobuf-devel}
 BuildRequires: python-devel
 BuildRequires: qt4-build
 BuildRequires: readline-devel
@@ -53,6 +59,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                skip_post_check_so      lib.*Python.*\.so.*
 
+# avoid provide clash with vtk.spec
+%define                _noautoprov             libvtk.*\.so.* vtk.*\.so.*
+%define                _noautoreq              libvtk.*\.so.* vtk.*\.so.*
+
 %description
 ParaView is an application designed with the need to visualize large
 data sets in mind. The goals of the ParaView project include the
@@ -86,13 +96,18 @@ developing applications that use %{name}.
 %setup -q -n %{name}-v%{version}-source
 %patch0 -p0
 %patch1 -p1
-%patch2 -p1
 %patch3 -p0
 %patch4 -p1
+
+%if %{with system_protobuf}
+%patch2 -p1
+%patch5 -p1
 #Remove included thirdparty sources just to be sure
 for x in protobuf ; do
        rm -r ThirdParty/$x/vtk$x
 done
+%endif
+
 for x in expat freetype gl2ps hdf5 jpeg libxml2 netcdf oggtheora png sqlite tiff zlib ; do
        rm -r VTK/ThirdParty/$x/vtk$x
 done
@@ -128,6 +143,7 @@ cd build
        -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
        -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
        -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
+       -DFREETYPE_INCLUDE_DIRS=%{_includedir}/freetype2 \
        -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
        -DVTK_USE_SYSTEM_HDF5=ON \
        -DHDF5_HL_LIBRARY:FILEPATH=%{_libdir}/libhdf5_hl.so \
@@ -136,6 +152,7 @@ cd build
        -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
        -DVTK_USE_SYSTEM_LIBRARIES=ON \
        -DVTK_USE_SYSTEM_PNG:BOOL=ON \
+       -DVTK_USE_SYSTEM_PROTOBUF:BOOL=%{?with_system_protobuf:ON}%{!?with_system_protobuf:OFF} \
        -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
        -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
        -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
This page took 0.085837 seconds and 4 git commands to generate.