]> git.pld-linux.org Git - packages/ParaView.git/blobdiff - ParaView.spec
- release 3 (by relup.sh)
[packages/ParaView.git] / ParaView.spec
index 8d559d1067c42f65bacb9746a985c68779ddbbf6..b2e25f33875434b0942fc9cb7901a4ac379509b3 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       Parallel visualization application
 Name:          ParaView
 Version:       4.0.1
-Release:       2
+Release:       3
 License:       BSD
 Group:         Applications/Engineering
 URL:           http://www.paraview.org/
@@ -18,7 +18,7 @@ BuildRequires:        Mesa-libOSMesa-devel
 BuildRequires: QtDesigner-devel
 BuildRequires: QtHelp-devel
 BuildRequires: QtSql-devel
-BuildRequires: QtSql-sqlite
+BuildRequires: QtSql-sqlite3
 BuildRequires: QtUiTools-devel
 BuildRequires: QtXmlPatterns-devel
 BuildRequires: QtWebKit-devel
@@ -28,6 +28,7 @@ BuildRequires:        desktop-file-utils
 BuildRequires: doxygen
 BuildRequires: expat-devel
 BuildRequires: freetype-devel
+BuildRequires: gl2ps-devel
 BuildRequires: gnuplot
 BuildRequires: graphviz
 BuildRequires: hdf5-devel
@@ -47,6 +48,7 @@ BuildRequires:        wget
 BuildRequires: zlib-devel
 Requires(post):        desktop-file-utils
 Requires(postun):      desktop-file-utils
+Requires:      QtSql-sqlite3
 %requires_eq_to        hdf5 hdf5-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -57,10 +59,10 @@ ParaView is an application designed with the need to visualize large
 data sets in mind. The goals of the ParaView project include the
 following:
 
-    - Develop an open-source, multi-platform visualization application.
-    - Support distributed computation models to process large data sets.
-    - Create an open, flexible, and intuitive user interface.
-    - Develop an extensible architecture based on open standards.
+- Develop an open-source, multi-platform visualization application.
+- Support distributed computation models to process large data sets.
+- Create an open, flexible, and intuitive user interface.
+- Develop an extensible architecture based on open standards.
 
 ParaView runs on distributed and shared memory parallel as well as
 single processor systems and has been successfully tested on Windows,
@@ -72,12 +74,12 @@ of Tcl/Tk and C++.
 NOTE: The version in this package has NOT been compiled with MPI
 support.
 
-%package        devel
+%package devel
 Summary:       Development files for %{name}
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description    devel
+%description devel
 The %{name}-devel package contains libraries and header files for
 developing applications that use %{name}.
 
@@ -103,9 +105,9 @@ rm -rf build
 mkdir build
 cd build
 %cmake .. \
-        -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-        -DCMAKE_CXX_COMPILER:FILEPATH=%{__cxx} \
-        -DCMAKE_C_COMPILER:FILEPATH=%{__cc} \
+       -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+       -DCMAKE_CXX_COMPILER:FILEPATH=%{__cxx} \
+       -DCMAKE_C_COMPILER:FILEPATH=%{__cc} \
        -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
        -DPV_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
        -DTCL_LIBRARY:PATH=tcl \
@@ -116,11 +118,11 @@ cd build
        -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
        -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
        -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
-        -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
-        -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/paraview \
-        -DVTK_INSTALL_INCLUDE_DIR:PATH=include/paraview \
-        -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
-        -DVTK_INSTALL_PACKAGE_DIR=share/cmake/paraview \
+       -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
+       -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/paraview \
+       -DVTK_INSTALL_INCLUDE_DIR:PATH=include/paraview \
+       -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/paraview \
+       -DVTK_INSTALL_PACKAGE_DIR=share/cmake/paraview \
        -DVTK_USE_BOOST:BOOL=ON \
        -DVTK_USE_INFOVIS:BOOL=OFF \
        -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
@@ -129,7 +131,7 @@ cd build
        -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
        -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
        -DVTK_USE_SYSTEM_HDF5=ON \
-        -DHDF5_HL_LIBRARY:FILEPATH=%{_libdir}/libhdf5_hl.so \
+       -DHDF5_HL_LIBRARY:FILEPATH=%{_libdir}/libhdf5_hl.so \
        -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
        -DVTK_USE_SYSTEM_LIBPROJ4=OFF \
        -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
@@ -137,12 +139,12 @@ cd build
        -DVTK_USE_SYSTEM_PNG:BOOL=ON \
        -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
        -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
-        -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
-        -DVTK_USE_INFOVIS:BOOL=OFF \
-        -DVTK_USE_SYSTEM_ICET=OFF \
-        -DVTK_USE_SYSTEM_NETCDF=ON \
-        -DVTK_USE_SYSTEM_QTTESTING=OFF \
-        -DVTK_USE_SYSTEM_XDMF2=OFF \
+       -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
+       -DVTK_USE_INFOVIS:BOOL=OFF \
+       -DVTK_USE_SYSTEM_ICET=OFF \
+       -DVTK_USE_SYSTEM_NETCDF=ON \
+       -DVTK_USE_SYSTEM_QTTESTING=OFF \
+       -DVTK_USE_SYSTEM_XDMF2=OFF \
        -DXDMF_WRAP_PYTHON:BOOL=ON \
        -DBUILD_DOCUMENTATION:BOOL=ON \
        -DBUILD_EXAMPLES:BOOL=ON
This page took 0.156209 seconds and 4 git commands to generate.