]> git.pld-linux.org Git - packages/PPerl.git/blob - PPerl.spec
b9a200a6723da485b8a5b233acc9fba863b5eb63
[packages/PPerl.git] / PPerl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (one test fails)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        A persistent Perl interpreter system, designed to speed up Perl scripts
7 Summary(pl):    Trwa³y system interpretera Perla s³u¿±cy do przyspieszenia skryptów
8 Name:           PPerl
9 Version:        0.25
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/%{name}-%{version}.tar.gz
15 # Source0-md5:  32c94d7154494e292241a3d629eed4ea
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 PPerl provides a persistent environment for Perl scripts. It makes
22 converting a useful old script into a persistent daemon process a
23 breeze.
24
25 Simply change your shebang line to "#!/usr/bin/pperl", rather than
26 "perl", and you'll find your old slow scripts that take ages to start
27 up, running like they were brand spanking new again. Well, that's the
28 plan at least!
29
30 %description -l pl
31 PPerl dostarcza trwa³e ¶rodowisko dla skryptów perlowych. Znacznie
32 u³atwia zamianê starego, przydatnego skryptu na stale dzia³aj±cego
33 demona.
34
35 Wystarczy zmieniæ pierwsz± liniê na "#!/usr/bin/pperl" zamiast "perl",
36 a stare, wolne skrypty, wcze¶niej potrzebuj±ce wieków na uruchomienie,
37 zaczn± dzia³aæ jakby znowu by³y nowe. A przynajmniej taki jest plan.
38
39 %prep
40 %setup -q
41
42 %build
43 %{__perl} Makefile.PL \
44         PERL_PATH=%{__perl} \
45         INSTALLDIRS=vendor
46 %{__make} \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_examplesdir}
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README TODO examples
66 %attr(755,root,root) %{_bindir}/pperl
67 %{perl_vendorarch}/%{name}.pm
68 %dir %{perl_vendorarch}/auto/%{name}
69 %{perl_vendorarch}/auto/%{name}/%{name}.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
71 %{_mandir}/man1/*
72 %{_mandir}/man3/*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.050055 seconds and 2 git commands to generate.