]> git.pld-linux.org Git - packages/OpenThreads.git/blob - OpenThreads.spec
- tabs in preamble
[packages/OpenThreads.git] / OpenThreads.spec
1 Summary:        A minimal & complete Object-Oriented (OO) thread interface
2 Summary(pl.UTF-8):      Minimalny ale kompletny interfejs wątków w programowaniu OO
3 Name:           OpenThreads
4 Version:        1.3
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/openscenegraph/%{name}-%{version}.tar.gz
9 # Source0-md5:  a1d792ae4ce38590ff498e0c7d9ad939
10 Source1:        %{name}.pc
11 Patch0:         %{name}-soname.patch
12 URL:            http://openthreads.sourceforge.net/
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This library is intended to provide a minimal & complete
18 Object-Oriented (OO) thread interface for C++ programmers. It is
19 loosely modeled on the Java thread API, and the POSIX Threads
20 standards.
21
22 %description -l pl.UTF-8
23 Biblioteka jest przeznaczona do udostępniania minimalnego ale pełnego
24 interfejsu obiektowo zorientowanych (OO) wątków dla programistów C++.
25 Bazuje na modelu API wątków w Javie oraz na standardzie wątków POSIX.
26
27 %package devel
28 Summary:        OpenThreads devel files
29 Summary(pl.UTF-8):      Biblioteki programistyczne OpenThreads
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libstdc++-devel
33
34 %description devel
35 OpenThreads devel files.
36
37 %description devel -l pl.UTF-8
38 Biblioteki programistyczne OpenThreads.
39
40 %prep
41 %setup -q -n %{name}
42 %patch0 -p0
43
44 %build
45 %{__make} \
46         CXX="%{__cxx} %{rpmcflags} -fPIC"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         INST_LOCATION=$RPM_BUILD_ROOT%{_prefix} \
53         INST_LIBS=$RPM_BUILD_ROOT%{_libdir}
54
55 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
56
57 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
58 sed -e 's,^libdir=.*,libdir=%{_libdir},' %{SOURCE1} >$RPM_BUILD_ROOT%{_pkgconfigdir}/openthreads.pc
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*
69
70 %files devel
71 %defattr(644,root,root,755)
72 %doc AUTHORS.txt ChangeLog README.txt TODO.txt
73 %attr(755,root,root) %{_libdir}/lib%{name}.so
74 %{_includedir}/%{name}
75 %{_pkgconfigdir}/openthreads.pc
This page took 0.035009 seconds and 4 git commands to generate.