]> git.pld-linux.org Git - packages/OpenIPMI.git/blob - OpenIPMI.spec
8ea222284905b833f35729098f92b0c4faba6d19
[packages/OpenIPMI.git] / OpenIPMI.spec
1 # TODO
2 # - bad BR (version mismatch):
3 #  File "_mc_user.py", line 240, in ?
4 #    class MCUsers(gui_treelist.TreeList): AttributeError: 'module' object has no attribute 'TreeList'
5 #  make[4]: *** [_entity.pyc] Error 1
6 #
7 # Conditional build:
8 %bcond_without  gui     # don't build tkinter-based GUI
9 #
10 Summary:        IPMI abstraction layer
11 Summary(pl):    Warstwa abstrakcji IPMI
12 Name:           OpenIPMI
13 Version:        2.0.10
14 Release:        1
15 License:        LGPL (library), GPL (ipmicmd)
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
18 # Source0-md5:  8f5c200c5f25c33250567eaeb685e8c0
19 Patch0:         %{name}-link.patch
20 Patch1:         %{name}-python.patch
21 URL:            http://openipmi.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gcc >= 5:3.2
25 BuildRequires:  gdbm-devel
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  libtool >= 1:1.4.2-9
28 BuildRequires:  ncurses-devel
29 BuildRequires:  net-snmp-devel
30 BuildRequires:  perl-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  popt-devel
33 BuildRequires:  python-devel
34 %{?with_gui:BuildRequires:      python-tkinter}
35 BuildRequires:  tcl-devel
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  swig-perl >= 1.3.25
38 BuildRequires:  swig-python >= 1.3.25
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 OpenIPMI project aims to develop an open code base to allow access to
43 platform information using Intelligent Platform Management Interface
44 (IPMI).
45
46 %description -l pl
47 Celem projektu OpenIPMI jest stworzenie otwartej podstawy kodu
48 pozwalaj±cego na dostêp do informacji o platformie pzy u¿yciu
49 interfejsu IPMI (Intelligent Platform Management Interface -
50 interfejsu inteligentnego zarz±dzania platform±)
51
52 %package devel
53 Summary:        Development part of OpenIPMI Toolkit libraries
54 Summary(pl):    Programistyczna cze¶æ bibliotek OpenIPMI
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Development part of OpenIPMI libraries.
60
61 %description devel -l pl
62 Programistyczna cze¶æ bibliotek OpenIPMI.
63
64 %package static
65 Summary:        Static OpenIPMI libraries
66 Summary(pl):    Statyczne biblioteki OpenIPMI
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static OpenIPMI Toolkit libraries.
72
73 %description static -l pl
74 Statyczne biblioteki OpenIPMI.
75
76 %package -n perl-%{name}
77 Summary:        Perl interface to OpenIPMI
78 Summary(pl):    Perlowy interfejs do OpenIPMI
79 Group:          Development/Languages/Perl
80 Requires:       %{name} = %{version}-%{release}
81
82 %description -n perl-%{name}
83 Perl interface to OpenIPMI.
84
85 %description -n perl-%{name} -l pl
86 Perlowy interfejs do OpenIPMI.
87
88 %package -n python-%{name}
89 Summary:        Python interface to OpenIPMI
90 Summary(pl):    Pythonowy interfejs do OpenIPMI
91 Group:          Development/Languages/Python
92 Requires:       %{name} = %{version}-%{release}
93 %pyrequires_eq  python-libs
94
95 %description -n python-%{name}
96 Python interface to OpenIPMI.
97
98 %description -n perl-%{name} -l pl
99 Pythonowy interfejs do OpenIPMI.
100
101 %package gui
102 Summary:        OpenIPMI GUI
103 Summary(pl):    Graficzny interfejs u¿ytkownika do OpenIPMI
104 Group:          X11/Applications
105 Requires:       python-%{name} = %{version}-%{release}
106 Requires:       python-tkinter
107
108 %description gui
109 OpenIPMI GUI.
110
111 %description gui -l pl
112 Graficzny interfejs u¿ytkownika do OpenIPMI.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %patch1 -p1
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__automake}
124 CPPFLAGS="-I/usr/include/ncurses"
125 %configure \
126         --without-glib12 \
127         %{!?with_gui:--without-tkinter}
128 %{__make} \
129         PYTHON_INSTALL_DIR=%{py_sitedir}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install -j1 \
135         DESTDIR=$RPM_BUILD_ROOT \
136         PYTHON_INSTALL_DIR=%{py_sitedir}
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a} \
139         $RPM_BUILD_ROOT%{py_sitedir}/openipmigui/*.py
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ChangeLog FAQ README* TODO
150 %attr(755,root,root) %{_bindir}/ipmi*
151 %attr(755,root,root) %{_bindir}/openipmicmd
152 %attr(755,root,root) %{_bindir}/openipmish
153 %attr(755,root,root) %{_bindir}/rmcp_ping
154 %attr(755,root,root) %{_bindir}/solterm
155 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
156 %{_mandir}/man[178]/*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/lib*.so
161 %{_libdir}/*.la
162 %{_includedir}/%{name}
163 %{_pkgconfigdir}/*.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/lib*.a
168
169 %files -n perl-%{name}
170 %defattr(644,root,root,755)
171 %{perl_vendorarch}/OpenIPMI.pm
172 %dir %{perl_vendorarch}/auto/OpenIPMI
173 %attr(755,root,root) %{perl_vendorarch}/auto/OpenIPMI/OpenIPMI.so
174
175 %files -n python-%{name}
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{py_sitedir}/_OpenIPMI.so
178 %{py_sitedir}/OpenIPMI.py[co]
179
180 %if %{with gui}
181 %files gui
182 %defattr(644,root,root,755)
183 %doc swig/python/openipmigui/TODO
184 %attr(755,root,root) %{_bindir}/openipmigui
185 %dir %{py_sitedir}/openipmigui
186 %{py_sitedir}/openipmigui/*.py[co]
187 %endif
This page took 0.062167 seconds and 2 git commands to generate.