]> git.pld-linux.org Git - packages/OpenIPMI.git/blob - OpenIPMI.spec
- updated to 2.0.8
[packages/OpenIPMI.git] / OpenIPMI.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build tkinter-based GUI
4 #
5 Summary:        IPMI abstraction layer
6 Summary(pl):    Warstwa abstrakcji IPMI
7 Name:           OpenIPMI
8 Version:        2.0.8
9 Release:        1
10 License:        LGPL (library), GPL (ipmicmd)
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13 # Source0-md5:  3bfc9c232ef0d4ccc3c4355e17ba79d5
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-python.patch
16 URL:            http://openipmi.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gcc >= 5:3.2
20 BuildRequires:  gdbm-devel
21 BuildRequires:  glib2-devel >= 2.0
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  ncurses-devel
24 BuildRequires:  net-snmp-devel
25 BuildRequires:  perl-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRequires:  python-devel
29 %{?with_gui:BuildRequires:      python-tkinter}
30 BuildRequires:  tcl-devel
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  swig-perl >= 1.3.25
33 BuildRequires:  swig-python >= 1.3.25
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 OpenIPMI project aims to develop an open code base to allow access to
38 platform information using Intelligent Platform Management Interface
39 (IPMI).
40
41 %description -l pl
42 Celem projektu OpenIPMI jest stworzenie otwartej podstawy kodu
43 pozwalaj±cego na dostêp do informacji o platformie pzy u¿yciu
44 interfejsu IPMI (Intelligent Platform Management Interface -
45 interfejsu inteligentnego zarz±dzania platform±)
46
47 %package devel
48 Summary:        Development part of OpenIPMI Toolkit libraries
49 Summary(pl):    Programistyczna cze¶æ bibliotek OpenIPMI
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Development part of OpenIPMI libraries.
55
56 %description devel -l pl
57 Programistyczna cze¶æ bibliotek OpenIPMI.
58
59 %package static
60 Summary:        Static OpenIPMI libraries
61 Summary(pl):    Statyczne biblioteki OpenIPMI
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static OpenIPMI Toolkit libraries.
67
68 %description static -l pl
69 Statyczne biblioteki OpenIPMI.
70
71 %package -n perl-%{name}
72 Summary:        Perl interface to OpenIPMI
73 Summary(pl):    Perlowy interfejs do OpenIPMI
74 Group:          Development/Languages/Perl
75 Requires:       %{name} = %{version}-%{release}
76
77 %description -n perl-%{name}
78 Perl interface to OpenIPMI.
79
80 %description -n perl-%{name} -l pl
81 Perlowy interfejs do OpenIPMI.
82
83 %package -n python-%{name}
84 Summary:        Python interface to OpenIPMI
85 Summary(pl):    Pythonowy interfejs do OpenIPMI
86 Group:          Development/Languages/Python
87 Requires:       %{name} = %{version}-%{release}
88 %pyrequires_eq  python-libs
89
90 %description -n python-%{name}
91 Python interface to OpenIPMI.
92
93 %description -n perl-%{name} -l pl
94 Pythonowy interfejs do OpenIPMI.
95
96 %package gui
97 Summary:        OpenIPMI GUI
98 Summary(pl):    Graficzny interfejs u¿ytkownika do OpenIPMI
99 Group:          X11/Applications
100 Requires:       python-%{name} = %{version}-%{release}
101 Requires:       python-tkinter
102
103 %description gui
104 OpenIPMI GUI.
105
106 %description gui -l pl
107 Graficzny interfejs u¿ytkownika do OpenIPMI.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__automake}
119 CPPFLAGS="-I/usr/include/ncurses"
120 %configure \
121         --without-glib12 \
122         %{!?with_gui:--without-tkinter}
123 %{__make} \
124         PYTHON_INSTALL_DIR=%{py_sitedir}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install -j1 \
130         DESTDIR=$RPM_BUILD_ROOT \
131         PYTHON_INSTALL_DIR=%{py_sitedir}
132
133 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a} \
134         $RPM_BUILD_ROOT%{py_sitedir}/openipmigui/*.py
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc ChangeLog FAQ README* TODO
145 %attr(755,root,root) %{_bindir}/ipmi*
146 %attr(755,root,root) %{_bindir}/openipmicmd
147 %attr(755,root,root) %{_bindir}/openipmish
148 %attr(755,root,root) %{_bindir}/rmcp_ping
149 %attr(755,root,root) %{_bindir}/solterm
150 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
151 %{_mandir}/man[178]/*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/lib*.so
156 %{_libdir}/*.la
157 %{_includedir}/%{name}
158 %{_pkgconfigdir}/*.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163
164 %files -n perl-%{name}
165 %defattr(644,root,root,755)
166 %{perl_vendorarch}/OpenIPMI.pm
167 %dir %{perl_vendorarch}/auto/OpenIPMI
168 %attr(755,root,root) %{perl_vendorarch}/auto/OpenIPMI/OpenIPMI.so
169
170 %files -n python-%{name}
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{py_sitedir}/_OpenIPMI.so
173 %{py_sitedir}/OpenIPMI.py[co]
174
175 %if %{with gui}
176 %files gui
177 %defattr(644,root,root,755)
178 %doc swig/python/openipmigui/TODO
179 %attr(755,root,root) %{_bindir}/openipmigui
180 %dir %{py_sitedir}/openipmigui
181 %{py_sitedir}/openipmigui/*.py[co]
182 %endif
This page took 0.127937 seconds and 3 git commands to generate.